Anda di halaman 1dari 3

25/01/12

Contar nmeros o datos basados en una prueba - Excel - Office.com

Contar n meros o datos basados en una prueba


Corresponde a: Microsoft Excel 2010, Excel 2007, Excel 2003

Soporte / Excel / Ayuda y procedimientos de Excel 2010 / Frmulas / Crear frmulas

Para contar nmeros o fechas que cumplen una sola prueba (como igual a, mayor que, menor que, mayor o igual que o

Mostrar todo

menor o igual que), use la funcin CONTAR.SI. En Excel 2007 y en una versin posterior, para contar nombres o fechas que estn dentro de un rango (como mayor que 9.000 y al mismo tiempo menor que 22.500), puede usar la funcin CONTAR.SI.CONJUNTO. Si usa Excel 2003 o una versin anterior, puede usar la funcin SUMAPRODUCTO para contar los nmeros que estn dentro de un rango (CONTAR.SI.CONJUNTO se introdujo en Excel 2007).

EJEMPLO
Es ms fcil comprender el ejemplo si lo copia en una hoja de clculo en blanco. Cmo copiar un ejemplo Para cambiar entre ver los resultados y las frmulas que devuelven los resultados, presione Alt+ (ordinal masculino) o bien, en la ficha F rmulas, en el grupo Auditora de f rmulas, haga clic en el botn Mostrar f rmulas.
A 1 2 3 4 5 6 7 8 9 =CONTAR.SI(B2:B7,">9000") Vendedor Buchanan Buchanan Suyama Suyama Buchanan Dodsw orth F rm ula B Factura 15.000 9.000 8.000 20.000 5.000 22.500 Descripci n (resultado) La funcin CONTAR.SI cuenta el nmero de celdas en el rango B2:B7 que contiene nmeros mayores que 9.000 (4) La funcin CONTAR.SI cuenta el nmero de celdas en el rango B2:B7 que contiene nmeros menores que 9.000 9000 (4) La funcin CONTAR.SI.CONJUNTO (disponible en Excel 2007 y versiones posteriores) cuenta el el nmero de celdas en el rango B2:B7 mayores o iguales que 9.000 y menores o iguales que 22.500 (4) =SUMAPRODUCTO((B2:B7>=9.000)*(B2:B7<=22.500)) La funcin SUMAPRODUCTO cuenta los nmeros de celdas en el rango B2:B7 que contienen nmeros mayores o iguales que 9.000 y menores o iguales que 22.500 (4). Puede usar esta funcin en Excel

10 =CONTAR.SI(B2:B7,"<=9000")

11 =CONTAR.SI.CONJUNTO(B2:B7,">=9.000",B2:B7," <=22.500")

12

microsoft.com/

/contar-numeros-o-datos-basados-en-una-prueba-HP0

1/3

25/01/12

Contar nmeros o datos basados en una prueba - Excel - Office.com


13 14 15 16 17 Fecha 3/11/2011 1/1/2010 12/31/2010 6/30/2010 F rm ula =CONTAR.SI(B14:B17,">1/3/2010")

esta funcin en Excel 2003 y en una versin anterior, en que CONTAR.SI.CONJUNTO no est disponible.

Descripci n (resultado) Cuenta el nmero de celdas en el rango B14:B17 con una fecha mayor que 1/3/2010 (3) Cuenta el nmero de celdas en el rango B14:B17 igual a 31/12/2010 (1). El signo igual no es necesario en el criterio, por lo que no se incluye aqu (la frmula funcionar con un signo igual si lo incluye ("=31/12/2010"). Cuenta el nmero de celdas en el rango B14:B17 que est entre (ambos inclusive) 1/1/2010 y 31/12/2010 (3). Cuenta el nmero de celdas en el rango B14:B17 que est entre (ambos inclusive) 1/1/2010 y 31/12/2010 (3). Este ejemplo sirve de sustituto de la funcin CONTAR.SI.CONJUNTO que se introdujo en Excel 2007. La funcin VALFECHA convierte las fechas en un valor nmero con el que puede trabajar la funcin SUMAPRODUCTO.

=CONTAR.SI(B14:B17,"31/12/2010")

=CONTAR.SI.CONJUNTO(B14:B17,">=1/1/2010",B14:B17," <=31/12/2010")

=SUMAPRODUCTO((B14:B17>=VALFECHA("1/1/2010"))* (B14:B17<=VALFECHA("31/12/2010")))

Detalles de la funci n
La funcin CONTAR.SI cuenta el nmero de celdas dentro de un rango que cumplen un solo criterio (condicin) que especifique. =CONTAR.SI(rango, criterios) La funcin CONTAR.SI.CONJUNTO se aplica a varios criterios de celdas en varios rangos y, a continuacin, cuenta el nmero de veces que se cumplen todos los criterios. Puede usar esta funcin para encontrar varios criterios en el mismo rango, los mismos criterios en varios rangos o varios criterios en varios rangos. =CONTAR.SI.CONJUNTO(criterios_rango1, criterios1, criterios_rango2, criterios2, ) En el ejemplo de CONTAR.SI.CONJUNTO, criterios_rango1 es B2:B7, criterios1 es ">=9.000", criterios_rango2 es de nuevo B2:B7 y criterios2 es "<=22.500". El mismo rango de nmeros se prueba dos veces pero tambin puede probar un

microsoft.com/

/contar-numeros-o-datos-basados-en-una-prueba-HP0

2/3

25/01/12

Contar nmeros o datos basados en una prueba - Excel - Office.com


n mero de rangos distintos con diferentes criterios para cada uno. La funcin SUMAPRODUCTO, tal como se muestra en el ejemplo, se puede usar en Excel 2003 y versiones anteriores, en que no est disponible CONTAR.SI.CONJUNTO. En el ejemplo de SUMAPRODUCTO,, B2:B7>=9.000 act a como el par criterios_rango1 y criterios1 y B2:B7<=22.500 act a como el par criterios_rango2 y criterios2 que se usan en el ejemplo de CONTAR.SI.CONJUNTO. Para obtener ms informacin, vea Funcin CONTAR.SI, Funcin CONTAR.SI.CONJUNTO y Funcin SUMAPRODUCTO.

2012 Microsoft Corporation. Reservados todos los derechos.

microsoft.com/

/contar-numeros-o-datos-basados-en-una-prueba-HP0

3/3