Anda di halaman 1dari 37
Instituto Superior de Transportes e Comunicação

Instituto Superior de Transportes e Comunicação

 

Departamento de Tecnologias de Informação e Comunicação Licenciatura em Engenharia Informática e de Comunicação Redes Digitais

 

4º Ano Trabalho Prático

Tema:

Projeção de uma rede interligando duas filiais com um circuito de 2Mbps

Turma: I41

Discentes:

Anselmo Félix

Grácio Mambo

Ivan Emílio

Yuri Wingester

Docente: Eng.º Aníbal Faiane

 

Maputo, Maio de 2012

   

Índice:

1.

Introdução

.................................................................................................................................................

3

2.

Objectivos

.................................................................................................................................................

4

  • 2.1 Objectivo geral: ...................................................................................................................................

4

  • 2.2 Objectivos específicos:

.......................................................................................................................

4

  • 3. Quantização de um sinal

...........................................................................................................................

5

  • 4. Tipos de quantização

.................................................................................................................................

5

  • 4.1 Quantização Uniforme

.........................................................................

Error! Bookmark not defined.

  • 4.1.1 Vantagens e desvantagens de uma quantização uniforme

............

Error! Bookmark not defined.

  • 4.2 Quantização não uniforme

...................................................................

Error! Bookmark not defined.

  • 4.2.1 Vantagens e desvantagens de uma quantização não uniforme

......

Error! Bookmark not defined.

  • 4.3 Quantização Logarítmica

.....................................................................

Error! Bookmark not defined.

  • 4.4 Quantização

Vectorial ..........................................................................

Error! Bookmark not defined.

  • 5. Erro de quantização

....................................................................................

Error! Bookmark not defined.

  • 6. Relação Sinal Ruído ...................................................................................

Error! Bookmark not defined.

  • 7. Leis de compressão

....................................................................................

Error! Bookmark not defined.

Índice: 1. Introdução ................................................................................................................................................. 3 2. Objectivos ................................................................................................................................................. 4 2.1 Objectivo geral: ................................................................................................................................... 4 2.2 Objectivos
  • 7.1 Compressor pela lei :

.....................................................................

Error! Bookmark not defined.

7.2

Compressor pela lei A

..........................................................................

Error!

Bookmark not defined.

  • 7.2.1 Características básicas que representam a lei A:

...........................

Error! Bookmark not defined.

  • 8. Largura de banda necessária para se fazer a quantização

..........................

Error! Bookmark not defined.

  • 9. Conclusão

...................................................................................................

Error! Bookmark not defined.

10. Referências Bibliográficas

.......................................................................

Error! Bookmark not defined.

1. Introdução

A necessidade do envio de informações de forma ágil pelo ser humano pode ser observada através dos tempos, pela história das civilizações. Desde a comunicação entre os povos, realizada por meios visuais e sonoros para distâncias curtas, passando pela utilização de sua energia ou a dos animais para médios trechos, até os dias atuais utilizando as telecomunicações para abrangências intercontinentais, o homem busca incansavelmente soluções alternativas para melhorar a eficácia de suas comunicações. A criatividade aliada ao desafio da superação, sempre esteve presente na evolução do ser humano através de grandes exemplos para as comunicações sem o auxílio dos fios, tais como o desenvolvimento de códigos básicos pré-estabelecidos feitos pelos índios da América do Norte, que enviavam sinais de fumaça, ou de povos na savana africana, através de tambores, contando inclusive com postos de retransmissão. A era das comunicações sem fio actual iniciou-se no século XIX, mais precisamente em 1831, com a descoberta realizada pelo físico-químico inglês Michael Faraday, que efectuou inúmeros estudos sobre electricidade e magnetismo, descobrindo o fenómeno da indução magnética que, em linhas gerais, explica porque uma corrente eléctrica variável ao circular em uma bobina induz uma corrente eléctrica variável em outra bobina, mesmo que as duas bobinas não estejam directamente conectadas. A partir daí, o notável físico escocês James Clerk Maxwell em 1865, demonstrou através de postulados, a teoria sobre a existência e a propagação das ondas electromagnéticas a unificação dos fenómenos interligados entre o magnetismo e a electricidade. Esta teoria se resumiu em quatro elegantes equações, que regem de modo geral o comportamento das ondas electromagnéticas. A confirmação experimental do uso destas notórias Equações de Maxwell somente foi realizada na prática em 1888 pelo físico alemão Heinrich Rudolf Hertz. A partir destes experimentos e aliada à descoberta alguns anos antes do telégrafo em 1844 pelo pintor americano Samuel Morse, e do telefone pelo cientista escocês Alexander Graham Bell em 1876, vários cientistas motivaram-se a enviar mensagens a distância. Após tais eventos, o mundo não deixou mais de presenciar inovações tecnológicas nas telecomunicações sem fio, algumas impulsionadas infelizmente por guerras, mas que trouxeram ao homem moderno a mobilidade e a confiabilidade de que necessita para enfrentar a exigência do mundo corporativo e a comodidade da vida quotidiana. A Internet foi o último grande baluarte na história contemporânea das telecomunicações e actualmente nota-se que o crescimento do acesso à mesma pelas pessoas físicas e jurídicas através da banda larga observado nos últimos anos, também contribuiu para o aumento nos meios do acesso sem fio em alta velocidade. Além das tecnologias já consolidadas para tal, como o ADSL e o Cable Modem, os sistemas Wireless deram a sua contribuição, através do acesso ponto-a-ponto para a constituição de redes básicas de transmissão ou o ponto-multiponto, fornecido por empresas provedoras de acesso que se utilizam da tecnologia Spread Spectrum aplicada ao protocolo IEEE 802.11 e regulamentada pela ANATEL, que apesar de não exigir licenciamento desta exploração junto aos seus assinantes, monitora a potência máxima permitida.

O presente trabalho visa apresentar uma rede que interligam duas instituições (para o caso de estudo ISUTC e ITC) através de um circuito de 2Mbps. A metodologia utilizada para o desenvolvimento deste trabalho contemplou a pesquisa de natureza qualitativa, por meio do levantamento bibliográfico baseado na literatura específica, a fim de buscar em materiais já publicados, documentos que ajudassem a responder as questões levantadas na problemática do tema em estudo e a pesquisa exploratória através da análise de um caso real.

Para atingirem-se os resultados pretendidos, o presente trabalho foi então subdividido como se segue:

  • 1. Inicialmente é apresentado um histórico da evolução dos sistemas de rede de computadores. O objectivo é o de posicionar o leitor e ao mesmo tempo fornecer uma síntese do cenário actual.

  • 2. Na parte intermediária do trabalho fala-se sobre como foi feita a projecção da rede entre as duas filiais ilustrando à partir do simulador packet tracer 5.3.3.

  • 3. Encerrando o trabalho, serão mostrados a execução de certos comandos que comprovam o bom funcionamento da rede.

2. Objectivos

Este trabalho tem como objectivos:

  • 2.1 Objectivo geral:

Projectar uma rede interligando duas instituições através de um circuito de 2Mbps.

  • 2.2 Objectivos específicos:

    • Configurar os respectivos roteadores;

    • Configurar os servidores (DNS,DHC e E-MAIL);

    • Dimensionar a rede (acesso a WAN, acesso a Ethernet, tecnologia de comunicação a Internet, mecanismo de gestão dos endereços públicos a Internet e determinar o software de gestão da rede).

3.

Redes de Computadores

Basicamente uma rede trabalho é um sistema que permite a comunicação entre pontos distintos, ou seja, um sistema que permite a troca de informações. Os componentes básicos de uma rede de trabalho (ou rede de informações) são um emissor (origem de informação), o meio através da qual a informação trafega (o canal), um receptor (o destino da informação) e finalmente a mensagem, que nada mais é do que a informação em si. As redes de computadores são compostas por meios físicos e lógicos através dos quais é possível trocar dados e compartilhar recursos entre máquinas. As redes tornaram possível a implementação dos sistemas distribuídos de computação. Os sistemas distribuídos usam a rede para trocar dados e informações de controlo e são capazes de prover serviços mais flexíveis do que os sistemas centralizados de computação. Segundo Torres (2001), as redes surgiram da necessidade da troca de informações, onde é possível ter acesso a um dado que está fisicamente localizado distante de você, como no exemplo de uma caixa electrónico, onde você pode estar tendo acesso aos dados de sua conta corrente que estão armazenados em um computador a centena ou milhares de quilómetros de distância.

  • 4. Rede de interligando duas instituições através de um circuito de 2Mbps

Como já foi citado na introdução do presente trabalho que tem como objectivo principal desenvolver uma rede interligando duas instituições (ISUTC-ITC), na figura a seguir e ilustrada a rede desenvolvida pelo grupo que e constituída por quatro roteadores que tem com função para o caso do primeiro fazer roteamento de pacotes para o ISUTC, o segundo fazer o roteamento de pacotes para o ITC, o terceiro roteador que funciona como ISP e o ultimo que funciona como a internet.

3. Redes de Computadores Basicamente uma rede trabalho é um sistema que permite a comunicação entre

4. 1. Configuração dos roteadores

Na configuração dos roteadores foi feita a divisao em dois tópicos: A configuração da rede WAN, ou seja, a configuração da sua conexão com a internet e a configuração da rede LAN, que é a configuração necessária para que a conexão seja distribuida entre os computadores. Nos roteadores de um modo geral foram configurados os passwords enable secret assim com o enable password que é o nome dos roteadores (neste caso o roteador do isutc tem como as passwordes ensble secret assim como enable password isutc,o mesmo para o roteador do itc, isp e internet), foram configurados também os passwords da linha de consola 0 (line consolo 0) assim como o password de acesso remoto (line vty 0 4) que são respectivamente iguais aos passwordes do enable. Configurou-se também os protocolos de roteamento rip e ospf .

Roteadores

Localização : Maputo

Nome do Roteador : Isutc

Interface

Propósito

DCE/DTE

Clock

Nome da

Número

IP da

Mascara de

e

Rate

rede

de rede

interface

sub-rede

descrição

Serial 0/0

Ligação

DTE

-

WAN

-

-

-

ao ISP

Serial

Ligação

DTE

-

WAN

172.20.1.4

172.20.1.6

255.255.255.252

0/0.201

ao ISP

Serial

Ligação

DTE

-

WAN

172.20.2.4

172.20.2.5

255.255.255.252

0/0.203

ao ISP

FastEthernet

Ligação a

-

-

LAN-

192.168.10

192.168.1.1

255.255.255.0

0/0

rede local

ISUTC

Localização : Maputo

Nome do Roteador : ITC

Interface

Propósito

DCE/DTE

Clock

Nome da

Número de

IP da

Mascara de sub-

e

Rate

rede

rede

interface

rede

descrição

Serial 0/0

Ligação

DTE

-

WAN

-

-

-

ao ISP

Serial

Ligação

DTE

-

WAN

172.20.3.4

172.20.3.5

255.255.255.252

0/0.301

ao ISP

Serial

Ligação

DTE

-

WAN

172.20.2.4

172.20.2.6

255.255.255.252

0/0.302

ao ISP

FastEthernet

Ligação a

-

-

LAN-ITC

193.168.10

193.168.1.1

255.255.255.0

0/0

rede local

Localização : Maputo

 

Nome do Roteador : ISP

 

Interface

Propósito

 

DCE/DTE

 

Clock

 

Nome da

 

Número

 

IP da

Mascara de

 
 

e

 

Rate

rede

de rede

interface

sub-rede

descrição

       

Serial 0/0

Acesso a

 

-

 
  • - WAN

   

-

 

-

-

internet e

       

circuito

dedicado

Serial

 

 

DTE

 
  • - WAN

   

172.20.1.4

 

172.20.1.5

255.255.255.252

0/0.102

         

Serial

 

 

DTE

 
  • - WAN

   

172.20.3.4

 

172.20.3.6

255.255.255.252

0/0.103

         

Serial 0/1

 

 

DTE

 
  • - WAN

   

205.0.0.0

 

205.0.0.2

255.255.255.252

Localização: Maputo

Nome do Roteador: Net

Interface

Propósito

DCE/DTE

Clock

Nome

Número de

IP da

Mascara de

e

Rate

da rede

rede

interface

sub-rede

descrição

FastEthernet

Ligação a

-

-

Internet

200.213.1.0

200.213.1.1

255.255.255.0

0/0

internet

Serial 0/0

Ligação

DCE

56000

Internet

205.0.0.0

205.0.0.1

255.255.255.252

ao

provedor

Protocolos de Roteamento RIP e OSPF

Os protocolo de roteamento tem como objectivo garantir a comunicação entre todas as redes com um alto grau de confiabilidade, contendo consigo as informações parciais que permitam o tráfego de pacotes entre todos os hosts com o mínimo de custo. Uma maneira de criar as tabelas de roteamento é dinamicamente. Com este método, os roteadores trocam informações entre si, periodicamente e actualizam suas tabelas de roteamento, com base nestas informações trocadas entre os roteadores. O método dinâmico exige bem menos manutenção e pode ser utilizado em grandes redes, como por exemplo a Internet. A actualização dinâmica das tabelas de roteamento é possível graças a utilização de protocolos de roteamento dinâmicos. Os protocolos mais conhecidos, para a criação automática de tabelas de roteamento são :

  • 1. RIP - Routing Information Protocol;

  • 2. OSPF - Open Shortest Path First.

Funcionamento dos protocolos de roteamento dinâmico

RIP Routing Internet Protocol

O protocolo RIP é baseado em um algoritmo conhecido como distance-vector (distância

vectorial). Este algoritmo é baseado na distância entre dois roteadores, sendo que esta “distância”

é medida em termos do número de roteadores existentes no caminho entre os dois roteadores também conhecido como hopes. Cada mensagem do RIP contém uma série de informações sobre as rotas que o roteador conhece (com base na sua tabela de roteamento actual) e a distância do roteador para cada uma das rotas. O roteador que recebe as mensagens, com base na sua distância para o roteador que enviou a mensagem, calcula a distância para as demais redes e

grava estas informações em sua tabela de roteamento. É importante salientar que distância significa hope, ou melhor, o número de roteadores existentes em um determinado caminho, em uma determinada rota.

As informações entre roteadores são trocadas quando o roteador é inicializado, quando o roteador recebe actualizações em sua tabela de roteamento e também em intervalos regulares. Aqui a primeira desvantagem do RIP. Mesmo que não exista nenhuma alteração nas rotas da rede, os roteadores baseados em RIP, continuarão a trocar mensagens de actualização em intervalos regulares, por padrão a cada 30 segundos. Dentre outros, este é um dos motivos pelos quais o RIP não é indicado para redes maiores, pois nestas situações o volume de tráfego gerado pelo RIP, poderia consumir boa parte da banda disponível. O RIP é projectado para intercambiar

informações de roteamento em uma rede de tamanho pequeno para médio. Além disso, cada mensagem do protocolo RIP comporta, no máximo, informações sobre 25 rotas diferentes, o que para grandes redes, faria com que fosse necessária a troca de várias mensagens, entre dois roteadores, para actualizar suas respectivas tabelas, com um grande número de rotas.

Vantagens do RIP

  • Ao receber actualizações, o roteador actualiza a sua tabela de roteamento e envia estas actualizações para todos os roteadores directamente conectados, ou seja, a um hope de distância.

  • A maior vantagem do RIP é que ele é extremamente simples para configurar e implementar em uma rede.

Desvantagens

  • Sua maior desvantagem é a incapacidade de ser ampliado para interconexões de redes de tamanho grande a muito grande;

  • A contagem máxima de hopes usada pelos roteadores RIP é 15. As redes que estejam a 16 hopes ou mais de distância, serão consideradas inacessíveis.

  • À medida que as redes crescem em tamanho, os anúncios periódicos de cada roteador RIP podem causar tráfego excessivo nos links de WAN.

  • O seu longo tempo de convergência: Quando a topologia de interconexão da rede é alterada (por queda em um link ou por falha em um roteador, dentre outros motivos), podem ser necessários vários minutos para que os roteadores RIP se reconfigurem, para reflectir a nova topologia de interconexão da rede. Embora a rede seja capaz de fazer a sua própria reconfiguração, podem ser formados loops de roteamento que resultem em dados perdidos ou sem condições de entrega.

  • Inicialmente, a tabela de roteamento de cada roteador inclui apenas as redes que estão fisicamente conectadas. Um roteador RIP envia periodicamente anúncios contendo suas entradas de tabela de roteamento para informar aos outros roteadores RIP locais, quais as redes que ele pode acessar.

OSPF - Open Shortest Path First

Com o uso do OSPF, os roteadores mantém um banco de dados independentemente da área de roteamento administrativa incluindo informações sobre as redes disponíveis, os equipamentos das redes e o custo por interface de cada uma das conexões. Este modelo oferece informações de topologia e infra-estrutura da rede. Caso exista uma mudança do estado da rede, cada um dos roteadores dentro da área descobre e incorpora aos seus bancos de dados locais, executa cálculos

de acordo com o custo dos caminhos de rede e reconstrói a tabela de roteamento. Protocolo OSPF aplica um algoritmo de vector de custo a um banco de dados de objectos de rede e utiliza as informações na determinação de rotas.

A utilização de banco de dados oferece os seguintes recursos:

  • Balanceamento de carga, se o gerenciador indicar mais de uma rota com o mesmo custo;

  • Permite particionamento das redes onde cada área tem seu recurso exclusivo, ou seja, o conhecimento da topologia de uma região fica apenas disponível para ela;

  • Define autenticação para toda a comunicação entre roteadores com grande variedade de esquemas de autenticação.

Entretanto tem um custo associado que corresponde a uma exigência maior com hardware dos roteadores, encarecendo o valo dos equipamentos.

As principais diferençam entre os protocolos RIP e OSPF

  • Quais informações sobre rotas são compartilhadas entre os roteadores. Quando um roteador apresenta problemas, a rede deve ser capaz de reconfigurar-se, para definir novas rotas, já baseadas na nova topologia da rede, sem o roteador com problemas. O tempo que a rede leva para reconfigurar-se é conhecido como convergência. Um dos principais problemas do protocolo RIP é o alto tempo de convergência em relação ao OSPF, que tem um tempo de convergência bem menor.

  • Como as informações sobre rotas e sobre a topologia da rede são compartilhadas entre os roteadores: Este aspecto também influencia o tempo de convergência da rede e apresenta diferenças significativas no RIP e no OSPF.

Dimensionamento do acesso e tecnologia de comunicação da WAN

Uma rede de longa distância (WAN) é uma rede de comunicações de dados que abrange uma grande área geográfica, como um estado, região ou país. As WANs geralmente utilizam meios de transmissão fornecidos por prestadoras de serviços de telecomunicações. Para o trabalho em causa o grupo achou conveniente fazer a comunicação WAN a partir de uma linha privada, visto que as linhas privadas são conexões dedicadas e permanentes, as mesmas podem chegar a 2,5 Gbps .As linhas privadas por terem uma capacidade dedicada não oferecem latência entre os nós. O grupo achou conveniente usar como tecnologia de acesso a WAN a tecnologia Frame Relay, visto que esta tecnologia permite taxa de dados até 4 Mbps mas neste trabalho apenas precisamos de uma linha dedicada de 2 Mbps. O acesso a internet também feito com a tecnologia frame raley.

Mecanismo de gestão dos endereços públicos para acesso a internet

Introdução ao NAT e ao PAT

O NAT foi projectado para economizar endereços IP e permitir que as redes usem endereços IP privados em redes internas. Esses endereços privados internos são traduzidos em endereços públicos roteáveis. Isso é obtido por dispositivos de interconexão de redes que executam um software NAT, que aumenta a privacidade da rede, ocultando os endereços IP internos. Um dispositivo habilitado para NAT geralmente opera na borda de uma rede stub. Rede stub é uma rede que tem uma única conexão para a rede externa. Quando um host dentro da rede stub quer transmitir para um host fora dela, ele encaminha o pacote para o roteador do gateway de borda. O roteador do gateway de borda realiza o processo NAT, traduzindo o endereço privado interno de um host em um endereço público externo roteável. Na terminologia NAT, rede interna é o conjunto de redes sujeitas a tradução. A rede externa refere-se a todos os outros endereços.

Principais recursos do NAT e do PAT

As traduções NAT podem ser usadas para inúmeras finalidades e podem ser atribuídas tanto de maneira dinâmica como estática.

O NAT estático: Permite o mapeamento dos endereços locais e endereços globais. Isso é particularmente útil para hosts que precisam ter um endereço consistente, acessível a partir da Internet. Esses hosts internos podem ser servidores corporativos ou dispositivos de rede.

O NAT dinâmico: Foi projectado para mapear um endereço IP privado para um endereço público. Qualquer endereço IP de um pool de endereços IP públicos é atribuído a um host da rede. Com o mecanismo de overloading, ou PAT (Port Address Translation Tradução de Endereços de Portas), Vários endereços privados podem ser mapeados para um único endereço público, porque cada endereço privado é rastreado por um número de porta.

O PAT usa números de porta de origem exclusivos no endereço IP global interno, para distinguir cada uma das traduções. O número da porta é codificado em 16 bits. O número total de endereços internos que podem ser traduzidos para um endereço externo poderia ser, teoricamente, até 65.536 por endereço IP. Na realidade, a quantidade de portas que podem receber um único endereço IP fica em torno de 4.000. O PAT tenta preservar a porta de origem. Se essa porta de origem já estiver em uso, o PAT atribui o primeiro número de porta disponível, a partir do início do grupo de portas apropriado 0-511, 512-1023 ou 1024-65535. Quando não há mais portas disponíveis e há mais de um endereço IP externo configurado, o PAT passa para o próximo endereço IP, para tentar alocar novamente a porta de origem. Esse processo continua até que não haja mais portas disponíveis nem endereços IP externos.

Vantagens do NAT

  • Elimina a necessidade de atribuir um novo endereço IP a cada host quando se muda para um novo provedor de serviços Internet (ISP);

  • Elimina a necessidade de endereçar novamente todos os hosts que exigem acesso externo, economizando tempo e dinheiro;

  • Economiza endereços, pela aplicação de multiplexação no nível das portas;

  • Os hosts internos podem compartilhar um único endereço IP público para toda comunicação externa. Nesse tipo de configuração, são necessários pouquíssimos endereços externos para suportar muitos hosts internos, economizando, assim, endereços IP;

  • Protege a segurança da rede. Como as redes privadas não anunciam seus endereços nem sua topologia interna, elas permanecem razoavelmente seguras quando usadas em conjunto com o uso de NAT para obter acesso externo controlado.

  • Economiza o esquema de endereçamento legalmente registrado, permitindo a privatização das intranets.;

  • Aumenta a flexibilidade das conexões à rede pública. Pools múltiplos, pools de backup e pools de balanceamento de carga podem ser implementados para garantir conexões de rede pública confiáveis.;

  • Consistência do esquema de endereçamento da rede interna. Em uma rede sem endereços IP privados e NAT, a alteração de endereços IP públicos exige a renumeração de todos os hosts da rede existente. Os custos para renumerar os hosts podem ser significativos;

  • O NAT permite manter o esquema existente e suportar um novo esquema de endereçamento público;

Desvantagens da NAT

  • Uma desvantagem significativa da implementação e utilização do NAT é a perda da rastreabilidade IP ponta-a-ponta. Torna-se muito mais difícil rastrear pacotes que passam por diversas alterações de endereço ao longo dos vários saltos do NAT. Se algum hacker quiser determinar a origem de um pacote, terá dificuldade em rastrear ou obter o endereço inicial da origem ou do destino.

  • O NAT também força alguns aplicativos que usam endereçamento IP a pararem de funcionar, porque oculta os endereços IP ponta-a-ponta. Os aplicativos que usam endereços físicos em vez de um nome de domínio qualificado não alcançam os destinos traduzidos através do roteador NAT. Às vezes, esse problema pode ser evitado através da implementação de mapeamentos NAT estáticos.

Após serem vistos as vantagens como as desvantagens do NAT, devido a necessidade de acesso a internet na rede efectuada pelo grupo, verificou-se que a melhor opção para gestão de endereços públicos é a utilização do mecanismo PAT. Visto que o PAT possibilita a utilização de um único IP publico para vários ips privados, fazendo a afectação de uma porta fonte diferente a cada pedido, de maneira a poder manter uma correspondência entre os pedidos que provem da rede interna e as respostas das maquinas na internet.

Software de gestão da rede

Para fazer a gestão da nossa redo o grupo escolheu como software de gestão o HP PCM+ Network Management Software que é uma plataforma de gerenciamento de rede com base no Microsof Windows que disponibiliza mapeamento, configuração de dispositivo e rede e monitoramento. O grupo escolheu o HP PCM+ porque ele oferece segurança e extensibilidade para redes de pequeno a grande porte com locais remotos, também porque o controle de gerenciamento no âmbito da rede permite que os usuários adicionem, personalizem e restrinjam com segurança o acesso de gerenciamento da rede, também porque o HP PCM+ oferece solução de gerenciamento em um único painel com a extensibilidade de agente remoto, o software pode

gerenciar muitos locais remotos por meio de comunicações criptografias e cruzamento de firewall. Os clientes ganharão retorno superior sobre gerenciamento, segurança, opções e flexibilidade.

Instalação de serviços

Instalacao de Active Directory

O active directory fornece a estrutura para centralizar a administração de rede e armazenar informações sobre recursos de rede em todo o domínio. O grupo entende que a criação de um domínio é de extrema importância para a gestão de uma rede e por esse motivo o grupo deu seguimento a instalação do active directory , DNS e DHCP.

Diriga se para start administrator tools server Manager .

Instalação de serviços Instalacao de Active Directory O active directory fornece a estrutura para centralizar a

Clique em addRoles.

Selecione Active Directory Domain Services e clique em next . De seguida clique em next e

Selecione Active Directory Domain Services e clique em next.

De seguida clique em next e em install.

De seguida clique em Go to active directory domain services.

Nas janelas seguintes clique em next.

De seguida clique em create a new domain in a new forest.

Clique em next. Agora digite o nome do domínio. 18

Clique em next.

Agora digite o nome do domínio.

De seguida deixe o nome NetBios padrão, neste caso ISUTC, clique em next. Selecione o tipo

De seguida deixe o nome NetBios padrão, neste caso ISUTC, clique em next.

Selecione o tipo de controladores de domínio a serem instalados.

Clique em next.

Selecione a opcao recomendada.

De seguida defina a senha para o modo de restauração. Clique em next e certifique se

De seguida defina a senha para o modo de restauração.

Clique em next e certifique se que as configurações estão correctas.

Servico DNS

Diriga se para start administrator tools DNS.

Vamos criar uma zona de pesquisa inversa, clique com o botão direito no reverse lookup zones e faca new zone.

Servico DNS Diriga se para start – administrator tools – DNS. Vamos criar uma zona de

Cique em next, deixe todas as configurações padrão existentes.

Digite o endereço ip para a zona e clique em next.

Clique em next. Teste 1 do serviço DNS De seguida o grupo efectuou os seguintes testes.

Clique em next.

Teste 1 do serviço DNS

De seguida o grupo efectuou os seguintes testes.

Ping a 192.168.1.254

Ping a isutc.local

E pudemos verificar a resolução de nomes para ip´s e vice versa, como podemos ver na figura abaixo.

O grupo simulou com ajuda da maquina virtual uma rede virtual de apenas dois computadores.

Adicionamos os hosts ao servidor DNS, da maneira explicada abaixo.

Em isutc.local clique na tecla direita e faca new host, digite o nome do host e o ip .

Adicionamos os hosts ao servidor DNS, da maneira explicada abaixo. Em isutc.local clique na tecla direita

E por fim add Host.

De seguida o grupo efectuou os seguites teste:

Teste 2 serviço DNS.

Primeiro a partir do servidor DNS fez o ping a partir do Fully Qualified domain name para as duas maquinas com sucesso como é mostrado a seguir.

Segundo efectuamos o comando ping a partir do computador1 para o computador 2. 24

Segundo efectuamos o comando ping a partir do computador1 para o computador 2.

Instalando o Servico DHCP Diriga se para start – administrator tools – server Manager . Clique

Instalando o Servico DHCP

Diriga se para start administrator tools server Manager .

Clique em add Roles e seleccione DHCP Server.

De seguida faca next.

Em DHCP scopes, clique em Add, e preencha os campos.

Faca next e install. 26

Faca next e install.

Serviço DHCP Teste 1 O grupo activou a opcao “Obtain automatitl ip adress” nas maquinas em

Serviço DHCP Teste 1

O grupo activou a opcao “Obtain automatitl ip adress” nas maquinas em rede e as mesma obteram os ips

correctos.

Servico de Email

Nota : Referir que infelizmente o grupo não pode instalar o serviço e email no ambiente Windows server 2008 pois não teve acesso ao aplicativo Exchange server.

Entretanto a instalação deste serviço foi feito no ambiente Windows server 2003.

Diriga se para Start-Control panel add or remove programas

Clique em add/remove windows components .

De seguida selecione E-Mail services

De seguida selecione E-Mail services Clique em next e faca install . De seguida va para

Clique em next e faca install .

De seguida va para start adminstrator tools Pop 3 service.

Agora adicionamos no nosso domínio os endereços de emails.

Faca doble click no nome do domínio.

Clique em add mail box e preencha os campos.

Clique em ok . Certifique se que o Outlook express esta configurado correctamente. 29

Clique em ok .

Certifique se que o Outlook express esta configurado correctamente.

Execução dos comandos de avaliação da rede

Roteador ISUTC

  • show startup-config

ISUTC#show startup-config Using 1054 bytes

version 12.2 no service timestamps log datetime msec no service timestamps debug datetime msec no service password-encryption

hostname ISUTC

enable secret 5

$1$mERr$aUjdp4Z6T1Trc5M/MDq9P1

enable password isutc

ip address 172.20.2.5

255.255.255.252

frame-relay interface-dlci 203 clock rate 2000000

interface Serial0/1 no ip address shutdown

router ospf 1 log-adjacency-changes network 192.168.1.0 0.0.0.255 area

0

network 172.20.2.4 0.0.0.3 area 0 network 172.20.1.4 0.0.0.3 area 0

interface FastEthernet0/0

router rip

ip address 192.168.1.1

version 2

255.255.255.0

network 172.20.0.0

duplex auto

network 192.168.1.0

speed auto

interface Serial0/0 bandwidth 2048 no ip address encapsulation frame-relay

interface Serial0/0.201 point-to- point

ip address 172.20.1.6

255.255.255.252

frame-relay interface-dlci 201 clock rate 2000000

ip classless

line con 0 password isutc login line vty 0 4 password isutc login

end

interface Serial0/0.203 point-to- point

show cdp neighbors

 

ISUTC#show cdp neighbors

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

 

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID

Local Intrfce

Holdtme

Capability

Platform

Port ID

Switch

Fas 0/0

174

S

2950

Fas 0/1

show ip route

 

ISUTC#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

 

D

- EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i

- IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter

area

 

* - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route

 

Gateway of last resort is not set

 
 

172.20.0.0/30 is subnetted, 3 subnets

 

C

172.20.1.4 is directly connected, Serial0/0.201

C

172.20.2.4 is directly connected, Serial0/0.203

192.168.1.0/24 is directly connected, FastEthernet0/0

 

R

172.20.3.4 [120/1] via 172.20.1.5, 00:00:06, Serial0/0.201

C

[120/1] via 172.20.2.6, 00:00:20, Serial0/0.203

R

193.168.1.0/24 [120/1] via 172.20.2.6, 00:00:20, Serial0/0.203

R

200.213.1.0/24 [120/2] via 172.20.1.5, 00:00:06, Serial0/0.201

R

205.0.0.0/24 [120/1] via 172.20.1.5, 00:00:06, Serial0/0.201

show ip protocols

 

ISUTC#show ip protocols Routing Protocol is "rip" Sending updates every 30 seconds, next due in 14 seconds Invalid after 180 seconds, hold down 180, flushed after 240 Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Redistributing: rip Default version control: send version 2, receive 2

Interface

Send

Recv Triggered RIP Key-chain

FastEthernet0/0

2

2

Serial0/0.201

2

2

Serial0/0.203

2

2

Automatic network summarization is in effect

Maximum path: 4 Routing for Networks:

172.20.0.0

192.168.1.0

Passive Interface(s):

Routing Information Sources:

Gateway

Distance

Last Update

172.20.1.5

120

00:00:22

  • 172.20.2.6 120

00:00:06

Distance: (default is 120)

Routing Protocol is "ospf 1" Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set

Router ID 192.168.1.1 Number of areas in this router is 1. 1 normal 0 stub 0 nssa Maximum path: 4 Routing for Networks:

192.168.1.0 0.0.0.255 area 0

  • 172.20.2.4 0.0.0.3 area 0

  • 172.20.1.4 0.0.0.3 area 0

Routing Information Sources:

Gateway

Distance

Last Update

192.168.1.1

110

00:03:11

Distance: (default is 110)

  • show version

ISUTC#show version Cisco Internetwork Operating System Software IOS (tm) C2600 Software (C2600-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5) Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2005 by cisco Systems, Inc. Compiled Wed 27-Apr-04 19:01 by miwang Image text-base: 0x8000808C, data-base: 0x80A1FECC

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1) Copyright (c) 2000 by cisco Systems, Inc. ROM: C2600 Software (C2600-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)

System returned to ROM by reload System image file is "flash:c2600-i-mz.122-28.bin"

Cisco 2620 (MPC860) processor (revision 0x200) with 253952K/8192K bytes of memory . Processor board ID JAD05190MTZ (4292891495) M860 processor: part number 0, mask 49 Bridging software. X.25 software, Version 3.0.0.

  • 1 FastEthernet/IEEE 802.3 interface(s)

  • 4 Low-speed serial(sync/async) network interface(s)

32K bytes of non-volatile configuration memory. 63488K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

show hosts

ISUTC#show hosts Default Domain is not set Name/address lookup uses domain service Name servers are 255.255.255.255

 

Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate temp - temporary, perm - permanent NA - Not Applicable None - Not defined

Host

Port

Flags

Age Type

Address(es)

ITC

None

(perm, OK)

0

IP

172.20.2.5

 

193.168.1.1

show ip interface

ISUTC#show ip interface FastEthernet0/0 is up, line protocol is up (connected) Internet address is 192.168.1.1/24 Broadcast address is 255.255.255.255 Address determined by setup command MTU is 1500 Helper address is not set Directed broadcast forwarding is disabled Outgoing access list is not set

Inbound

access list is not set

Proxy ARP is enabled Security level is default Split horizon is enabled ICMP redirects are always sent ICMP unreachables are always sent ICMP mask replies are never sent IP fast switching is disabled IP fast switching on the same interface is disabled IP Flow switching is disabled IP Fast switching turbo vector IP multicast fast switching is disabled IP multicast distributed fast switching is disabled Router Discovery is disabled IP output packet accounting is disabled IP access violation accounting is disabled TCP/IP header compression is disabled RTP/IP header compression is disabled Probe proxy name replies are disabled Policy routing is disabled Network address translation is disabled WCCP Redirect outbound is disabled WCCP Redirect exclude is disabled BGP Policy Mapping is disabled Serial0/0 is up, line protocol is up (connected) Internet protocol processing disabled Serial0/1 is administratively down, line protocol is down (disabled) Internet protocol processing disabled

Roteador ITC

  • show startup-config

ITC#show startup-config Using 1084 bytes version 12.2 no service timestamps log datetime msec no service timestamps debug datetime msec no service password-encryption

hostname ITC

enable secret 5

$1$mERr$4rlwJCi9tu4tUOkeA2kFs0

enable password itc

ip host ISUTC 172.20.2.5

192.168.1.1

interface Serial0/0.302 point-to- point

ip address 172.20.2.6

255.255.255.252

frame-relay interface-dlci 302 clock rate 2000000

interface Serial0/1 no ip address shutdown

router ospf 1 log-adjacency-changes network 193.168.1.0 0.0.0.255 area

0

network 172.20.2.4 0.0.0.3 area 0 network 172.20.3.4 0.0.0.3 area 0

interface FastEthernet0/0 ip address 193.168.1.1

router rip

255.255.255.0

version 2

duplex auto

network 172.20.0.0

speed auto

network 193.168.1.0

interface Serial0/0

interface Serial0/0.301 point-to-

ip classless

bandwidth 2048 no ip address encapsulation frame-relay

point ip address 172.20.3.5

line con 0 password itc login line vty 0 4 password itc login

255.255.255.252

frame-relay interface-dlci 301

end

clock rate 2000000

show cdp neighbors

 

ITC#show cdp neighbors Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID

Local Intrfce

Holdtme

Capability

Platform

Port ID

Switch

Fas 0/0

137

S

2950

Fas 0/1

show ip route

 

ITC#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

 

- EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

D

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i

- IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter

area

 

* - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route

 

Gateway of last resort is not set

 

O

172.20.0.0/30 is subnetted, 3 subnets 172.20.1.4 [110/128] via 172.20.2.5, 00:04:53, Serial0/0.302

C

172.20.2.4 is directly connected, Serial0/0.302

 

C

172.20.3.4 is directly connected, Serial0/0.301

O

192.168.1.0/24 [110/65] via 172.20.2.5, 00:04:53, Serial0/0.302

C

193.168.1.0/24 is directly connected, FastEthernet0/0

 

R

200.213.1.0/24 [120/2] via 172.20.3.6, 00:00:15, Serial0/0.301

R

205.0.0.0/24 [120/1] via 172.20.3.6, 00:00:15, Serial0/0.301

show ip protocols

 

ITC#show ip protocols Routing Protocol is "rip" Sending updates every 30 seconds, next due in 15 seconds Invalid after 180 seconds, hold down 180, flushed after 240 Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Redistributing: rip Default version control: send version 2, receive 2

Interface

Send

Recv Triggered RIP Key-chain

FastEthernet0/0

2

2

Serial0/0.301

2

2

Serial0/0.302

2

2

Automatic network summarization is in effect

Maximum path: 4 Routing for Networks:

172.20.0.0

193.168.1.0

Passive Interface(s):

Routing Information Sources:

Gateway

Distance

Last Update

  • 172.20.3.6 120

00:00:15

  • 172.20.2.5 120

00:00:22

Distance: (default is 120)

Routing Protocol is "ospf 1" Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set Router ID 193.168.1.1 Number of areas in this router is 1. 1 normal 0 stub 0 nssa Maximum path: 4 Routing for Networks:

  • 193.168.1.0 0.0.0.255 area 0

    • 172.20.2.4 0.0.0.3 area 0

    • 172.20.3.4 0.0.0.3 area 0

Routing Information Sources:

Gateway

Distance

Last Update

  • 192.168.1.1 110

00:05:27

  • 193.168.1.1 110

00:04:46

Distance: (default is 110)

  • show version

ITC#show version Cisco Internetwork Operating System Software IOS (tm) C2600 Software (C2600-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5) Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2005 by cisco Systems, Inc. Compiled Wed 27-Apr-04 19:01 by miwang Image text-base: 0x8000808C, data-base: 0x80A1FECC

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1) Copyright (c) 2000 by cisco Systems, Inc. ROM: C2600 Software (C2600-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)

System returned to ROM by reload System image file is "flash:c2600-i-mz.122-28.bin"

Cisco 2620 (MPC860) processor (revision 0x200) with 253952K/8192K bytes of memory . Processor board ID JAD05190MTZ (4292891495) M860 processor: part number 0, mask 49 Bridging software. X.25 software, Version 3.0.0.

  • 1 FastEthernet/IEEE 802.3 interface(s)

  • 4 Low-speed serial(sync/async) network interface(s)

32K bytes of non-volatile configuration memory. 63488K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

  • show hosts

ITC#show hosts Default Domain is not set Name/address lookup uses domain service Name servers are 255.255.255.255

Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate temp - temporary, perm - permanent NA - Not Applicable None - Not defined

Host

Port

Flags

Age Type

Address(es)

ISUTC

None

(perm, OK)

0

IP

172.20.2.5

  • show ip interface

192.168.1.1

ITC#show ip interface FastEthernet0/0 is up, line protocol is up (connected) Internet address is 193.168.1.1/24 Broadcast address is 255.255.255.255 Address determined by setup command MTU is 1500 Helper address is not set Directed broadcast forwarding is disabled Outgoing access list is not set

Inbound

access list is not set

Proxy ARP is enabled Security level is default Split horizon is enabled ICMP redirects are always sent ICMP unreachables are always sent ICMP mask replies are never sent IP fast switching is disabled IP fast switching on the same interface is disabled IP Flow switching is disabled IP Fast switching turbo vector IP multicast fast switching is disabled IP multicast distributed fast switching is disabled Router Discovery is disabled IP output packet accounting is disabled IP access violation accounting is disabled TCP/IP header compression is disabled RTP/IP header compression is disabled Probe proxy name replies are disabled Policy routing is disabled Network address translation is disabled WCCP Redirect outbound is disabled WCCP Redirect exclude is disabled BGP Policy Mapping is disabled Serial0/0 is up, line protocol is up (connected) Internet protocol processing disabled Serial0/1 is administratively down, line protocol is down (disabled) Internet protocol processing disabled