Anda di halaman 1dari 11

1

SISTEMA DE ENSINO PRESENCIAL CONECTADO CURSO SUPERIOR DE TECNOLOGIA EM ANALISE E DESENVOLVIMENTO DE SISTEMAS CLEMILTOM DOS SANTOS LOBO FAGNA GOMES DA SILVA SANTOS RAFAEL CAVALCANTE SILVA JOSECLEMEN LOPES CORREIA PAULO JOS ALVES GUSMO

Vitria da Conquista - Ba 2011

AURENILMA SOARES SANTOS MARIA VITRIA DE OLIVEIRA MEIRA OSVALDO TUPHIQ SMERA NETO RUBEM CHAVES BARRETO JNIOR

Trabalho apresentado ao Curso Tecnologia em Anlise e Desenvolvimento de Sistemas da UNOPAR Universidade Norte do Paran, para as disciplinas Fundamentos de Lgica e Matemtica Discreta, Organizao de Computadores , Fundamentos da Administrao da Informao, Linguagens e Tcnicas de Programao I. Prof. Denise Dias, Elaine Araman,verson Moraes,Jos R. Passini, veronice de Freitas.

Vitra da Conquista - Ba 2011

Sumrio

1 Introduo..............................................................................................................4 2 Desenvolvimento...................................................................................................5 3 Consideraes ......................................................................................................6 3 Referencias............................................................................................................7

INTRODUAO
Esse trabalho tem como principal objetivo inserir ao graduado tcnicas e linguagem de programao. O trabalho est estruturado em duas etapas, na primeira foi solicitado a realizao de alguns exerccios utilizando o VisuAlg que um programa que edita, interpreta e executa algoritmos com uma linguagem prxima do portugus estruturado. Nessa primeira parte apresentamos algoritmos, onde foram resolvidas as seguintes questes: Consumo mdio, Calculo do salrio lquido, Descontos por valor de compra, Mdia de alunos, e converso de valores do sistema decimal para o sistema binrio. Na segunda parte, foi traduzido para a linguagem lgica um conceito de Fundamentos da administrao da Informao e criada uma tabela verdade, a partir de proposies simples.

1 INTRODUO Algoritmo uma seqncia lgica, finita e definida de instrues que devem ser seguidas para resolver um problema ou executar uma tarefa. Um algoritmo nada mais do que uma receita que mostra passo a passo os procedimentos necessrios para a resoluo de uma tarefa

2 DESENVOLVIMENTO Algoritmo uma seqncia lgica, finita e definida de instrues que devem ser seguidas para resolver um problema ou executar uma tarefa. Um algoritmo nada mais do que uma receita que mostra passo a passo os procedimentos necessrios para a resoluo de uma tarefa

algoritmo "algoritmo para calcular o consumo" var DIST,VOL,CM:real inicio // Seo de Comandos escreval("Algoritmo para calcular o consumo: ") //Captura a distancia percorrida para a varivel DIST escreval("Insira a distncia total percorrida (Km): ") Leia(DIST) //Captura o volume de combustvel consumido para a varivel VOL escreval("Volume de combustvel gasto(L): ") leia(VOL) //Calcula o consumo mdio e atribui a varivel CM CM <- DIST/VOL // Escreve na tela o resultado escreval("Consumo mdio = ",CM," Km/L") fimalgoritmo

algoritmo "Calculo de INSS" // Funo :Calcular salrio liquido // Autor : // Data : 23/05/2011 // Seo de Declaraes var nome,perc:caracter sal,imp,liq:real inicio // Seo de Comandos escreval("Digite o nome do funcionrio:") leia(nome) escreval("Valor do salrio bruto de ",nome) leia(sal) se sal>1000 entao imp <- sal*11/100 liq <- sal-imp perc <- "11%" senao imp <- sal*9/100 liq <- sal-imp perc <-"9%" fimse escreval ("Nome do funcionrio: ",nome) escreval ("Salrio bruto: ",sal) escreval ("percentual INSS: ",perc) escreval ("Valor do imposto: ",imp) escreval("Valor do salrio liquido: ",liq) fimalgoritmo

algoritmo "Calculo de INSS" // Funo :Calcular salrio liquido // Autor : // Data : 23/05/2011 // Seo de Declaraes var nome,perc:caracter sal,imp,liq:real inicio // Seo de Comandos escreval("Digite o nome do funcionrio:") leia(nome) escreval("Valor do salrio bruto de ",nome) leia(sal) se sal>1000 entao imp <- sal*11/100 liq <- sal-imp perc <- "11%" senao imp <- sal*9/100 liq <- sal-imp perc <-"9%" fimse escreval ("Nome do funcionrio: ",nome) escreval ("Salario bruto: ",sal) escreval ("percentual INSS: ",perc) escreval ("Valor do imposto: ",imp) escreval("Valor do salrio liquido: ",liq) fimalgoritmo

algoritmo "Mdia notas alunos " // Funo : // Autor : // Data : 24/05/2011 // Seo de Declaraes var i: inteiro SOMA, MEDIA: real A : vetor [1..5] de real contMaior, contMenor:real inicio // Seo de Comandos SOMA <- 0 para I de 1 ate 5 faca escreva("Digite a nota do aluno ",I, " :") leia(A[i]) SOMA <- SOMA + A[i] fimpara MEDIA <- SOMA /5 para i de 1 ate 5 faca se A[i] >= MEDIA entao contMaior <- contMaior+1 senao contMenor <- contMenor+1 fimse fimpara escreval ("") escreval ("A mdia da turma : ", MEDIA) escreval ("Quantidade de alunos igual ou acima da mdia: ",contMaior) escreval ("Quantidade de alunos abaixo da mdia: ",contMenor) fimalgoritmo

algoritmo "Converso decimal para binrio " // Funo : // Autor : // Data : 24/05/2011 // Seo de Declaraes var NUM, RESTO,RESULTADO, CONT,fimCont, decimal:INTEIRO A : vetor [1..20] DE INTEIRO inicio // Seo de Comandos escreval("Digite o nmero decimal:") leia(NUM) decimal <- NUM CONT <- 0 RESULTADO <- 1 enquanto RESULTADO > 0 faca RESULTADO <- NUM div 2 RESTO <- NUM mod 2 NUM <- RESULTADO CONT <- CONT +1 A[CONT] <- RESTO se RESULTADO <= 0 ENTAO fimCont <- CONT fimse fimenquanto escreval("O cdigo binrio de", decimal," : ") enquanto fimCont >0 faca escreva(A[fimCONT]) fimCONT <- fimCONT -1 fimenquanto escreval (" 2") fimalgoritmo

10

3 - CONISIDERAES FINAIS De maneira geral, o trabalho atingiu o objetivo de desenvolver e demonstrar exemplos de algoritmos e noes de linguagem e tcnicas de programao, que pudessem auxiliar na criao de programas simples, todos com o objetivo especfico para cada rea de atuao empresarial. Na execuo deste trabalho pudemos contar com a interatividade e destreza de todo o grupo que se organizou de forma para que todos pudessem participar integralmente. Durante o desenvolvimento do trabalho surgiram dificuldades na realizao de algumas etapas, bem como na interpretao de determinadas questes, dentre elas a principal foi o exerccio nmero 4, onde houve ambigidade no entendimento da referida questo. No entanto, foram sanadas por meio de discusses entre o grupo e atravs do auxlio de materiais complementares.

11

4 -REFERNCIAS

SANTANA, Denise Dias; Perine, Luis Cludio; Fundamentos da Informao da Informao. So Paulo: Pearson,2009 <: http://www.tecmundo.com.br/2082- .> Acesso em:24.Mai.2011.