Anda di halaman 1dari 17

SISTEMA DE ENSINO PRESENCIAL CONECTADO CURSO SUPERIOR DE TECNOLOGIA EM ANALISE E DESENVOLVIMENTO DE SISTEMAS

CLEMILTOM DOS SANTOS LOBO EDROALDO BATISTA PEREIRA FAGNA GOMES DA SILVA SANTOS JOSECLEMEN LOPES CORREIA PAULO JOS ALVES GUSMO RAFAEL CAVALCANTE SILVA

A LINGUAGEM DE PROGRAMAO DO VISUALG:


Iniciando os Primeiros Passos, do Programador

Vitria da Conquista 2011

CLEMILTOM DOS SANTOS LOBO EDROALDO BATISTA PEREIRA FAGNA GOMES DA SILVA SANTOS JOSECLEMEN LOPES CORREIA PAULO JOS ALVES GUSMO RAFAEL CAVALCANTE SILVA

A LINGUAGEM DE PROGRAMAO DO VISUALG:


Iniciando os Primeiros Passos, do Programador

Trabalho apresentado ao Curso Superior de Tecnologia em Anlise e Desenvolvimento de Sistemas da UNOPAR - Universidade Norte do Paran, para as disciplinas Fundamentos de Lgica e Matemtica Discreta, Organizao de Computadores , Fundamentos da Administrao da Informao, Linguagens e Tcnicas de Programao I. Orientador: Prof. Denise Dias, Elaine Araman,verson Moraes,Jos R. Passini, Veronice de Freitas.

Vitria da Conquista 2011

Dedicatria Dedico este trabalho primeiramente a Deus e a meus pais, por ter apoiado e contribuindo de toda forma possvel, para que eu no perdesse a motivao de continuar lutando, e para que eu tenha um estudo melhor e mais completo, para que seja garantido um bom futuro. E aos meus colegas, que contriburam para elaborao desse trabalho.

Londrina, _____de ___________de 20___.

AGRADECIMENTOS Ao Tutor. Charles, meu orientador e amigo de todas as horas, que me acompanhou e me auxiliou desde o inicio at a presente data. Aos professores que contriburam para que este trabalho fosse concludo. Aos meus colegas, que esto sempre presentes.

Deus real, menos se declarado intreger. J.AllanToogood, Programador Fortran

LOBO, Clemilton dos santos; PEREIRA, Edroaldo batista; SANTOS, Fagna Gomes da Silva; CORREIA, Joseclemen Lopes; GUSMO, Paulo Jos Alves; SILVA, Rafael Cavalcante. A Linguagem de Programao do VisuAlg: iniciando os primeiros passos, do programador. 2011. 17 folhas. Trabalho de Concluso de Curso Superior de Tecnologia em Anlise e Desenvolvimento de Sistemas Centro de Ensino Presencial Conectado, Universidade Norte do Paran, Vitria da Conquista, 2011.

RESUMO

Esse trabalho tem como principal objetivo inserir ao graduado tcnicas e linguagem de programao. O trabalho est estruturado em duas etapas, na primeira foi solicitado a realizao de alguns exerccios utilizando o VisuAlg que um programa que edita, interpreta e executa algoritmos com uma linguagem prxima do portugus estruturado. Nessa primeira parte apresentamos algoritmos, onde foram resolvidas as seguintes questes: Consumo mdio, Calculo do salrio lquido, Descontos por valor de compra, Mdia de alunos, e converso de valores do sistema decimal para o sistema binrio.Na segunda parte, foi traduzido para a linguagem lgica um conceito de Fundamentos da administrao da Informao e criada uma tabela verdade, a partir de proposies simples.

Palavras-chave: Linguagem. Calculo. Algoritmos. Programao. Visualg.

LOBO, Clemilton dos Santos; PEREIRA, Edroaldo batista; SANTOS, Fagna Gomes da Silva, Correia, Joseclemen Lopes; Gusmo, Paulo Jos Alves, SILVA, Rafael Cavalcante. Programming Language VisuAlg of: initiating the first steps, the programmer. 2011. 17 sheets. Completion of course work of Technology in Analysis and Systems Development - Connected Presence Teaching Center, University of Northern Parana, Vitoria da Conquista, 2011.

ABSTRACT

This work has as main objective to enter graduate technical and programming language. The work is structured in two phases, the first was asked to carry out some exercises using VisuAlg which is a program that edits, interprets and executes algorithms with a structured language similar to Portuguese. In this first part we present algorithms, which were resolved the following issues: Average consumption, Calculation of net pay, discounts on the purchase price, average students, and value conversion of the decimal system to binary system. The second part was translated into the language a logical concept of Foundations of Information and administration created a truth table, from simple propositions.

Key-words: Language. Calculation. Algorithms. Programming. Visualg.

SUMRIO 1 Introduo..............................................................................................................9 2 Desenvolvimento.................................................................................................10 2.1 Algoritmo para calcular o consumo de litros por km percorridos................10 2.1.1 Algoritmo funcionrio salrio bruto e descontado......................................11 2.1.1.1 Algoritmo de compra e concede o desconto, com condio de valor da compra.......................................................................................................................12 2.1.1.1.1 Algoritmo calculando medias de 5 notas, e imprima media global da turma..........................................................................................................................13 2.1.1.1.1.1 Algoritmo calculando medias de 5 notas, e imprima media global da turma.(continuao do programa anterior.)...........................................................14 2.1.1.1.1.1.1 Algoritmo conversor de decimal para binrio..................................15 3 Consideraes ....................................................................................................16 4 Referncias..........................................................................................................17

9 1 INTRODUO Algoritmo uma seqncia lgica, finita e definida de instrues que devem ser seguidas para resolver um problema ou executar uma tarefa. Um algoritmo nada mais do que uma receita que mostra passo a passo os procedimentos necessrios para a resoluo de uma tarefa

Um algoritmo, uma sequncia finita de instrues bem definidas e no ambguas, cada uma das quais pode ser executada mecanicamente num perodo de tempo finito e com uma quantidade de esforo finita.O conceito de algoritmo frequentemente ilustrado pelo exemplo de uma receita, embora muitos algoritmos sejam mais complexos. Eles podem repetir passos (fazer interaes) ou necessitar de decises (tais como comparaes ou lgica) at que a tarefa se estiver implementado incorretamente ou se no for apropriado ao problema. (Wikipdia).

10 2 DESENVOLVIMENTO Neste capitulo ser mostrada os programas convertidos para a linguagem lgica, um conceito de linguagem Tcnica de programao I. Confira abaixo os programas na linguagem lgica. 2.1 - Algoritmo para calcular o consumo de litros por km percorridos algoritmo "algoritmo para calcular consumo" // Funo : Calcula o consumo de litro, com base no km percorrido // Autor : Clemilton S. Lobo // Data : 22/05/2011 // Seo de Declaraes var dist, vol_combst: real cm: real // Nesta parte foi definida as variveis e suas respectivas funes inicio // Seo de Comandos escreval ("digite sua distncia total percorrida") leia (dist) //Captura a distncia percorrida, para varivel dist escreval ("digite o volume de combustivel gasto") leia (vol_combst) //Captura a quantidade de litro gastos para varivel vol_combust cm <- dist/vol_combst escreval ("consumo mdio= ", cm, "Km/l") //Faz a diviso da distncia percorrida pela quantidade de combustvel gasto, //e armazena, na varivel cm fimalgoritmo

11

2.1.1 - Algoritmo funcionrio salrio bruto e descontado algoritmo "Funcionrio salrio Bruto" // Funo : Calcula o salrio com desconto do funcionrio // Autor : Clemilton S. Lobo // Data : 25/05/2011 // Seo de Declaraes var nome: caracter salario_bruto, soma, sal_descontado: real // Nesta parte foi definida as variveis e suas respectivas funes inicio // Seo de Comandos escreval ("digite o seu nome") leia (nome) //Captura o nome do funcionrio e armazena na varivel nome escreval ("digite o seu salario bruto") leia (salario_bruto) //Captura o salrio e armazena na varivel salario_bruto se salario_bruto >= 1000 entao sal_descontado <- salario_bruto - (salario_bruto*11)/100 senao sal_descontado <- salario_bruto - (salario_bruto*9)/100 fimse //Impe a condio se salrio for menor que 1.000,00, descontar //de 9% se for maior, descontar 11% escreval ("Funcionario: ", nome) escreval ("Seu salario Bruto : ", salario_bruto) escreval ("Salario com desconto do inss ", sal_descontado) //nesta parte, mostra na tela o resultado do valor inserido fimalgoritmo

12

2.1.1.1 - Algoritmo de compra e concede o desconto, com condio de valor da compra. algoritmo "Valor_da_compra+descoto" // Funo : Calcular o valor da compra, comparar e conceder desconto // Autor : Clemilton S. Lobo // Data : 01/06/2011 // Seo de Declaraes var nome: caracter valor_compra: real valorcompra_desconto: real inicio // Seo de Comandos escreval ("digite o nome do cliente:") leia (nome) escreva ("digite o valor da compra R$:") leia (valor_compra) se valor_compra <=1000 entao valorcompra_desconto <- valor_compra-(valor_compra*5)/100 senao se valor_compra <=5000 entao valorcompra_desconto <- valor_compra-(valor_compra*10)/100 senao se valor_compra >5000 entao valorcompra_desconto <- valor_compra-(valor_compra*15)/100 fimse fimse fimse escreval ("O valor da compra R$",valor_compra) escreval ("O valor da compra com desconto R$:",valorcompra_desconto)

13 fimalgoritmo 2.1.1.1.1 - Algoritmo Calculando medias de 5 notas, e imprima media global da turma. algoritmo "Calculando medias de 5 notas" // Funo : Calcula media de da turma de aluno e media geral. // Autor : Clemilton S. Lobo // Data : 01/06/2011 // Seo de Declaraes var i: inteiro soma, media: real a: vetor[1..5] de real cont_maior, cont_menor:real // Nesta parte foi definida as variveis e suas respectivas funes inicio // Seo de Comandos soma <- 0 //Aplicando o comnado de repetiao para i de 1 ate 5 faca escreva ("digite a nota do aluno:",i,":") leia (a[i]) //Acumulando a nota lida soma <- soma + a[i] fimpara // Calculando a mdia media <- soma/5 //escrevendo a media calculada para i de 1 ate 5 faca se a[i] >=media entao cont_maior <- cont_maior+1 senao cont_menor <- cont_menor-1 fimse fimpara

14

2.1.1.1.1.1 - Algoritmo Calculando medias de 5 notas, e imprima media global da turma.(continuao do programa anterior.) escreval ("") escreval ("A mdia da turma : ", media) escreval ("Quantidade de alunos igual ou acima da mdia: ",cont_maior) escreval ("Quantidade de alunos abaixo da mdia: ",cont_menor) //imprimi na tela os resultados dos clculos anteriores fimalgoritmo

15

2.1.1.1.1.1.1 - Algoritmo conversor de decimal para binrio algoritmo "Converso decimal para binrio" // Funo : Faz a converso do numero decimal para binrio // Autor : Clemilton S. Lobo // Data : 01/06/2011 // Seo de Declaraes var num, resto, resultado, cont, fim_cont, decimal:INTEIRO a: vetor [1..20] DE INTEIRO inicio // Seo de Comandos escreval("Digite o nmero decimal:") leia(num) decimal <- num cont <- 0 resultado <- 1 enquanto resultado > 0 faca resultado <- num div 2 resto <- num mod 2 num <- resultado cont <- cont +1 a[cont] <- resto se resultado <= 0 entao fim_cont <- cont fimse fimenquanto escreval("O cdigo binrio de", decimal," : ") enquanto fim_cont >0 faca escreva(a[fim_cont]) fim_cont <- fim_cont -1 fimenquanto fimalgoritmo

16 3 CONCLUSO De maneira geral, o trabalho atingiu o objetivo de desenvolver e demonstrar exemplos de algoritmos e noes de linguagem e tcnicas de programao, que pudessem auxiliar na criao de programas simples, todos com o objetivo especfico para cada rea de atuao empresarial. Na execuo deste trabalho pudemos contar com a interatividade e destreza de todo o grupo que se organizou de forma para que todos pudessem participar integralmente. Durante o desenvolvimento do trabalho surgiram dificuldades na realizao de algumas etapas, bem como na interpretao de determinadas questes, dentre elas a principal foi o exerccio nmero 4, onde houve ambigidade no entendimento da referida questo. No entanto, foram sanadas por meio de discusses entre o grupo e atravs do auxlio de materiais complementares. Podemos concluir tambm de incio, que esses programas designados a ns, estudantes do curso de ADS.(Anlise e Desenvolvimento de Sistemas) program-los, so de origem simples, e mesmo assim encontramos algumas dificuldades a program-los, porem temos que ter em mente, que viro pela frente, programas bem mais complexos, e assim teremos que estar preparados, para que a dificuldade se torne um grande problema, para que isso no ocorra devemos nos prontificar, com os diversos tipos de materiais, disponibilizados a nos.

17 REFERNCIAS SANTANA, Denise Dias; Perine, Luis Cludio; Fundamentos da Informao. So Paulo: Pearson,2009 UNIVERSIDADE FEDERAL DO PARAN. Biblioteca Central. Normas para apresentao de trabalhos. 2. ed. Curitiba: UFPR, 1992. v. 2. Wikipdia, http://pt.wikipedia.org/wiki/Visualg. Visualg, junho de 2010. Martins, Paulo Roberto. Linguagem e Tcnicas de Programao I. Pearson education do Brasil, 2009. Youtube, http://www.youtube.com/?hl=pt-BR&tab=w1&gl=BR, aprendendo a usar visualg, 31 de maio 2011. <: http://www.tecmundo.com.br/2082- .> Acesso em:24.Mai.2011. http://www.ceunes.ufes.br/downloads/2/mariateixeira-calcularMediaAluno.versao %2011.txt, Acesso em 30.maio.2011. http://forum.clubedohardware.com.br/visualg/436168,Acesso em 29.maio.2011 http://www.google.com.br/, Acesso em 30. maio.2011