Anda di halaman 1dari 3

Prof.

Guilherme Henrique

Referncia Rpida Visualg


Variveis caractere inteiro real logico cadeia de caracteres (string). nmero inteiro positivo ou negativo. nmero com casas decimais, positivo ou negativo com valor verdadeiro ou falso (booleano)

Comando ESCREVA (escreve na tela strings ou variveis) escreva (lista expresses) exemplo: i := 18 x := 2.543 escreva (idade , i+1) //Escreve: idade 19 escreva (x:2:1) //Escreve: 2.5 (o complemento :2 responsvel pelo espaamento esquerda e o :1 determina o numero de casas a serem exibidas) Comando ESCREVAL (faz o mesmo que o comando ESCREVA, com a diferena de pular uma linha em seguida) escreval (lista expresses) exemplo: escreval (ol mundo) Operadores Matemticos ^ * / + div mod potenciao multiplicao diviso soma subtrao diviso inteira resto da diviso (mdulo)

Operador de Atribuio := Usado na atribuio de valor variveis e constantes. Exemplo: idade := 18

Constantes No Visualg no existe declarao de constantes, mas pode ser simulada inicializando uma varivel que no vai mais ser alterada logo aps o incio do algoritmo. exemplo: salario_base : real inicio salario_base := 750.00 Entrada e Sada Comando LEIA (armazena em uma varivel o valor digitado ao pressionar o <enter>) leia (lista de variveis) exemplo: leia (nota1, nota2, nota3)

Referncia Rpida Visualg

Prof. Guilherme Henrique

Operadores Relacionais = <> < > <= >= igual a diferente de menor que maior que menor ou igual maior ou igual

exemplo: se valor > 10 entao escreva(O valor maior que dez.) senao escreva(O valor no maior que dez.) fimse Seleo de mltipla escolha Comando ESCOLHA... CASO (a condio outrocaso executada caso nenhuma das outros casos forem vlidos) escolha <varivel> caso <valor>, <valor>, ..., <valor> <comandos> caso <valor>, <valor>, ..., <valor> <comandos> ... outrocaso <comandos> fimescolha

Operadores Lgicos nao ou e Negao Disjuno Conjuno

Estruturas Condicionais Comando SE... ENTAO (caso no haja comandos a executar se o resultado da condio seja falso, basta no usarmos a parte senao da estrutura) se <condio> entao <comandos> senao <comandos> fimse

Referncia Rpida Visualg

Prof. Guilherme Henrique

exemplo: escolha qualidade caso 1, 2 escreva(ruim) caso 3 escreva(razovel) caso 4, 5 escreva(boa) outrocaso escreva(opo invlida) fimescolha Estruturas de Repetio Lao Condicional (o nmero de repeties no conhecido) Comando ENQUANTO (os comandos so executados apenas se a condio for satisfeita, teste no incio) enquanto <condio> faca <comandos> fimenquanto exemplo: enquanto numero <> 10 faca escreval(repetindo enquanto numero for diferente de 10) fimenquanto

Comando REPITA... ATE (os comandos so executados pelo menos uma vez, teste no final) repita <comandos> ate <condio> exemplo: repita escreval(repetindo ate numero ser igual 10) ate numero = 10 Lao Contado (o nmero de repeties conhecido) Comando PARA (enquanto minha varivel no atingir o limite repita) para <varivel> de < inicio> ate < limite> passo <incremento> faca <comandos> fimpara exemplo: para numero de 1 ate 5 passo 1 faca escreval(numero) fimpara

Referncia Rpida Visualg