Anda di halaman 1dari 38

Overview of

Dynamic Routing Protocols

CIS 185 Advanced Routing (CCNP 1)


Spring 2006
Rick Graziani

Based on Chapter 4: Dynamic Routing Protocols, Routing TCP/IP


2nd Edition, Jeff Doyle and Jennifer Carroll
Resources

• Information for this presentation is


largely based on the following book:
• Routing TCP/IP, Volume 1, 2nd Edition
By Jeff Doyle, Jennifer DeHaven Carroll
ISBN: 1587052024
• Thank you to Jeff Doyle, Jennifer
Carroll, and Cisco Press for the use of
their graphics and other materials for
this presentation.

Rick Graziani graziani@cabrillo.edu 2


Resources

• For more in depth information and


especially for instructors, I highly
recommend the following book:
• Cisco IP Routing: Packet Forwarding &
Intra-domain Routing Protocols
by Alex Zinin
ISBN: 0201604736
• Thank you to Alex Zinin for the use of
his materials for this presentation.

Rick Graziani graziani@cabrillo.edu 3


Note to instructors

• This presentation is not solely based on information from


the Cisco Academy CCNP 1 curriculum.
• The majority of the information for this presentation is from
Routing TCP/IP, Volume 1, 2nd Edition
By Jeff Doyle.
• I feel the information in this book does a more adequate
job of discussing the objectives and outcomes necessary
for understanding the concepts, implementation, and
troubleshooting of routing protocols, whether it is for
university academics, certification, or professional
advancement.

Rick Graziani graziani@cabrillo.edu 4


Overview of Routing Protocols

Exterior
Interior Gateway Protocols Gateway
Protocols
Distance Vector Link State Routing Path
Routing Protocols Protocols Vector
Classful RIPv1 IGRP EGP
(1982/1988) (1985) (1982)
Classless RIPv2 EIGRP OSPFv2 IS-IS BGPv4
(1994) (1992) (1991) (1990) (1995)
IPv6 RIPng EIGRP for OSPFv3 IS-IS for BGPv4
(1997) IPv6 (1999) IPv6 for IPv6
(not yet (2000) (1999)
released)
• Note: IGRP and EIGRP are Cisco proprietary protocols. They are meant as an alternative between
the limited RIP routing protocol and the more complicated and resource intensive OSPF and IS-IS
routing protocols. IGRP was discontinued with IOS 12.2 in 2005.
• The dates shown are when the RFC or other document was finalized. The protocol may have been
implemented earlier than this date.
Rick Graziani graziani@cabrillo.edu 5
The Routing Protocols we will focus on

Exterior
Interior Gateway Protocols Gateway
Protocols
Distance Vector Link State Routing Path
Routing Protocols Protocols Vector
Classful RIPv1 IGRP EGP
(1982/1988) (1985) (1982)
Classless RIPv2 EIGRP OSPFv2 IS-IS BGPv4
(1994) (1992) (1991) (1990) (1995)
IPv6 RIPng EIGRP for OSPFv3 IS-IS for BGPv4
(1997) IPv6 (1999) IPv6 for IPv6
(not yet (2000) (1999)
released)

• Note: RIPv2 will not be discussed in detail but will be used as an


example of transitioning from a classful to a classless routing protocol.

Rick Graziani graziani@cabrillo.edu 6


Another look at the course

OSPFv2 Static Route EIGRP BGP IS-IS RIPv2 Other


and Routes, Control CCNP
OSPFv3 Routing and topics
Concepts Redist.
and
Theory

• This does not necessarily reflect the amount of time we will spend on
each topic, but the focus given during the entire course.
Rick Graziani graziani@cabrillo.edu 7
Our Focus
• Understand the basics
– CCNA: Quick review
– CCNP: New
• Understand the protocols
– Gaining an overall understanding of what is important
– FYI – Some material and details is so we get past the intimidation
factor. You saw it once and can always refer to it later.
• Configuration
– CCNP Toolbelt
– Don’t just copy commands in that look like they might work, but
understand the options and what their affects will be.
• Troubleshooting
– Be comfortable with outputs, and know what to look for.
– Don’t just try different things and see what happens, as this may
have other unexpected results.

Rick Graziani graziani@cabrillo.edu 8


Dynamic Routing Protocol Basics

• Routing Protocol = A language a router speaks with other routers to


share information about the reachability and status of networks.
• Routing protocols perform:
– Best-path determination
– Route-table-update functions
– Next-best path should the best-path become unusable

Rick Graziani graziani@cabrillo.edu 9


Algorithms
• All dynamic routing protocols are built around an
algorithm.
• Algorithm = Step-by-step procedure for solving a
problem.
• At a minimum the algorithm must specify:
– A procedure for passing reachability information
about networks to other routers.
– A procedure for receiving reachability information
from other routers. A tribute to al-
– A procedure for determining optimal routes based Khwarizmi, 9th
century Persian
on the reachability information it has and for mathematician, the
recording this information in a route table. originator and
– A procedure for reacting to, compensating for, and namesake of
algorithms.
advertising topology changes in a network.

Rick Graziani graziani@cabrillo.edu 10


Algorithms
Distance Vector Routing Protocols
• RIP, IGRP:
– Variant of Bellman-Ford (or Ford-Fulkerson)
• EIGRP:
– Diffusing Update Algorithm (DUAL) first
proposed by E.W. Dykstra and C.S. Scholten
– Latest and most prominent work done by J.J.
Garcia-Luna Aceves (UC Santa Cruz)

Link State Routing Protocols


• OSPF, IS-IS:
– Dijkstra’s SPF (Shortest Path First) algorithm,
E.W. Dijkstra

Rick Graziani graziani@cabrillo.edu 11


Path Determination
192.168.10.1
Serial 0 255.255.255.252

Ethernet 0

172.16.1.1
255.255.255.0 Ethernet 1
MAC: 0cddeeffaabb
172.16.2.1
255.255.255.0
MAC: 0abbccddeeff

• Router interfaces must be members of different networks.


• Router interfaces participate in the network like other hosts on that
network.
• Ethernet interfaces:
– Have MAC Addresses
– ARP Tables
– Participate in the ARP Request and ARP Reply process like other
hosts on that network.
Rick Graziani graziani@cabrillo.edu 12
Path Determination

?
Routing
Updates

Simplistic questions illustrating the complexity of routing protocols:


• What should Router A do with the routing updates from B and C?
• What mechanism is used to ensure that all routers receive all routing
information?
• If Router A has hears about 192.168.4.0/24 from B and C which router
should be the next hop used to reach that network? Should both be
used?
• RickWhat metric is used to determine best path?
Graziani graziani@cabrillo.edu 13
Metrics

• Metric = A variable assigned to • RIP


routes as a meaning of ranking – Hop count
them from best to worst or from • IGRP and EIGRP
most preferred to least – Bandwidth
preferred. – Delay
– Hop count – Reliability
– Bandwidth – Load
– Delay • OSPF
– Reliability – Cost (Cisco defines cost as
– Load Bandwidth)
– Cost • IS-IS
– Default (Cisco supported)
– Delay
– Expense
– Error
• BGP
Rick Graziani graziani@cabrillo.edu – Policies and Attributes 14
Convergence

• Convergence = The process of brining all route tables to a


state of consistency.

Convergence Vegetarian Ca

Rick Graziani graziani@cabrillo.edu 15


Convergence
• During the time it takes for convergence to occur, routers will continue
to route packets using their current routing tables.
• It is during this time that routing errors may occur.
• Therefore, convergence time is an important factor in any routing
protocol.
• The faster a network can reconverge after a topology change, the
better.

Rick Graziani graziani@cabrillo.edu 16


Distance Vector Routing Protocols

• Most routing protocols fall into one of two classes:


1. Distance Vector
2. Link State
• Distance Vector = Derived from the fact that routes are advertised as
vectors of (distance, direction), where distance is defined in terms of a
metric and direction is defined in terms of the next-hop router.
• Built around Bellman-Ford algorithm.

Serial 0

Ethernet 0
Distance

Distance
Ethernet 1

Distance

Rick Graziani graziani@cabrillo.edu 17


Distance Vector Routing Protocols

• Distance Vector Routing Protocols include:


– RIP for IP
– XNS (Xerox Networking System’s) RIP
– Novell’s IPX RIP
– Cisco’s IGRP
– Cisco EIGRP
– DEC’s DNA Phase IV
– AppleTalks Routing Table Maintenance Protocol
(RTMP)
• Only RIP for IP and EIGRP are current routing protocols.

Rick Graziani graziani@cabrillo.edu 18


Distance Vector Routing Protocols

Periodic updates

Common Characteristics (generalization)


• Periodic Updates
– RIP’s 30 seconds to IGRP’s 90 seconds. (Notable exception is
EIGRP)
• Neighbors
– Sharing a common data link or higher-level adjacency.
• Broadcast updates
– Sends updates to a broadcast IP address (Some protocols use
multicast addresses)
• Full Routing Table Updates
– Tell their neighbors everything they know by sending their entire
routing table.
Rick Graziani graziani@cabrillo.edu 19
Routing by Rumor

Rick Graziani graziani@cabrillo.edu 20


Distance Vector Event-driven or triggered updates

Techniques Review
• Route Invalidation Timers
– “If I don’t hear from you within a certain time period I will invalidate
you and your routes.”
• Split Horizon and Split Horizon with Poison Reverse
– “I don’t need to tell you since you are the one who told me.”
• Counting to Infinity and Setting a Maximum
– “In case there is a routing loop being created, I will set a maximum
metric and then declare the route unreachable.”
• Triggered Updates or Flash Updates
– “As soon as I hear a change, I will let my other neighbors know.”
• Holddown Timers
– “I’m skeptical of this new “poorer” information and will wait to see if
convergence is in the works.”
• Asynchronous Updates and Timing Jitter
– “So we all don’t talk at once, we’ll each wait a certain random time.”
Note: For more information on these topics see me or see my CIS 82 and
CIS 83 presentations.
Rick Graziani graziani@cabrillo.edu 21
Routing by Rumor

• Distance vector routing


protocols provide road signs
to networks.

Rick Graziani graziani@cabrillo.edu 22


As opposed to Link State Routing Protocols

• Link state routing


protocols provide
road maps to
networks (next).

Rick Graziani graziani@cabrillo.edu 23


Link State Routing Protocols

• Link state routing protocols sometimes


called:
– Shortest Path First (SPF) protocol
– Distributed Database protocol
• Built around algorithm from graph
theory, E.W. Dijkstra’s short path
algorithm.
• Link state routing protocols include:
– OSPF
– IS-IS
– DEC’s DNA Phase V (legacy)
– Novell’s Netware Link Services
Protocol (NLSP) (legacy)

Rick Graziani graziani@cabrillo.edu 24


Link State Routing Protocols
These topics will be discussed in detail during OSPF
• Neighbor and Neighbor Discovery
– Process of discovering neighbors on common
links
• Link State Flooding
– Process of flooding link state information within
a topology
– Link state protocols converge much faster than
distance vector routing protocols when the
topology changes
• Link State Database
– Major part of a link state routing protocol
– Important that routers have common link state
databases
• SPF Algorithm
– Using the link state database, this algorithm is
used to calculate the shortest paths to
networks.

Rick Graziani graziani@cabrillo.edu 25


Link State Routing Protocols

1 – Flooding of link-state
information

2 – Building a 5 – Routing Table


Topological Database

3 – SPF Algorithm

4 – SPF Tree

Rick Graziani graziani@cabrillo.edu 26


Interior and Exterior Gateway Protocols

Exterior
Interior Gateway Protocols Gateway
Protocols
Distance Vector Link State Routing Path
Routing Protocols Protocols Vector
Classful RIPv1 IGRP EGP
(1982/1988) (1985) (1982)
Classless RIPv2 EIGRP OSPFv2 IS-IS BGPv4
(1994) (1992) (1991) (1990) (1995)
IPv6 RIPng EIGRP for OSPFv3 IS-IS for BGPv4
(1997) IPv6 (1999) IPv6 for IPv6
(not yet (2000) (1999)
released)
• Note: IGRP and EIGRP are Cisco proprietary protocols. They are meant as an alternative between
the limited RIP routing protocol and the more complicated and resource intensive OSPF and IS-IS
routing protocols. IGRP was discontinued with IOS 12.2 in 2005.
• The dates shown are when the RFC or other document was finalized. The protocol may have been
implemented earlier than this date.
Rick Graziani graziani@cabrillo.edu 27
Interior and Exterior Gateway Protocols

• Border Gateway Protocol (BGP) for IP


• Exterior Gateway Protocol (EGP) for IP (yes, an EGP named EGP)
• ISO’s InterDomain Routing Protocol (IDRP)

Rick Graziani graziani@cabrillo.edu 28


Interior and Exterior Gateway Protocols

• Interior Gateway Protocols = Routing protocols within an


autonomous system.
• Exterior Gateway Protocols = Routing protocols between an
autonomous system.
• Autonomous System
– Older definition: Group of routers under a common administrative
domain running a common routing protocol. (Nowadays it is
common the some companies may run multiple routing protocols.)
– Newer definition: A network under a common administration.
– Note: AS might also sometimes refer to a process domain.
Rick Graziani graziani@cabrillo.edu 29
One AS, but multiple sites running different
routing protocols.

Rick Graziani graziani@cabrillo.edu 30


Redistribution

• Redistribution is used to route between different IGP


routing protocols.

Rick Graziani graziani@cabrillo.edu 31


Classful vs. Classless Routing Protocols

Rick Graziani graziani@cabrillo.edu 32


Classless Routing Protocols

“The true characteristic of a classless routing protocol is the ability to


carry subnet masks in their route advertisements.” Jeff Doyle, Routing
TCP/IP

Benefits:
• All-zeros and all-ones subnets
– - Although some vendors, like Cisco, can also handle this with
classful routing protocols.
• VLSM
– Can have discontiguous subnets
– Better IP addressing allocation
• CIDR
– More control over route summarization

Rick Graziani graziani@cabrillo.edu


Classless Routing Protocols

Classless Routing Protocols:


• RIPv2
• EIGRP
• OSPF
• IS-IS
• BGPv4
Remember classful/classless routing protocols is different than classful/classless
routing behavior.
Classlful/classless routing protocols (RIPv1, RIPv2, IGRP, EIGRP, OSPF, etc.)
has to do with how routes get into the routing table; how the routing table gets
built.
Classful/classless routing behavior (no ip classless or ip classless) has to do with
the lookup process of routes in the routing table (after the routing table has
been built).
It is possible to have a classful routing protocol and classless routing behavior or
visa versa.
It is also possible to have both a classful routing protocol and classful routing
behavior; or both a classless routing protocol and classless routing behavior.
Rick Graziani graziani@cabrillo.edu
SantaCruz1 RIPv2 Example
router rip
network 172.30.0.0 207.0.0.0/16
207.1.0.0/16
network 192.168.4.0 Internet 207.2.0.0/16
static route to 207.3.0.0/16
version 2 etc.
10.0.0.0/8 207.0.0.0/8
no auto-summary
.1 e0
.1
SantaCruz2 ISP
.25 s0 s1 .21
router rip
network 172.30.0.0
network 192.168.4.0 192.168.4.24/30
version 2 192.168.4.20/30

no auto-summary
172.30.200.32/28
Lo2
ISP .26 s0 s0 .22 `
172.30.200.16/28
Lo1
Lo0
router rip .1 SantaCruz1 SantaCruz2 Lo0
172.30.2.0/24 .1
redistribute static .1 e0 .1 e0 172.30.110.0/24

network 10.0.0.0
172.30.1.0/24 172.30.100.0/24
network 192.168.4.0
version 2
no auto-summary

ip route 207.0.0.0 255.0.0.0 null0

Rick Graziani graziani@cabrillo.edu


SantaCruz2#show ip route
VLSM and the Routing Table
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
C 172.30.200.32/28 is directly connected, Loopback2
C 172.30.200.16/28 is directly connected, Loopback1
R 172.30.2.0/24 [120/2] via 192.168.4.21, 00:00:21, Serial0
R 172.30.1.0/24 [120/2] via 192.168.4.21, 00:00:21, Serial0
C 172.30.100.0/24 is directly connected, Ethernet0
C 172.30.110.0/24 is directly connected, Loopback0
192.168.4.0/30 is subnetted, 2 subnets
R 192.168.4.24 [120/1] via 192.168.4.21, 00:00:21, Serial0
207.0.0.0/16
C 192.168.4.20 is directly connected, Serial0 207.1.0.0/16
Internet 207.2.0.0/16
R 10.0.0.0/8 [120/1] via 192.168.4.21, 00:00:21, Serial0 207.3.0.0/16
static route to
etc.
R 207.0.0.0/8 [120/1] via 192.168.4.21, 00:00:21, 10.0.0.0/8
Serial0 207.0.0.0/8
.1 e0
.1
ISP
.25 s0 s1 .21
Supernet, classless routing protcols
will route supernets (CIDR)
192.168.4.24/30
192.168.4.20/30

172.30.200.32/28
Lo2
.26 s0 s0 .22 `
172.30.200.16/28
Lo1
Lo0
.1 SantaCruz1 SantaCruz2 Lo0
172.30.2.0/24 .1
.1 e0 .1 e0 172.30.110.0/24

172.30.1.0/24 172.30.100.0/24
Rick Graziani graziani@cabrillo.edu
From The Simpsons

Rick

Rick Graziani graziani@cabrillo.edu 37


Overview of
Dynamic Routing Protocols

CIS 185 Advanced Routing (CCNP 1)


Spring 2006
Rick Graziani

Based on Chapter 4: Dynamic Routing Protocols, Routing TCP/IP


2nd Edition, Jeff Doyle and Jennifer Carroll