Anda di halaman 1dari 11

Estructuras de Control

(Manejo de Ciclos)
Profesor Francisco Alejandro
Medina A

Estructuras de control

Estructura Mientras Que


(While)
Pasos:

1.Evala Expresin condicional que existe


dentro del ciclo, en caso de que sea
Verdadera va al paso #2; en caso de que la
Expresin Condicional sea Falsa va al paso
#3.
2.Ejecuta las Sentencias de la Parte
Verdadera y vuelve al paso #1.
3.Termina el Ciclo Mientras Que (Va al
FinMientras) y continua la secuencia del
programa.
Sintaxis en Seudoalgoritmo:

Sintaxis en C++

Mientras (Expresin)
---------------------------------------FinMientras

While (Expresin)
{
---------------------------------------}

Estructura Mientras Que


(While)
Ejemplo:
Elaborar un algoritmo que capture un nmero y que realice la tabla
de multiplicar del uno al diez de dicho nmero.
inici
o

Entre un
Nmero

n
i=1
MQ ( i <= 10 )
F

m=n*
i
n,*,i,=
,m
i=i+1
fin

Pseudoalgoritmo:
Programa tabla1;
Variables
entero n, i, m;
Inicio
escribir(entre un numero);
leer(n);
i=1;
Mientras ( i <= 10 )
m = n * i;
escribir ( n , * , i , =
, m );
i = i + 1;
FinMientras
fin

Estructura Mientras Que


(While)
Ejemplo en C++
Elaborar un algoritmo que capture un nmero y que realice la tabla
de multiplicar del uno al diez de dicho nmero.

Estructura Para (For)


Pasos:

1.Iniciativa de una variable declarada que


permite controlar el ciclo (Vlr_inicial)
2.Verifica que la variable que controla el
ciclo sea menor o igual al limite superior y si
esto ocurre va al paso #3, si el valor de la
variable es mayor al del limite superior va al
paso #5
3.Ejecuta las Sentencias que hay dentro del
ciclo
4.Incremente la variable que controla el
ciclo y retorna al paso #2
5.Termina el Ciclo Para (Va al FinPara) y
continua la secuencia del programa.
Sintaxis en Seudoalgoritmo:

Sintaxis en C++

Para(Vlr_inicial;Limite;Incremento)
------------------------------------------------FinPara

For(Vlr_inicial;Limite;Incremento)
{
------------------------------------------------}

Estructura Para (For)


Ejemplo:
Elaborar un algoritmo que capture un nmero y que realice la tabla
de multiplicar del uno al diez de dicho nmero.
inici
o
Entre un
Nmero

n
F

Para( i = 1 ; i <=
10 ; i++ )
V
m=n*
i
n,*,i,=
,m

fin

Pseudoalgoritmo:
Programa tabla2;
Variables
entero n, i, m;
Inicio
escribir(entre un numero);
leer(n);
Para( i = 1 ; i <= 10 ; i++ )
m = n * i;
escribir ( n , * , i , =
, m );
FinPara
fin

Estructura Para (For)


Ejemplo en C++
Elaborar un algoritmo que capture un nmero y que realice la tabla
de multiplicar del uno al diez de dicho nmero.

Estructura Hacer-Mientras
(Do-While)
Pasos:

1.Ejecuta las Sentencias que hay dentro del


ciclo y va al paso #2.
2.Evala Expresin condicional que existe
dentro del ciclo, en caso de que sea
Verdadera retorna al paso #1; en caso de
que la Expresin Condicional sea Falsa va al
paso #3.
3.Termina el Ciclo Hacer-Mientras y continua
la secuencia del programa.

Sintaxis en Seudoalgoritmo:

Sintaxis en C++

Hacer
---------------------------------------Mientras(Expresin)

do
{
---------------------------------------}
while (Expresin);

Estructura Hacer-Mientras
(Do-While)

Ejemplo:
Elaborar un algoritmo que capture un nmero y que realice la tabla
de multiplicar del uno al diez de dicho nmero.
inici
o

Entre un
Nmero

Pseudoalgoritmo:

n
i=1
m=n*
i
n,*,i,=
,m
i=i+1
MQ ( i <= 10 )
F

fin

Programa tabla3;
Variables
entero n, i, m;
Inicio
escribir(entre un numero);
leer(n);
i=1;
Hacer
m = n * i;
escribir ( n , * , i , =
, m );
i = i + 1;
Mientras ( i <= 10 )
fin

Estructura Hacer-Mientras
(Do-While)

Ejemplo en C++
Elaborar un algoritmo que capture un nmero y que realice la tabla
de multiplicar del uno al diez de dicho nmero.