Anda di halaman 1dari 16

Estructuras de Control

Profesor Francisco Alejandro


Medina A

Estructuras de control

Operadores
Operadores Aritmticos
+, -, *, /, ^, %

Operadores de Relacionales
>, >=, <, <=, ==, <>

Operadores Lgicos
Y (And)(&&)
O (Or)(||)
No (Not)(~)

aY
b

aO
b

No
(a)

Operadores
DFD
Potencia

modulo

C++

X <- 5^2

#include
<math.h>
x=pow(5,2);

X <- 5 mod 2

Int X;
X = 5 % 2;
C++

DFD
Igual

==

Diferente

!=

!=
DFD

C++

and

&&

or

||

not

no

Estructura Si ( If ):
Pasos:
1) Evala Expresin condicional, en caso de
que sea Verdadera va al paso #2; en caso
de que la Expresin Condicional sea Falsa va
al paso #3.
2) Ejecuta las Sentencias de la Parte
Verdadera y va al paso #3.
3) Termina la estructura Condicional (Va al
FinSi) y continua secuencia del programa.
Sintaxis en Seudoalgoritmo:

Sintaxis en C++

Si (Expresin) Entonces
---------------------------------------------------FinSi

if (Expresin)
{
---------------------------------------------}

Estructura Si ( If ):
Ejemplo:
Elaborar un algoritmo que permita capturar un nmero y que calcule
su valor absoluto.
Inicio

Pseudoalgoritmo:

Entre el
Nmero
num

num<
0

V
num <- num*(-1)

Su valor
Absoluto es ,
num

Fin

Programa ValorAbs;
Variables
entero num;
Inicio
escribir(entre un numero);
leer(num);
si (num<0) entonces
num=num*(-1);
finsi
escribir(Su valor Absoluto es
, num);
fin

Estructura Si ( If ):
Ejemplo en C++
Elaborar un algoritmo que permita capturar un nmero y que calcule
su valor absoluto.

Estructura Si-SiNo ( Ifelse ):

Sintaxis en Seudoalgoritmo:
Si (Expresin) Entonces
---------------------------------------------------SiNo
---------------------------------------------------FinSi

Pasos:
1.Evala Expresin condicional, en caso de que
sea
Verdadera va al paso #2; en caso de que
la Expresin Condicional sea Falsa va al paso
#3.
2.Ejecuta las Sentencias de la Parte Verdadera y
va al paso #4
3.Ejecuta las Sentencias de la Parte Falsa y va al
paso #4.
4.Termina la estructura Condicional (Va al FinSi)
y continua la secuencia del programa.
Sintaxis en C++
if (Expresin)
{
---------------------------------------------}
else
{
---------------------------------------------}

Estructura Si-SiNo ( Ifelse


):
Ejemplo:
Elaborar un algoritmo que permita capturar un nmero y que
indique si el nmero capturado es positivo o negativo.
inicio

Pseudoalgoritmo:
Entre un
Nmero

num

num
>=0

V
El nmero es
Positivo

El nmero es
Negativo

Fin

Programa signo;
Variables
entero num;
Inicio
escribir(entre un numero);
leer(num);
si ( num>=0 ) entonces
escribir(El nmero es
Positivo);
sino
escribir (El nmero es
Negativo);
finsi
fin

Estructura Si-SiNo ( Ifelse


):
Ejemplo en C++
Elaborar un algoritmo que permita capturar un nmero y que
indique si el nmero capturado es positivo o negativo.

Estructura Si-SiNo ( Ifelse ):


Ejemplo:
Elaborar un algoritmo que capture tres nmeros y que indique cual
de estos es el mayor
1

inicio
Entre el
Numero
1

a >=
b

a
Entre el
Numero
2

El
Mayor
es , c

b >=
c

a >=
c

El
Mayor
es , c

El
Mayor
es , b

b
Entre el
Numero
3
c
1

fin

El
Mayor
es , a

Estructura Si-SiNo ( Ifelse ):


Ejemplo:
Elaborar un algoritmo que capture tres nmeros y que indique cual
de estos es el mayor
Pseudoalgoritmo:
si ( a >= b ) entonces
si ( a >= c ) entonces
Programa mayor;
escribir (El mayor es ,
a);
Variables
sino
entero a, b, c;
escribir (El mayor es , c);
Inicio
finsi
escribir(entre el
sino
nmero 1);
si ( b >= c ) entonces
leer(a);
escribir (El mayor es ,
escribir(entre el
b);
nmero 2);
sino
leer(b);
escribir (El mayor es ,
escribir(entre el
c);
nmero 3);
finsi
leer(c);
finsi

Estructura Si-SiNo ( Ifelse ):


Ejemplo en C++
Elaborar un algoritmo que capture tres nmeros y que indique cual
de estos es el mayor

Estructura Si-SiNo ( Ifelse ):


Ejemplo:
Elaborar un algoritmo que capture tres nmeros y que indique cual
de estos es el mayor
1

inicio

a >=
b
and a
>= c

Entre el
Numero
1
a
Entre el
Numero
2

El
Mayor
es , c

b >=
c

El
Mayor
es , a

El
Mayor
es , b

b
Entre el
Numero
3
c
1

fin

Estructura Si-SiNo ( Ifelse ):


Ejemplo:
Elaborar un algoritmo que capture tres nmeros y que indique cual
de estos es el mayor
Pseudoalgoritmo:
si ( a >= b and a >= c )
entonces
Programa mayor;
escribir (El mayor es , a);
sino
Variables
si ( b >= a and
b>=a)
entero a, b, c;
entonces
Inicio
escribir (El mayor es ,
escribir(entre el
b);
nmero 1);
sino
leer(a);
escribir (El mayor es ,
escribir(entre el
c);
nmero 2);
finsi
leer(b);
finsi
escribir(entre el
fin
nmero 3);
leer(c);

Estructura Si-SiNo ( Ifelse ):


Ejemplo en C++
Elaborar un algoritmo que capture tres nmeros y que indique cual
de estos es el mayor