Anda di halaman 1dari 30

Principios de Algoritmos

SEMANA 2
LOGRO
Al final de la sesin, el alumno identifica variables y su tipo para la
elaboracin de pseudocdigos bsicos.
AGENDA
Diagrama de Flujo.
Pseudocdigo
Etapas en el desarrollo de un algoritmo.
Variables y constantes
Tipos de datos
https://www.youtube.com/watch?v=njThINdTrAo
DIAGRAMA DE FLUJO
Un diagrama de flujo es una
representacin grfica de un
algoritmo o de una parte del
mismo. Se construyen utilizando
ciertos smbolos de uso especial
como son rectngulos, valos,
pequeos crculos, etc.; estos
smbolos estn conectados entre s
por flechas conocidas como lneas
de flujo.
DIAGRAMA DE FLUJO
DIAGRAMA DE FLUJO
PSEUDOCDIGO
Pseudocdigo
Es un lenguaje de especificacin (descripcin) de algoritmos . El
pseudocdigo tiene que traducirse posteriormente a un lenguaje de
programacin.

Ventajas:
Se enfoca en la lgica del programa y no en las reglas de un lenguaje
especfico.
Se puede traducir fcilmente a lenguajes estructurados (Pascal, C,
C++).
Pseudocdigo
Modelo General
Proceso IdentificadorSolucin
Definir identificadorVariable, ... como
Tipo

// Entrada
Leer identificadorVariableEntrada, ....
// Proceso
//Operaciones con las variables
identificadorResultado<- operaciones
// Salida
Escribir identificadorResultado
FinProceso
PSEUDOCDIGO
Modelo General
Proceso IdentificadorSolucin
Definir identificadorVariable, ... como
Tipo

// Entrada
Leer identificadorVariableEntrada, ....
// Proceso
//Operaciones con las variables
identificadorResultado<- operaciones
// Salida
Escribir identificadorResultado
FinProceso
ELEMENTOS BSICOS

VARIABLE
dato definido en
un programa cuyo CONSTANTE
valor puede dato definido en
cambiar durante un programa que
su tiempo de vida presenta un valor
permanente
durante su
tiempo de vida
VARIABLE
Posicin de memoria que posee valor, tipo, nombre (identificador),
tamao.
Debe tener un identificador, que es el nombre de la Variable.
El identificador debe ser significativo.
CONSTANTE
En programacin, una constante es un valor que no puede ser
alterado durante la ejecucin de un programa
Una constante corresponde a una longitud fija de un rea reservada
en la memoria principal, donde el programa almacena valores fijos.
Por ejemplo:
El valor de pi = 3.1416
EJEMPLO 1
Identifique las variables que necesita para hallar el promedio de tres
nmeros:
Debemos identificar la formula que usaremos:
Promedio = (Variable1 + Variable2 + Variable3)/3

De la formula obtenemos la variables:


Variable1
Variable2
Variable3
Promedio
Datos

TIPOS DE DATOS
Carcter
Numricos Lgico
Cadena

Entero Real
TIPOS DE DATOS
Enteros: Representan los nmeros
Numricos (Enteros, reales). enteros, no poseen parte decimal,
Tipos de datos simples Lgicos (booleanos). ejemplo: 5, 6, -15, -100,1000,
Alfanumricos (Carcter, cadenas).
Reales: Representan nmeros
reales, poseen parte decimal,
Alfanumricos: Conjunto de ejemplo: 0.08, 3.14, 3.7452, -8.003,
caracteres finito y ordenado que el 3.0.
computador reconoce.
Booleanos: Aquellos que pueden
tomar dos posibles valores; falso
(false) o verdadero (true).
ASIGNACION
La asignacin es la operacin que usamos para dar un valor a una
variable.
Debemos tener en cuenta el tipo de variable cuando almacenamos un
valor en una variable, en otros lenguajes son mas estrictos con este
tema, pero en pseudocdigo solo debemos saber que no podemos
mezclar distintos tipos de valores.
La asignacin es una operacin destructiva, es decir, que si
almacenamos un valor en la misma variable el valor que tenia antes
desaparece.
EJEMPLO

La variable A al principio vale 6, despus, A valdr 1 y por ultimo


valdr 8.
Al final prevalece el ultimo resultado, el valor 6 y 1 desapareceran,
siempre y cuando se almacene en la misma variable.
ENTRADA Y SALIDA DE DATOS
Para la entrada y salida de datos se usan las palabras reservadas LEER
y ESCRIBIR
Leer A
Escribir Hola Mundo
ENTRADA - LEER
Permite asignar valores a variables desde un dispositivo de entrada como el teclado.

Leer var1,var2,,varN

Variables

Ejemplo: Supngase que se tiene la variable n y que se usa una instruccin Leer para
asignarle a sta un nuevo valor, la siguiente figura muestra el funcionamiento de dicha
instruccin:
Definir n como
Entero

Leer n
SALIDA - ESCRIBIR
Permite mostrar en pantalla los valores almacenados en variables o valores constantes asociados a
mensajes.
Escribir cadena1,,cadenaN,var1,var2,,varN

Constantes Variables

Lo que se encuentra entre comillas sencillas () es constante, lo que no se encuentra entre comillas
es variable.
Ejemplo: Supngase que se tienen las variables enteras: a=3, b = 8 y c = 11.
Escribir a + b = ,a, + ,b, = ,c
OPERACIONES MATEMATICAS
Operador Operacin

+ Suma

- Resta

* Multiplicacin

/ Divisin

^ Potenciacin

MOD Mdulo (residuo)


EXPRESIONES ARITMETICAS
Las expresiones aritmticas son anlogas a las formulas matemticas.
Las variables y constantes son numricas (real o entera) y las
operaciones son las aritmticas.
Pseudocdigo
-b + (b*b-4*a*c)^0.5

Pseudocdigo
x*x / (z*z+y*y)
EJERCICIO
ESTRUCTURA DE UN ALGORITMO
ESTRUCTURA
La estructura de un algoritmo sirve para organizar a los elementos
que aparecen en l. Todos los algoritmos tienen la misma estructura,
la cual viene definida por tres secciones:
Cabecera
Declaraciones
Cuerpo
CABECERA
En la cabecera de un algoritmo se debe de indicar el nombre
(identificador) asignado al mismo.
La sintaxis es: Proceso <nombre_del_algoritmo>.
Ejemplo
Si se quiere disear el algoritmo de un programa que calcule el
area de una circunferencia por lo tanto el algoritmo debe llevar en
la cabecera proceso Area_de_una_circuferencia
DECLARACIONES
En esta seccin se declaran las variables y los tipos de datos que se
usan en un algoritmo.
La sintaxis es la siguiente:
Definir <nombre_de_variable> como <tipo_de_dato>
Ejemplo
Para resolver el problema planteado en la cabecera, es necesario declarar tres
variables
Definir v_pi, radio, rea como real
CUERPO
En el cuerpo se escriben todas las instrucciones del algoritmo:
<Instruccin 1>

<Instruccin n>
FinProceso
Ejemplo: Para resolver el problema planteado en la cabecera
Escribir introduzca radio:
Leer radio
area =v_pi*radio^2
Escribir El rea de la circunferencia es:, rea
FinProceso
EJEMPLO
Disear el algoritmo de un programa que calcule el rea de una
circunferencia
Proceso Area_de_una_circuferencia
Definir v_pi, radio, rea como real
Escribir introduzca radio:
Leer radio
area =v_pi*radio^2
Escribir El rea de la circunferencia es:, rea
FinProceso