Anda di halaman 1dari 42

VIRTUAL LOCAL AREA

NETWORK - VLAN

VIRTUAL LOCAL  Funcionamiento de la VLAN


AREA NETWORK:  Configuración de la VLAN
VLAN
Propiedad intelectual de Daniel Díaz @ 2014

Profesor Daniel Díaz Ataucuri


ddiaz1610@gmail.com
http://www.danieldiaza.com

ddiaz1610@gmail.com
Catedrático Titular a Tiempo Parcial FIEE-UNI / UNMSM
Director de Investigación y Desarrollo
Tecnológico del INICTEL-UNI

Lima, Enero-Diciembre de 2014


Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN

FUNCIONAMIENTO DE
LA VLAN
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz1610@gmail.com
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
CONCEPTO DE VLAN
Grupo de dispositivos conectados a la red de manera
lógica y no física, que actúan como si estuvieran en su
propia red independiente.
►El criterio lógico puede estar basado en puerto del switch,
direcciones MAC, direcciones lógicas, números de puertos,
tipo de protocolos, etc. Las computadoras en
VLAN separadas no
Propiedad intelectual de Daniel Díaz @ 2014

pueden comunicarse.
Se requiere de un router.
SW1 SW2 SW3

ddiaz1610@gmail.com
VLAN10
VLAN3

VLAN2
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
ENRUTAMIENTO ENTRE VLAN
El enrutamiento entre VLAN requiere de un router o
Switches multicapas (capa 3).
Se presenta dos posibilidades:
►Se definen cantidad de interfaces físicas como VLAN existen.
►Se definen varias interfaces virtuales en una interfaz física,
asociada a cada VLAN: Interfaz virtual está basada en software.
R1
Propiedad intelectual de Daniel Díaz @ 2014

Fa0/1
SubInterfaz Fa0/1.1 SubInterfaz Fa0/1.2

SubInterfaz Fa0/1.3
SW1 SW2 SW3

ddiaz1610@gmail.com
VLAN10
VLAN3

VLAN2
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
LO BÁSICO PARA IMPLEMENTAR UNA VLAN
Se debe definir sub-interfaces en
el router (interfaces virtuales)
R1
Un puerto de switch perteneciente a El enlace entre switches se denomina

Fa0/1
una VLAN se denomina puerto de troncal.
acceso.

Puerta de enlace
SW1 SW2 SW3

VLAN10
Dominio de Colisión
Dominio
Propiedad intelectual de Daniel Díaz @ 2014

VLAN3
de
Colisión

ddiaz1610@gmail.com
VLAN2 Dominio
Dominio de de Colisión
Colisión
Cada VLAN tiene: Las VLAN reducen el Los dispositivos ubicados en
 Prefijo de Red número de dispositivos que dos VLAN diferentes se
 Máscara pueden participar en una comunican a través de un
 Puerta de enlace tormenta de broadcast. router (Capa 3).
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
METODOS PARA CREAR VLAN
Por ejemplo: Cada puerto se configura
Si se configura
VLAN estáticas.- Cada para VLAN 3
1 para que pertenezca a
una VLAN
SW1 SW2
dispositivo conectado
a un determinado puerto
asume inmediatamente
la VLAN del puerto.
Esta PC pertenece Cada dispositivo (PC) pertenece a
a la VLAN 3 2 la VLAN del puerto conectado
Propiedad intelectual de Daniel Díaz @ 2014

Sola la PC con dirección MAC1


será parte de la VLAN 3
SW1 SW2
VLAN dinámicas.- Asigna
puertos del switch a una

ddiaz1610@gmail.com
VLAN basándose en la
dirección MAC del
dispositivo conectado al puerto.
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
ENLACE TRONCAL - VLAN TRUNKING
Enlace troncal
-VLAN Trunking-

SW1 SW2 SW3

VLAN10
VLAN3
VLAN 1 VLAN 2 VLAN 3
Propiedad intelectual de Daniel Díaz @ 2014

VLAN2

Enlace punto a punto que admite varias VLAN.

ddiaz1610@gmail.com
La interfaz usada como troncal (trunking) llega a ser
un miembro de todas las VLAN configuradas.
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
OPERACION DEL ENLACE TRONCAL
Existen dos mecanismos para enviar los datos de
diferentes VLAN por el enlace troncal.
►Filtrado de tramas. Similar al esquema utilizado por los routers
►Etiquetado de tramas: Envío más veloz y fácil de administrar.

Dentro del esquema de Etiquetado de trama (ó tagging)


Propiedad intelectual de Daniel Díaz @ 2014

existen dos propuestas :


►Inter Switch Link-ISL. Propuesta por CISCO y fue creada antes
de los estándares de la IEEE.

ddiaz1610@gmail.com
►IEEE 802.1Q. Estándar adoptado por la industria en VLAN

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
IEEE 802.1q

MAC MAC Tipo Datos


FCS
Dest. Orig. Ethernet (longitud variable)

Trama Ethernet II - 64 a 1518 bytes

802.1q
Propiedad intelectual de Daniel Díaz @ 2014

4 bytes

MAC MAC IEEE Tipo Datos


FCS
Dest. Orig. 802.1Q Ethernet (longitud variable)

ddiaz1610@gmail.com
16 bits 3 bits 1 bit 12 bits
TPID CFI
Prioridad VLAN ID
(8100h) (0)

Nueva Trama - 68 a 1522 bytes


Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
IEEE 802.1q

TPID Prioridad CFI VLAN ID


TCI, Tag Control Information
16 bits 3 bits 1 bit 12 bit

TPID (Tag Protocol IDentifier).


►Identifica la trama IEEE 802.1Q, su valor es 8100H
Prioridad.
Propiedad intelectual de Daniel Díaz @ 2014

►Prioriza el dato transportado. Detalles en IEEE 802.1p


CFI (Canonical Format Indicator).

ddiaz1610@gmail.com
►Para un Switch Ethernet este campo está en 0 (canónica)
VLAN ID (VLAN IDentifier).
►Identifica la VLAN a la que pertenece la trama
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
IEEE 802.1q

MAC MAC ID Tipo MAC MAC ID Tipo


Dest. Orig. VLAN Ethe. Datos CRC Dest. Orig. VLAN Ethe. Datos CRC
2 2
MACy MACx MACy MACx
Trama etiquetada
Interfaz asignada Inserta ID VLAN=2 Envío a la al SW3
Interfaz asignada
a la VLAN2 Troncal a la VLAN2
SW1 SW2 SW3
Pertenece a VLAN 2.
VLAN10 Quita etiqueta y envía

VLAN3
Propiedad intelectual de Daniel Díaz @ 2014

MACx MACy
VLAN2 Trama sin etiqueta

MAC MAC Tipo MAC MAC Tipo

ddiaz1610@gmail.com
Dest. Orig. Ethe. Datos CRC Dest. Orig. Ethe. Datos CRC

MACy MACx MACy MACx

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
IEEE 802.1q

MAC MAC ID Tipo MAC MAC ID Tipo


Dest. Orig. VLAN Ethe. Datos CRC Dest. Orig. VLAN Ethe. Datos CRC
2 2
MACz MACx MACz MACx
Trama etiquetada
Interfaz asignada Inserta ID VLAN=2 Envío a la al SW3
Interfaz asignada
a la VLAN2 Troncal a la VLAN1
SW1 SW2 SW3

Trama pertenece a la VLAN 2, pero


VLAN10 la interfaz pertenece a la VLAN 1
VLAN3
Propiedad intelectual de Daniel Díaz @ 2014

MACx MACz
VLAN2

MAC MAC Tipo

ddiaz1610@gmail.com
Dest. Orig. Ethe. Datos CRC

MACz MACx

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
CARACTERÍSTICAS DE UNA TRONCAL
IEEE 802.1q
Un enlace troncal IEEE 802.1q admite tráfico
simultáneo: tramas etiquetas y no etiquetadas.
►Un enlace troncal 802.1Q se le asigna un PVID predeterminado
y todo el tráfico sin etiquetar se transporta en el PVID
predeterminado del enlace.
►El paquete con un ID de VLAN igual al PVID predeterminado
Propiedad intelectual de Daniel Díaz @ 2014

del puerto de salida se envía sin etiquetar.

ddiaz1610@gmail.com
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
COMUNICACIÓN ENTRE VLAN (1/3)
R1 envía su Respuesta Solicitud Trama: Se debe enviar datos
MAC a PC1 ARP (b) ARP (a) datos (c) a PC13; no se conoce
PC1 con PC13 la MAC de PC13!.
Como las IP de PC1 y PC13 R1

Fa0/1
están en diferentes VLAN,
se debe de enviar el dato
a su puerta de enlace R1

SW1 SW2 SW3

VLAN10
Dominio de Colisión
Dominio
Propiedad intelectual de Daniel Díaz @ 2014

VLAN3
de
Solicitud
ARP (a)
Colisión
Trama:
datos (c)
Respuesta Solicitud Solicitud Solicitud Solicitud Solicitud
ARPPC1
(b) ARP (a) ARP (a) ARP (a) PC13 ARP (a) ARP (a)

ddiaz1610@gmail.com
PC1 conoce VLAN2 Dominio de Colisión
MAC de R1
Paso a: PC1 no sabe la MAC de su puerta Paso c: Envía trama con los datos al router
de enlace: R1. Envía solicitud ARP R1 (ya conoce la MAC de R1)
(broadcast a la VLAN 10)
Paso b: Router R1 responde con ARP, envía
su MAC a PC1 (unicast)
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
COMUNICACIÓN ENTRE VLAN (2/3)
R1 debe conocer Solicitud Trama: Respuesta R1 recién conoce
PC1 con PC13 la MAC de PC13 ARP (d) datos
datos(f) ARP (e) la MAC de PC13

R1

Fa0/1
SW1 SW2 SW3

VLAN10
Dominio de Colisión
Dominio
Propiedad intelectual de Daniel Díaz @ 2014

VLAN3
de
Colisión Trama:
datos (f)
Solicitud Solicitud Solicitud
ARP (d) ARP (d) ARP (d)
PC1 PC13

ddiaz1610@gmail.com
Respuesta PC13 envía
VLAN2 Dominio de Colisión
ARP (e) su MAC a R1

Paso d: Envía trama de solicitud ARP a VLAN 3 Paso f: Envía trama con los datos a la PC13
(broadcast) para conocer MAC de PC13 (ya conoce la MAC de 13)
Paso e: PC13 responde con ARP, enviando
su MAC a R1 (unicast)
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
COMUNICACIÓN ENTRE VLAN (3/3)
PC1 con PC13
R1

Fa0/1
Analizando solo la trama
que lleva datos

SW1 SW2 SW3

VLAN10
Dominio de Colisión
Dominio
Propiedad intelectual de Daniel Díaz @ 2014

VLAN3
de
Colisión

Trama:
datos

PC1 PC13

ddiaz1610@gmail.com
VLAN2 Dominio de Colisión

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
RANGOS DE LA VLAN
VLAN de rango normal
►El ID VLAN está entre 1 y 1005.
►El ID VLAN está entre 1002 y 1005 se reservan las
VLAN Token Ring y FDDI.
►Las VLAN 1, 1002, 1003, 1004 y 1005 se crean automáticamente
y no se pueden eliminar.
►Las configuraciones se almacenan en el archivo vlan.dat.
Propiedad intelectual de Daniel Díaz @ 2014

►VTP utiliza este rango para administrar la creación de VLAN


entre switches.
VLAN de rango extendido

ddiaz1610@gmail.com
►El ID VLAN está entre 1006 y 4094.
►VTP no aprende este rango de VLAN.
►Posibilita a los proveedores extender sus infraestructuras.
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
TIPOS DE VLAN
VLAN predeterminada (o VLAN 1 para switch CISCO)
►Todos los puertos forman al inicio parte de la VLAN predeterminada
►No se puede denominar ni eliminar.
►Soporta tráfico de control de la capa 2 (CDP) y spanning tree.

VLAN nativa (se debe configurar en el enlace troncal)


►Se asigna una VLAN nativa a un puerto troncal IEEE 802.1q.
Propiedad intelectual de Daniel Díaz @ 2014

►Una troncal IEEE 802.1q acepta tráfico etiquetado y no etiquetado.


►Una troncal IEEE 802.1q coloca el tráfico no etiquetado a la
VLAN nativa
►Una VLAN nativa puede tener cualquier ID, se acostumbra ID 99

ddiaz1610@gmail.com
VLAN de datos o de usuarios (se debe configurar)
►Es una VLAN configurada para enviar solo tráfico de datos
generados por los usuarios.
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
TIPOS DE VLAN
VLAN administración
►Es cualquier VLAN que se configura para administrar al switch.
►Podría ser la VLAN 1 o la VLAN nativa.
►Se asigna una dirección IP y una máscara de subred a la VLAN
de administración.
►Se puede manejar un switch mediante HTTP, Telnet, SSH o SNMP.
►No se aconseja que la VLAN 1 sea la administrativa.
Propiedad intelectual de Daniel Díaz @ 2014

VLAN de voz
►Se necesita una VLAN propia de voz porque la voz necesita QoS.
►Se debe separa el tráfico para una mejor eficiencia en la

ddiaz1610@gmail.com
comunicación de voz.
►Requiere priorizar los paquetes VoIP.
►Retardos menor a 150 ms.
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
TIPOS DE VLAN

SW1 VLAN 20

SW2
VLAN de Voz 150
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz1610@gmail.com
Información del CCNA 3(3.1.2)
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
PROTOCOLO ISL: Inter-Switch Link
Protocolo de encapsulación de propiedad de CISCO y
soportado por switches y routers.
Soporta hasta 1000 VLAN.

MAC MAC Tipo Datos


FCS
Dest. Orig. Ethernet (longitud variable)
Propiedad intelectual de Daniel Díaz @ 2014

Trama Ethernet II - 64 a 1518 bytes

ddiaz1610@gmail.com
Cabecera
MAC MAC Tipo Datos
ISL FCS
Dest. Orig. Ethernet (longitud variable)
(26 bytes)

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
VIRTUAL TRUNK PROTOCOL - VTP

VLAN 2

Como compartir
Base de y actualizar estas Base de
datos bases de datos datos

Trunking
Propiedad intelectual de Daniel Díaz @ 2014

Virtual Trunk
Protocol
VTP

ddiaz1610@gmail.com
VLAN 1

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
RESUMIENDO
En una VLAN estática se asigna los puertos del Switch
a una VLAN manualmente.
En una VLAN dinámica se basa en las direcciones
MAC, IP o tipo de protocolos.
La VLAN 1 es la de administración y corresponde a la
VLAN predeterminada.
Propiedad intelectual de Daniel Díaz @ 2014

Las publicaciones del protocolo CDP y VTP son


realizadas en la VLAN 1.

ddiaz1610@gmail.com
En los dos extremos de un enlace troncal se configura
IEEE 802.1Q ó ISL.
VLAN nativa (99)
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN

CONFIGURACIÓN DE
LA VLAN EN EQUIPOS
Propiedad intelectual de Daniel Díaz @ 2014

CISCO

ddiaz1610@gmail.com
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
IMPLEMENTAR UNA VLAN
SWITCH PC1 PC2 PC3 PC4 PC5
LIMA

F0/2
F0/3
F0/10
F0/11
F0/12
.10 .11 .18 .19 .130
LAN Sub-
207.7.7.0/24 interfaces
F0/0.1 VLAN 1
F0/0.2 VLAN 2
F0/0.3 VLAN 3

.2
Propiedad intelectual de Daniel Díaz @ 2014

F0/21

SWITCH PC6 PC7 PC8 PC9 PC10


F0/20 CUZCO
F0/12
F0/1
F0/4
F0/7
F0/9

.12 .13 .20 .21 .132


.1
S0/0

F0/0

ddiaz1610@gmail.com
S0/1

VLAN 2 FISICA VLAN 3 QUIMICA VLAN 1


200.1.1.0/30 210.1.1.0/28 210.1.1.16/28 210.1.1.128/25
GW= 210.1.1.1 GW= 210.1.1.17 Gw= 210.1.1.129
WAN IP=210.1.1.130

LAN 210.1.1.0/24
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
ANALISIS DE LAS VLANs DEFINIDOS
Comando show vlan muestra las VLAN.

VLAN por
defecto
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz1610@gmail.com
03 VLAN
creadas
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
UBICACIÓN DE LOS ARCHIVOS DE
CONFIGURACION
Comando show flash, permite ver el directorio
flash.
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz1610@gmail.com
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
ELIMINACION DE TODAS LAS VLAN
DEFINIDAS PREVIAMENTE
Se debe borrar el archivo vlan.dat del directorio flash.

Se debe borrar el archivo de respaldo startup-config

Reiniciar el switch con reload


Propiedad intelectual de Daniel Díaz @ 2014

Switch#delete flash:vlan.dat

ddiaz1610@gmail.com
Switch#erase startup-config

Switch#reload

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
VERIFICACIÓN DE SWITCH SIN VLAN
Propiedad intelectual de Daniel Díaz @ 2014

No hay

ddiaz1610@gmail.com
vlan.dat

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
SWITCH INICIALIZADO
Comando show vlan brief, muestra interfaces
Propiedad intelectual de Daniel Díaz @ 2014

Todas
las

ddiaz1610@gmail.com
interfaces
en la
vlan 1

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
CREACION DE LAS VLAN
Creando las VLAN:
Switch> enable Similar configuración
Switch# configure terminal en el switch
Cuzco o
Switch(config)# hostname Lima usar VTP
Lima(config)# exit
Lima# vlan database
Lima(vlan)# vlan 2 name Fisica
Propiedad intelectual de Daniel Díaz @ 2014

Lima(vlan)# vlan 3 name Quimica


Observando las VLAN

ddiaz1610@gmail.com
creadas en el
switch Lima:
Lima#show vlan brief
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
CONFIGURACION USANDO VTP

Lima#vlan database Cuzco#vlan database


Lima(vlan)#vtp server Cuzco(vlan)#vtp client
Lima(vlan)#vtp domain america Cuzco(vlan)#vtp domain america
Lima(vlan)#exit Cuzco(vlan)#exit

Lima Fa0/24 Fa0/21 Cuzco


Propiedad intelectual de Daniel Díaz @ 2014

Lima#vlan database Las VLAN (2 y 3) definidos en el


Lima(vlan)#vlan 2 name Fisica Switch Lima deben de migrar al
Lima(vlan)#vlan 3 name Quimica Switch Cuzco debido al protocolo VTP.
Lima(vlan)#exit .
.

ddiaz1610@gmail.com
Luego asignar a cada VLAN los puertos Luego asignar a cada VLAN (2 y 3) los
respectivos. puertos respectivos.

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
ASIGNACION DE LAS INTERFACES
A CADA VLAN
A la VLAN 2 asignar las interfaces Fa0/11 y Fa0/12
Lima(config)# interface fastethernet 0/11
Lima(config-if)# switchport mode access Switch Lima,
Lima(config-if)# switchport access vlan 2 complementar
la asignación de
Lima(config-if)# exit interfaces en
Propiedad intelectual de Daniel Díaz @ 2014

Lima(config)# interface fastethernet 0/12 la VLAN3


Lima(config-if)# switchport mode access
Lima(config-if)# switchport access vlan 2
Lima(config-if)# exit

ddiaz1610@gmail.com
Similar configuración en
el switch Cuzco

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
CONFIGURACION DE LA VLAN 1
Configuración de la VLAN 1
Lima(config)#interface vlan 1
Lima(config-if)#ip address 210.1.1.130 255.255.255.128
Lima(config-if)#no shutdown
Lima(config-if)#exit
Lima(config-if)#ip default-gateway 210.1.1.129

Habilitando el servidor web en el switch Lima.


Propiedad intelectual de Daniel Díaz @ 2014

Lima(config)#ip http server


Lima(config)#ip http port 80

Acceso al servidor web del

ddiaz1610@gmail.com
switch Lima:
►Desde la PC5 ingresar en
el buscador web: http://201.1.1.130
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
CONFIGURACION DE ENLACE TRONCAL:
802.1Q

Lima Fa0/24 Fa0/21 Cuzco

Lima(config)#interface fastethernet 0/24


Lima(config-if)#switchport mode trunk
Lima(config)#end
Propiedad intelectual de Daniel Díaz @ 2014

Cuzco(config)#interface fastethernet 0/21


Cuzco(config-if)#switchport mode trunk

ddiaz1610@gmail.com
Cuzco(config)#end
Para verifica enlace troncal emplear:
show interface fastethernet 0/1 switchport
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
ENRUTAMIENTO ENTRE VLAN: SUBINTERFAZ
Asignar una interfaz física para cada VLAN.
Son las puerta de enlace de cada VLAN

Fa0/0 210.1.1.129 VLAN 1


Fa0/1 210.1.1.1 VLAN 2
Fa0/2 210.1.1.17 VLAN 3 Cuzco

►Una nueva VLAN implica usar otra interfaz!!!!


Propiedad intelectual de Daniel Díaz @ 2014

Asignar una interfaz física para todas las VLAN,


pero se definir sub-interfaces.

ddiaz1610@gmail.com
VLAN 2
Fa0/0 Cuzco

►Es lo que se acostumbra realizar.


Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
CONFIGURACION DE SUBINTERFACES
VLAN 2
Fa0/0 Cuzco

Fa0/0.1 IP=210.1.1.129/25
Fa0/0.2 IP=210.1.1.1/28
Fa0/0.3 IP=210.1.1.17/28
Router(config)# interface fastethernet 0/0.1
Router(config-subif)# description VLAN 1 Administracion
Router(config-subif)# encapsulation dot1q 1
Propiedad intelectual de Daniel Díaz @ 2014

Router(config-subif)# ip address 210.1.1.129 255.255.255.128


Router(config)# interface fastethernet 0/0.2
Router(config-subif)# description VLAN 2 Fisica
Router(config-subif)# encapsulation dot1q 2
Router(config-subif)# ip address 210.1.1.1 255.255.255.240

ddiaz1610@gmail.com
Sigue con fa0/0.3

Router(config)# interface fastethernet 0/0


Router(config-if)# no shutdown

Profesor Daniel Díaz A. http://www.danieldiaza.com


VIRTUAL LOCAL AREA
NETWORK - VLAN
DEFINIENDO TRONCAL IEEE 802.1q
EN SWITCH

Trunk IEEE 802.1q


Fa0/0 Fa0/20 Cuzco
Propiedad intelectual de Daniel Díaz @ 2014

Cuzco#configure terminal
Cuzco(config)#interface fastethernet 0/20
Cuzco(config-if)#switchport mode trunk

ddiaz1610@gmail.com
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
TABLAS MAC DEL SWITCH
show mac-addres-table

Clear mac-address-table dynamic vlan 1


Propiedad intelectual de Daniel Díaz @ 2014

ddiaz1610@gmail.com
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
ESCENARIO DE IMPLEMENTACIÓN
Los servidores deben VLAN de Administración es VLAN 1
conectarse a la VLAN nativa R1 por defecto (no es recomendable)
IP: Se asigna una dirección IP y
200.1.2.200 máscara. Se puede administrar

Fa0/1
VLAN 99 Fa0/1.10 Fa0/1.3
mediante http, telnet, ssh o snmp.
Fa0/1.9 Fa0/1.2 Puede ser la VLAN 99 (nativa).

Fa0/2
Fa0/13 SW1 SW2 SW3
Fa0/10 Fa0/8 Fa0/11 Fa0/2

Fa0/12
Fa0/13
Fa0/1
Fa0/2
Fa0/3
Fa0/6
Fa0/9

Fa0/1
Fa0/3
Fa0/4
Fa0/5
Fa0/6

Fa0/7
Fa0/8
Fa0/9
VLAN10
Dominio de Colisión
Dominio
Propiedad intelectual de Daniel Díaz @ 2014

VLAN3
de
Colisión

ddiaz1610@gmail.com
VLAN2 Dominio de Colisión
VLAN 2 (ELECTRÓNICA) : 200.1.2.0/26 Puerta de Enlace: 200.1.2.1
VLAN 3 (MECATRÓNICA) : 200.1.2.64/26 Puerta de Enlace: 200.1.2.65
VLAN 10 (ECONOMÍA) : 200.1.2.128/26 Puerta de Enlace: 200.1.2.129
VLAN 99 (VLAN nativa) : 200.1.2.192/27 Puerta de Enlace: 200.1.2.193 (VLAN de Administración)
VLAN 1 (VLAN defecto) : 200.1.2.224/27 Puerta de Enlace: 200.1.2.225
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
LABORATORIO
Asuma criterios
Rb
Prefijo WAN: 20.2.2.0/30 para su diseño
Enrutamiento estático
R2
Ra Rd
LAN UTP:
LAN LIMA: 10.10.3.0/24
Habilitar el NAT por puerto
 VLAN 1 a 201.1.1.1
 VLAN 2 a 201.1.1.2
Rc
 VLAN 3 a 201.1.1.3
R1 LAN UTP: 10.10.0.0/22
VLAN 1: 10.10.1.0/24
Propiedad intelectual de Daniel Díaz @ 2014

VLAN 2: 10.10.2.0/24
VLAN 3: 10.10.3.0/24
SW1 SW2 LAN LIMA:
 Habilitar el NAT por puerto
VLAN1 para el rango 10.10.3.2 hasta

ddiaz1610@gmail.com
VLAN3 el 10.10.3.63, con la IP
pública 202.2.2.1
 Habilitar el NAT dinámico
para el rango 10.10.3.64
hasta 10.10.3.254 con el
VLAN2 rango público 202.2.2.2
a 202.2.2.15
Profesor Daniel Díaz A. http://www.danieldiaza.com
VIRTUAL LOCAL AREA
NETWORK - VLAN
BIBLIOGRAFIA
Guía del segundo año, CCNA 3 y 4
Capítulo 9: LAN Virtuales, Pag 281

Guía del segundo año, CCNA 3 y 4


Capítulo 10: Protocolo de Trunking VLAN, Pag 309

Configuring VLANs, por CISCO.


Propiedad intelectual de Daniel Díaz @ 2014

http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_guide_chapter09186a00800d84be.html

ddiaz1610@gmail.com
MUCHAS GRACIAS

Profesor Daniel Díaz A. http://www.danieldiaza.com