Anda di halaman 1dari 9

LEMBAR KERJA

Teknik Komputer dan Jaringan

SMK MUHAMMADIYAH KAJEN


Hari / Tanggal
Mata Pelajaran
Kompetensi Praktikum

:
: Administrasi Server
: VPN Server

Sifat Praktikum
Guru Pembimbing

: Individu
: Bandiyo A.Md dan Miftakhul A S.Kom

Nama
Kelas
Nilai Laporan

:
: XII TKJ 1
:

A. Tujuan Praktikum (diisi oleh guru) :


Memahami prinsip kerja VPN server router Cisco + Radius Server dengan simulasi packet tracer
B. Jenis dan Spesifikasi Software yang digunakan (diisi oleh guru):
Sofware Aplikasi networking Packet Tracer untuk Windows

1. Buatlah topologi seperti di atas dengan packet tracer


2. Gunakan script CLI IOS di bawah ini untuk mengerjakannya
3. Mulailah dengan konfigurasi IP address pada masing-masing perangkat (Server, PC dan Router)

Gb. Konfigurasi Server Radius


4. Untuk router, lanjutkan dengan mulai konfigurasi hostname dan seterusnya
5. Untuk router, jika sudah di konfigurasi hingga selesai lakukan show run dan pastikan hasilnya seperti di
bawah ini
6. Pastikan pengujian PING dari PC ke semua router dan Server terhubung (replyfrom..ttl....)
A. Konfigurasi pada Router1
Router>ena
Router#conf t
----------------hostname Router1
aaa new-model
aaa authentication login VPNAUTH group radius local
aaa authorization network VPNAUTH local
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 2
crypto isakmp client configuration group ciscogroup
key ciscogroup
----------------pool VPNCLIENTS
netmask 255.255.255.0
crypto ipsec transform-set mytrans esp-3des esp-sha-hmac

crypto dynamic-map mymap 10


set transform-set mytrans
reverse-route
----------------crypto map mymap client authentication list VPNAUTH
crypto map mymap isakmp authorization list VPNAUTH
crypto map mymap client configuration address respond
crypto map mymap 10 ipsec-isakmp dynamic mymap
ip ssh version 1
spanning-tree mode pvst
----------------interface FastEthernet0/0
ip address 10.3.0.1 255.255.255.0
duplex auto
speed auto
crypto map mymap
no shutdown
----------------interface FastEthernet0/1
ip address 10.2.0.1 255.255.255.0
duplex auto
speed auto
no shutdown
----------------interface Vlan1
no ip address
shutdown
----------------ip local pool VPNCLIENTS 10.1.1.100 10.1.1.200
class less
----------------ip route 10.0.0.0 255.255.255.0 10.3.0.2
radius-server host 10.2.0.2 auth-port 1645 key cisco
------------------------------------Lakukan ping dari posisi router ini ke Radius Server, catat hasilnya (seharusnya terhubung)
Router#ping 10.2.0.2

B. Konfigurasi pada Router2


hostname Router2
ip ssh version 1
spanning-tree mode pvst
-----------------interface FastEthernet0/0
ip address 10.3.0.2 255.255.255.0
duplex auto
speed auto
no shutdown

interface FastEthernet0/1
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
no shutdown
-----------------interface Vlan1
no ip address
shutdown
ip classless
-----------------ip route 10.2.0.0 255.255.255.0 10.3.0.1
ip route 10.1.0.0 255.255.255.0 10.3.0.1
ip route 10.1.1.0 255.255.255.0 10.3.0.1

Lakukan ping dari posisi router ini ke Router1 dan ke Radius Server catat hasilnya (seharusnya terhubung)
Router#ping 10.3.0.1

Router#ping 10.2.0.2

C. Hasil konfigurasi yang berjalan di Router1 (setelah di konfigurasi)


router1# sh run
Building configuration...
Current configuration : 1410 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname router1
!
!
!
!
!
!
!
aaa new-model
!
aaa authentication login VPNAUTH group radius local
!
!
aaa authorization network VPNAUTH local
!

!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 2
!
!
!
crypto isakmp client configuration group ciscogroup
key ciscogroup
pool VPNCLIENTS
netmask 255.255.255.0
!
!
crypto ipsec transform-set mytrans esp-3des esp-sha-hmac
!
crypto dynamic-map mymap 10
set transform-set mytrans
reverse-route
!
crypto map mymap client authentication list VPNAUTH
crypto map mymap isakmp authorization list VPNAUTH
crypto map mymap client configuration address respond
crypto map mymap 10 ipsec-isakmp dynamic mymap
!
!
!
!
ip ssh version 1
!
!
spanning-tree mode pvst
!
class-map match-all less
!
!
!
!
!
interface FastEthernet0/0
ip address 10.3.0.1 255.255.255.0
duplex auto
speed auto
crypto map mymap
!
interface FastEthernet0/1
ip address 10.2.0.1 255.255.255.0

duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip local pool VPNCLIENTS 10.1.1.100 10.1.1.200
ip classless
ip route 10.0.0.0 255.255.255.0 10.3.0.2
!
ip flow-export version 9
!
!
!
!
radius-server host 10.2.0.2 auth-port 1645 key cisco
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
!
!
!
End

D. Hasil konfigurasi yang berjalan di Router2 (setelah di konfigurasi)


router2# sh run
Building configuration...
Current configuration : 740 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname router2
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!

!
!
!
!
!
!
!
!
!
ip ssh version 1
!
!
spanning-tree mode pvst
!
class-map match-all less
!
!
!
!
!
interface FastEthernet0/0
ip address 10.3.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 10.2.0.0 255.255.255.0 10.3.0.1
ip route 10.1.0.0 255.255.255.0 10.3.0.1
ip route 10.1.1.0 255.255.255.0 10.3.0.1
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!

end

Gb. Uji ping dari PC ke server radius

Gb. Login dengan user dan password yang sudah di konfigurasi di server radius

Buatlah userlagi seperti gambar di atas ! sehingga hasilnya sebagai berikut

Selesai..

Anda mungkin juga menyukai