Anda di halaman 1dari 2

MEMBUAT SIMPLE QUEUES OTOMATIS DENGAN DHCP SERVER-LEASE SCRIPTS

Scripts dibawah, copas saja ke IP->DHCP Servers-DHCP lease-sripts

Untuk limit bisa disesuaikan, dibawah adalah contoh limit 1:1 untuk kecepatan 1Mbps

:local queueName "Client- $leaseActMAC";

:if ($leaseBound = "1") do={


/queue simple add name=$queueName target=($leaseActIP . "/32") limit-
at=1024k/1024k max-limit=1024k/1024k comment=[/ip dhcp-server lease get
[find where active-mac-address=$leaseActMAC && active-address=$leaseActIP]
host-name];
} else={
/queue simple remove $queueName
}

Dan hasilnya akan seperti di gambar berikut:

Agar masuknya ke child dibawah parent

:local queueName "Guest $leaseActMAC";

:if ($leaseBound = "1") do={


/queue simple add name=$queueName parent=DHCP-IP place-before="DHCP-IP" target=($leaseActIP . "/32")
max-limit=1M/2M comment=[/ip dhcp-server lease get [find where active-mac-address=$leaseActMAC &&
active-address=$leaseActIP] host-name];
} else={
/queue simple remove $queueName
}