Anda di halaman 1dari 11

Cara Setting Mikrotik RB750 Untuk Warnet

Cara Setting Mikrotik RB750 Untuk Warnet Tujuan dari menambahkan mikrotik pada jaringan warnet terutama warnet yang pakai telkom speedy adalah untuk mempermudah pembagian besaran bandwith tiap-tiap PC atau komputer client.

Dikarenakan telkom speedy menggunakan jaringan ADSL/Kabel dan menggunakan modem router. Ketika pasang jaringan telkom speedy, setelah konek dengan kabel telp, jaringan atau internet bisa langsung dipakai. Gampang dan simple.

Nah yang jadi permasalahan adalah, ketika jaringan telkom speedy digunakan oleh banyak komputer, contohnya warnet, secara logika besarnya bandwith akan dipakai oleh semua komputer yang konek ke internet, besarnya bandwith akan diambil oleh komputer yang butuh bandwith banyak, seperti download menggunakan internet download manager, nonton video streaming YOUTUBE, jadi komputer atau client yang tidak melakukan keduanya akan mendapatkan jatah bandwith sangat sedikit. Karena modem router ADSL tidak mempunyai BANDWITH MANAGEMENT,. disinilah kita butuh yang namanya MikroTik sebagai Bandwith Management. Fungsi dasar mikrotik

Sebagai bandwith management Sebagai dial up modem router adsl Sebagai bridge Sebagai router dll

Sekian penjelasannya.. sekarang kita masuk : CARA SETTING MIKROTIK RB750 UNTUK WARNET PAKAI TELKOM SPEEDY Topologi Jaringan : ISP Telkom Speedy ---------> Modem Router Telkom Speedy (TP Link) ---------> MikroTik --------> Swicth Hub ----------> Clinet (1--->dst)

Langkah Kerja: 1. Tancapkan kabel lan dari MikroTik port1 (ether1) ke Modem ADSL Speedy 2. Tancapkan kabel lan dari MikroTik port2 (ether2) ke Switch 3. Tancapkan kabel lan dari Switch ke Komputer Pamasangan perkabelan selesai.. Berikutnya Setting MikroTik RB 750 Untuk Warnet Kita asumsikan adalah:

IP Address Modem ADSL Telkom Speedy adalah : 192.168.1.1 IP Address MikroTik port 1 (Public) adalah : 192.168.1.2 IP Address MikroTik port 2 (Local) adalah : 192.168.0.1 Primary DNS : 203.130.193.74, Secondary DNS : 203.130.206.250

Catt: * Harap sesuaikan dengan IP Address anda. 1. Remote Mikrotik RB750 menggunakan WinBox [download di sini] 2. Klik "Connect"

3. WinBox yang sudah connect dengan MikroTik RB750

4. Click "New Terminal" ganti nama ether1 dan ether2

Perintahnya sebagai berikut: /interface set 0 name=Public (port1 mengarah ke Modem ADSL Telkom Speedy) /interface set 1 name=Local (port2 mengarah ke Swicth Hub/Client) 5. Masukkan IP Address IP Address Public, Pada WinBox klik "IP" -----> Addresses ------->" + " -------> masukkan "192.168.1.2/24" --------> Interface " Public " ------> "OK" IP Address Local, Pada WinBox klik "IP" -----> Addresses ------->" + " -------> masukkan "192.168.0.1/24" --------> Interface " Local " ------> "OK" Atau Pada New Terminal /ip address add address=192.168.1.2 netmask=255.255.255.0 interface=Public /ip address add address=192.168.0.1 netmask=255.255.255.0 interface=Local 6. Masukan Gateway Pada New Terminal /ip route add gateway=192.168.1.1 (IP Aderess Modem ADSL Speedy) 7. Masukkan DNS Pada New Terminal /ip dns set primary dns=203.130.193.74 allow-remote-requests=yes /ip dns set secondary dns=203.130.206.250 allow-remote-requests=yes

Jika tampil keterangan seperti ini : " expected end of command (line 1 column 12)" ganti dengan perintah /ip dns set servers=203.130.193.74,203.130.206.250 allow-remote-requests=yes 8. Agar client bisa terhubung dengan Internet kita perlu memberi NAT Pada New Terminal /ip firewall nat add chain=srcnat out-interface=Public action=masquerade 9. Agar tidak perlu repot2 setting IP address pada setiap client, kita buat DHCP secara Otomatis, IPPOOL Pada New Terminal /ip pool add name=pool ranges=192.168.0.2-192.168.0.254 10. Restart MikroTik RB 750 .... Setingan MikroTik RB 750 sudah selesai, sekarang kita coba buka browser di salah satu PC Client, jika konek bararti setingan sudah benar..... Bisa juga dengan tes Ping dari computer client: klik Star ----> Run -----> Cmd -----> Enter Dari menu CMD klik

ping www.google.com -t ping www.yahoo.com -t ping www.detik.net -t ping 192.168.1.1 -t (ping ke modem speedy) ping 192.168.1.2 -t (ping ke port1 MikroTik /Public) ping 192.168.0.1 -t (ping ke port 2 MikroTik/Local)Jika ada Reply berarti OK

Catt: "Local Area Network" nya dipilih : "Obtain an Ip address automaticaly"

Membagi Rata Bandwidth Per Client

Tulisan ini hanya sekedar sharing untuk implementasi penggunaan Queue Tree diwarnet, dengan asumsi bahwa koneksi internet 2Mbps stabil (tidak naek turun) kesemua site, jumlah PC adalah 12 unit share maximum 1Mbps/pc (naek dan turun dengan otomatis jika user yang menggunakan bertambah, jika hanya 1 dan 2 user maka bandwith akan mentok di 1Mbps untuk tiap user). Kondisi jaringan ip lan router=192.168.0.14, billing server=192.168.0.13, asumsi billing server juga digunakan operator untuk ngenet. Tambahkan ip address pada lan router

ip address add address=192.168.0.14/28 interface=lan Kemudian kita lakukan marking connection pada setiap pc-client

ip firewall mangle add action mark-connection new-connection-mark=pc01 srcaddress=192.168.0.1 chain=prerouting ip firewall mangle add action mark-connection new-connection-mark=pc02 srcaddress=192.168.0.2 chain=prerouting ip firewall mangle add action mark-connection new-connection-mark=pc03 srcaddress=192.168.0.3 chain=prerouting ip firewall mangle add action mark-connection new-connection-mark=pc04 srcaddress=192.168.0.4 chain=prerouting ip firewall mangle add action mark-connection new-connection-mark=pc05 srcaddress=192.168.0.5 chain=prerouting ip firewall mangle add action mark-connection new-connection-mark=pc06 srcaddress=192.168.0.6 chain=prerouting ip firewall mangle add action mark-connection new-connection-mark=pc07 srcaddress=192.168.0.7 chain=prerouting ip firewall mangle add action mark-connection new-connection-mark=pc08 srcaddress=192.168.0.8 chain=prerouting ip firewall mangle add action mark-connection new-connection-mark=pc09 srcaddress=192.168.0.9 chain=prerouting ip firewall mangle add action mark-connection new-connection-mark=pc10 srcaddress=192.168.0.10 chain=prerouting ip firewall mangle add action mark-connection new-connection-mark=pc11 srcaddress=192.168.0.11 chain=prerouting ip firewall mangle add action mark-connection new-connection-mark=pc12 srcaddress=192.168.0.12 chain=prerouting

ip firewall mangle add action mark-connection new-connection-mark=op src-address=192.168.0.13 chain=prerouting Lakukan marking packet dari setiap connection yang terjadi

ip firewall mangle add action=mark-packet new-packet-mark=pc01 connection-mark=pc01 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc02 connection-mark=pc02 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc02 connection-mark=pc03 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc03 connection-mark=pc03 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc04 connection-mark=pc04 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc05 connection-mark=pc05 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc06 connection-mark=pc06 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc07 connection-mark=pc07 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc08 connection-mark=pc08 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc09 connection-mark=pc09 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc10 connection-mark=pc10 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc11 connection-mark=pc11 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=pc12 connection-mark=pc12 chain=prerouting passtrough=no ip firewall mangle add action=mark-packet new-packet-mark=op connection-mark=op chain=prerouting passtrough=no Tambahkan queue tree yang digunakan parent pada interface lan agar bandwith bisa terbagi rata queue tree add parent=lan max-limit=2M name=Downlink

Tambahan penggunaan PCQ agar setting lebih maximal lagi

queue type add name=PCQ-1Mbps kind=pcq pcq-rate=1024k pcq-classifier=dst-address Tambahkan child pada parent sesuai dengan packet mark

queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc01 packet-mark=pc01 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc02 packet-mark=pc02 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc03 packet-mark=pc03 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc04 packet-mark=pc04 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc05 packet-mark=pc05 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc06 packet-mark=pc06 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc07 packet-mark=pc07 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc08 packet-mark=pc08 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc09 packet-mark=pc09 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc10 packet-mark=pc10 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc11 packet-mark=pc11 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=pc12 packet-mark=pc12 queue=PCQ-1Mbps queue tree add parent=Downlink limit-at=128k max-limit=1024k name=op packet-mark=op queue=PCQ-1Mbps Maka setelah itu bandwith akan tershapping rata kepada setiap user, ini hanya sekedar share, untuk mengembangkan lebih jauh silahkan trial dan error sendiri.

Mikrotik - Cara Setting Proxy Server Pada Warnet

Ada banyak macam proxy, untuk basis OS windows bisa menggunakan winroute, winproxy, dll. untuk basis OS linux bisa menggunakan Squid. Disini saia menngunakan basis linux mikrotik. Selain handal digunakan sebagai router, mikrotik juga bisa digunakan sebagai web proxy server. settingannya dibawah ini yang digunakan

Spek PC : P3 800 Mhz, Mem 256, HD 30 Gb, 2 buah LAN Card (1 LAN onboard, 1 LAN tambahan) OS : Mikrotik OS 2.29.XX ISP : Telkom Speedy (Profesional) 1 line Modem merk Sanex standard bawaan speedy Client : 10 komputer Konfigurasi Mikrotik : 1. Setting Interface LAN card /interface set ether1 name=modem set ether2 name=lan Keterangan: ether1 diganti nama (interface) menjadi modem (koneksi dari dan ke modem) ether2 diganti nama (interface) menjadi lan (koneksi dari dan ke jaringan LAN) tujuannya biar mudah di ingat gak ada pengaruh ke akses-nya.

2. Setting IP address /ip address add address=192.168.1.2/24 interface=modem add address=192.168.10.1/24 interface=lan Keterangan : ip address standart (umumnya) modem 192.168.1.1 jadi ip interface dari-ke modem antara 192.168.1.2-254 (suka-suka)

3. Setting Gateway /ip route /add gateway=192.168.1.1

4. Setting DNS /ip dns set primary-dns=202.134.1.10 set secondary-dns=203.130.196.155 set allow-remote-requests=yes Keterangan : DNS digunakan untuk menerjemahkan alamat IP ke domain (****.com, ****.net, dll) atau sebaliknya, ada beberapa DNS untuk speedy pilih yang latency-nya kecil dengan nge-ping agar akses ke dns-nya agak cepat dikit.

5. Setting NAT /ip firewall nat add chain=srcnat action=masquerade out-interface=modem keterangan : Network Address Translation (NAT) fasilitas router untuk meneruskan paket dari ip asal dan atau ke ip tujuan dan merupakan standart internet yang mengizinkan komputer host dapat berkomunikasi dengan jaringan luar menggunakan ip address public.

6. Setting web Proxy (transparent) /ip web-proxy set enabled=yes set hostname=proxywarnetku set transparent-proxy=yes set cache-administrator=admin@warnetmu Keterangan : settingan web proxy yang lain menggunakan default bawaan mikrotik. hostname=hostname dns atau ip address web proxy cache-administrator=email admin yang bisa dihubungi ketika proxy error, yang akan ditampilkan pada browser client ketika proxy error.

7. Setting redirect ke proxy /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-port=3128

keterangan : Redirect digunakan untuk membelokkan/memaksa koneksi port 80 (www/web) dari client ke port 3128 default-nya web proxy mikrotik, jadi semua request client yang menggunakan port 80 (www/web) akan di belokkan ke web proxy mikrotik.

8. Memonitor web proxy /ip web-proxy monitor interval=1 keterangan : memonitor penggunaan web proxy mikrotik dengan interval waktu 1 detik