Anda di halaman 1dari 39

MATLAB Tutorial

PENDAHULUAN
MATLAB adalah bahasa tingkat tinggi interaktif yang memungkinkan Anda untuk
melakukan tugas-tugas komputasi intensif lebih cepat dibandingkan dengan bahasa
pemrograman tradisional seperti C, C + +, dan Fortran.
Anda dapat menggunakan MATLAB dalam berbagai aplikasi, termasuk sinyal dan pengolahan
citra, komunikasi, desain kontrol, uji dan pengukuran, model dan analisis keuangan, dan biologi
komputasi. Tambahan Toolbox (koleksi fungsi MATLAB tujuan khusus, tersedia secara
terpisah) memperluas aplikasi MATLAB untuk memecahkan masalah tertentu dalam area
aplikasi.
Berikut ini akan ditunjukkan dasar-dasar penggunaan Matlab :
Tutorial Dasar
Analisis dan Desain Sistem Kontrol (MATLAB)
Tutorial Dasar MATLAB
Tutorial Dasar Matlab
Berikut akan dijelaskan dasar-dasar penggunaan MATLAB untuk mengolah salah satu problem
matematika yaitu matriks.
Misalkan Anda akan mamanfaatkan MATLAB untuk membuat suatu matriks dengan jumlah
baris 3, kolom 3 (atau 3-kali-3) . Perhatikanlah bahwa semua baris harus memiliki jumlah
elemen yang sama. Anda ketik :
>> A = [2 6 9; 1 2 8; -4 1 -2]
Bila Anda menekan Tombol Enter, akan tampil
A=
2
1
-4

6
2
1

9
8
-2

Selanjutnya bila Anda menginginkan mendapatkan invers dari matriks A tersebut, anda cukup
mengetik
>> inv(A) {ENTER}

0.0976 -0.1707 -0.2439


0.2439 -0.2602 0.0569
-0.0732 0.2114 0.0163
Sederhana bukan?. Ada banyak perintah langsung yang telah dipersiapkan MATLAB untuk
mengolah matriks dan operasi matriks. Anda dapat meminta bantuan MATLAB untuk
mengetahui berbagai perintah berkaitan dengan matriks cukup dengan mengetik :
>> help matlab\elmat
Anda akan diperlihatkan berbagai perintah dasar-dasar matriks dan operasi matriks sebagai
berikut :

Inilah salah satu cara meminta bantuan penggunaan perintah MATLAB. Untuk mengetahui
fungsi perintah dan cara penggunaannya, Anda cukup klik perintah yang ditandai warna biru.
Misal Anda klik zeros , maka akan ditampilkan fungsi perintah zeros dan penggunaannya seperti
gambar berikut :

Selanjutnya Anda juga dapat memanfaatkan MATLAB untuk menggambar kurva (Plot Fungsi).
Lanjut Plot Fungsi

Plot Fungsi
Menggambar Grafik
Fungsi plot adalah untuk menggambar grafik dalam bentuk yang dapat berbeda-beda, tergantung
pada argumen masukan. Jika y adalah vektor, plot (y) menghasilkan grafik garis linear dari
elemen y terhadap indeks y. Jika Anda menetapkan dua vektor sebagai argumen, plot (x, y)
menghasilkan grafik dari y terhadap x.
Misalnya, Anda akan melukis grafik sinus dengan masukan vektor x nilai berkisar dari 0 sampai
2, maka lebih dulu menghitung sinus nilai-nilai x, lalu melukis dengan fungsi plot hasilnya:
x = 0: pi/100: 2 * pi;
y = sin (x);
plot (x, y)
Sekarang label sumbu dan menambahkan judul. Karakter pi \ menciptakan simbol. Lihat teks
string dalam dokumentasi Referensi MATLAB untuk simbol lebih lanjut:
xlabel (x = 0:02 \ pi)
ylabel (Sinus dari x)
title (Plot dari Fungsi Sinus, FontSize, 12)

Membuat Kurva Data Rangkap dalam Satu Grafik


Beberapa argumen pasangan xy dapat dibuat beberapa kurva dengan panggilan tunggal untuk
plot. Gambar secara otomatis akan menampilkan kurva dengan urutan standar warna yang
berbeda-beda antara kumpulan data. Lihat sumbu ColorOrder dan properti LineStyleOrder.
Misalnya, anda akan menggambar kurva tiga fungsi yang berhubungan dengan x, dengan
masing-masing kurva dibedakan dengan warna yang berbeda :

x = 0: pi/100: 2 * pi;
y = sin (x);
y2 = sin (x-0,25);
Y3 = sin (x-0,5);
plot (x, y, x, y2, x, Y3)
Perintah legend menyediakan cara mudah untuk mengidentifikasi plot individu:
legend('sin(x)','sin(x-.25)','sin(x-.5)')

Kembali

III.1.

Menetapkan Style Warna

Menetepkan Style dan Warna


Dimungkinkan kita menetapkan warna, style garis, dan tanda tertentu (seperti tanda + atau
linkaran) saat kita menggambar data menggunkan perintah plot.
plot(x,y,color_style_marker)
color_style_marker adalah sebuah string yang berisi satu sampai empat karakter (dibatasi tanda
petik) untuk membuat grafik dengan warna, style garis, dan jenis tanda :

String untuk warna diantaranya 'c', 'm', 'y', 'r', 'g', 'b', 'w', and 'k'. Ini
menunjukkan arti cyan, magenta, yellow, red, green, blue, white, dan black.
Strings style garis berupa '-' untuk garis padat, '' untuk garis putus-putus, ':' untuk
garis :, '-.' Untuk garis strip-titik.
Jenis tanda diantaranya adalah '+', 'o', '*', dan 'x' dan jenis tanda berisi adalah 's'
untuk persegi, 'd' untuk permata, '^' untuk segitiga atas, 'v' untuk segitiga bawah, '>'
untuk segitiga kanan, '<' untuk segitiga kiri, 'p' untuk pentagram, 'h' untuk
heksagram, dan kosong untuk tanpa tanda.

Kita dapat juga mengubah warna, garis dan tanda secara interaktif.
Menggambar Garis dan Tanda Garis
Jika kita menetapkan jenis tanda bukan style garis, MATLAB hanya akan menggambar berupa
tanda. Sebagai contoh,
plot(x,y,ks)
akan menggambar persegi hitam pada tiap titik data, tetapi tidak menghubungkan tanda dengan
garis.
Pernyataan
plot(x,y,r:+)
akan menggambar grafik garis titik merah dan menempatkan tanda plus pada tiap titik data. Kita
mungkin saja menginginkan menggunakan beberapa titik data untuk menggambar tanda
kemudian kita menggunkanannya untuk menggambar garis.
x1 = 0:pi/100:2*pi;
x2 = 0:pi/10:2*pi;
plot(x1,sin(x1),r:,x2,sin(x2),r+)

III.2.

Menggambar Grafik Lanjutan

Data Imajiner dan Kompleks

Bila argumen bagi plot berupa kompleks, bagian imajiner diabaiakan kecuali ketika saat plot
diberikan sebagai argumen kompleks tunggal. Untuk kasus khusus ini, perintah pendeknya
adalah menggambar bagian nyata vs bagian imajiner. Oleh karena itu,
plot(Z)
dengan Z adalah vektor atau matriks kompleks, adalah ekivalen dengan
plot(real(Z),imag(Z))
Sebagai cantoh,
t = 0:pi/10:2*pi;
plot(exp(i*t),-o)
axis equal
menggmabr poligon dengan 20- sisi dengan lingkaran kecil pada vertikalnya. Perintah axis
equal membuat tambahan sama panjang pada sumbu x dan y, yang menjadikan gambar tampak
lebih melingkar.

Menambah Gambar ke Grafik Yang Ada


Perintah hold memungkinkan kita menambah gambar pada grafik yang ada. Ketika kita ketik
hold on
MATLAB tidak mengganti grafik yang ada saat kita memberikan perintah gambar lain. Perintah
menambah data baru pada grafik yang ada, mengatur skala sumbu jika diperlukan.

Sebagai contoh, pernyataan ini pertama membuat gambar kontur fungsi peaks, selanjutnya
menyelipkan gambar berwarna pada fungsi yang sama.
[x,y,z] = peaks;
contour(x,y,z,20,k')
hold on
pcolor(x,y,z)
shading interp
hold off
Perintah hold on menyebabkan plot pcolor digambungkan dengan plot contour dalam satu
gambar.

III.3.

Jendela Gambar

Jendela Gambar
Fungsi grafik secara otomatis membuka jendela gambar yang baru saat tidak ada jendela pada
layar. Jika jendela gambar telah ada, MATLAB menggunakan jendela ini untuk keluaran grafik.
Jika terdapat banyak jendela gambar yang terbuka, MATLAB akan memiliki target kelauaran
gambar pada jendela sekarang (gambar terakhir yang digunakan atau di-klik)
Untuk membuat jendela gambar yang ada pada gambar sekarang, kita dapat meng-klik mouse
saat pointer pada jendela atau kita dapat mengetik
figure(n)

dengan n bilangan yang ada pada bar judul gambar. Hasil perintah akan ditampilkan pada jendela
ini.
Untuk membuka jendela gambar baru dan membuat padanya gambar sekarang, ketiklah
figure
Plot Rangkap dalam Satu Gambar
Perintah subplot memungkinkan kita untuk menampilkan plot rangkap dalam jendela yng sama
atau mencetaknya pada selembar kertas yang sama. Dengan mengetik
subplot(m,n,p)
akan membagi jendela gambar kedalam matrik m-kali-n sub gambar kecil dan memilih subplot
pada gambar yang muncul saat sekarang. Gambar diurutkan dari pertama pada baris pertama
jendela gambar, kemudian baris kedua, dan seterusnya. Sebagai contoh, pernyataan ini akan
mnggambar data dalam empat sub daerah yang berbeda pada jendela gambar.
t = 0:pi/10:2*pi;
[X,Y,Z] = cylinder(4*cos(t));
subplot(2,2,1); mesh(X)
subplot(2,2,2); mesh(Y)
subplot(2,2,3); mesh(Z)
subplot(2,2,4); mesh(X,Y,Z)

III.4.

Mengatur Sumbu

Mengatur Sumbu-sumbu
Perintah axis mendukung sejumlah pilihan untuk menyetel skala, orientasi, dan ukuran gambar.
Kita dapat juga menyetel pilihan ini secara interaktif.
Menetapkan Batas Sumbu
MATLAB menetapkan harga maksimum dan minimum data untuk memilih batas sumbu untuk
membuat jangkauan batas.. Perintah axis mengizinkan kita untuk menetepkan batas.
axis([xmin xmax ymin ymax])
atau untuk gafik tiga dimensi,
axis([xmin xmax ymin ymax zmin zmax])
Gunakan perintah
axis auto
agar MATLAB secara otomatis mengatur pemilihan batas.
Menetapkan Rasio Sumbu
axis

juga mengizikan kita untuk menetapkan sejumlah moda tertentu. Sebagai contoh,

axis square
membuat sumbu x dan sumbu y memiliki panjang yang sama.
axis equal
membuat pertambahan tanda batas skala pada sumbu-x dan sumbu-y yang memiliki panjang
sama. Ini artinya perintah
plot(exp(i*[0:pi/10:2*pi]))
diikuti dengan perintah axis square or axis equal akan merubah bentuk oval ke bentul
seperti linkaran.
axis auto normal
Menetapkan Tampilan Sumbu

Kita dapat menggunakan perintah axis untuk memperlihatkan sumbu atau menyembunyikannya.
axis on
akan memerperlihatkan sumbu. Dan telah menjadi penetapan pada MATLAB.
axis off
akan menyembunyikan sumbu.
Menetapkan Garis Kisi
Perintah grid akan memerintahkan agar garis kisi akan ditampilkan atau tidak. Pernyataan
grid on
akan menampilkan garis kisi dan
grid off
menghilangkan garis kisi.
Menberi Label Sumbu dan Judul Gambar
Perintah xlabel, ylabel, dan zlabel akan menambahkan label pada sumbu x-, y-, dan z.
Sedangkan perintah title akan menambahkan judul pada posisi atas gambar dan fungsi text
akan menyisipkan teks dimanapun pada gambar. Notasi TeX menghasilkan huruf yunani. Kita
dapat saja menetapkan secara interaktif.
t = -pi:pi/100:pi;
y = sin(t);
plot(t,y)
axis([-pi pi -1 1])
xlabel(-\pi \leq {\itt} \leq \pi)
ylabel(sin(t))
title(Graph of the sine function)
text(1,-1/3,{\itNote the odd symmetry.})

III.5.

Menyimpan dan Mengedit Gambar

Menyimpan Gambar
Untuk menyimpan gambar, pilihlah Save dari menu File. Untuk menyimpannya kita
menggunakan format grafik, seperti TIFF, bila ingin menggunakan format lain pilihlah Export
dari menu File.
Mengedit Gambar
MATLAB membuat bentuk sebuah grafik untuk memberi kemampuan untuk dapat dibaca, skala
sumbu yang dapat diubah, termasuk mengubah warna dan jenis garis sesuai diinginkan. Namun,
jika kita sedang membuat grafik, kita dapat saja mengubah bentuk gambar tertentu atau
menambah label, judul dan notasi lain untuk membentu menjelaskan data.
MATLAB menyediakan dua cara untuk mengubah gambar yang kita buat.

Menggunakan mouse untuk memilih dan mengedit objek secara interaktif


Menggunakan fungsi MATLAB pada garis-perintah atau file-M

Gambar Mesh dan Permukaan


MATLAB mendefinisikan sebuah permukaan dengan koordinat titik z diatas bidang x-y,
menggunakan garis lurus untuk menghubungkan titik-titik yang berdekatan. Fungsi gambar mesh
dan surf menampilkan permukaan dalam tiga dimensi. mesh menghasilkan permukaan kerangka
kawat yang berwarna hanya pada garis yang menghubungkan titik-titik tertentu. surf
menampilkan baik garis yang saling berhubungan juga menampilkan permukaan berwarna.
Visualisasi Fungsi dua variabel
Untk menampilkan fungsi dua variabel, z = f (x,y),

Membangkitkan matriks X dan Y yang masing-masing terdiri atas baris dan kolom
berulang, dalam domain fungsi.
Menggunakan X dan Y untuk mengevaluasi dan menggambar fungsi.

Fungsi meshgrid melakukan transformasi domain yang ditentukan oleh vektor tunggal atau dua
vektor x dan y kedalam matriks X dan Y yang digunakan untuk mengevaluasi fungsi dua variabel.
Baris X merupakan pemindahan dari vektor x dan kolom Y adalah pindahan dari vektor y.
Contoh Membuat grafik fungsi sinc
Contoh berikut ini mengevaluasi dan menggambar grafik fungsi dua dimensi sinc, sin(r)/r, antara
arah x dan y. R adalah jarak dari pusat, yang merupakan titik pusat matriks. Adding eps (a
MATLAB command that returns the smallest floating-point number on your system) avoids the
indeterminate 0/0 at the origin.
[X,Y] = meshgrid(-8:.5:8);
R = sqrt(X.^2 + Y.^2) + eps;
Z = sin(R)./R;
mesh(X,Y,Z,EdgeColor,'black)

Secara tetap, MATLAB memberi warna mesh menggunakan warna sekarang. Namun, contoh ini
mengunakan mesh berwarna tunggal dengan menetapkan sifat permukaan edgecolor . Lihatlah
halaman referensi surface.
Kita dapat membuat mesh tranparan dengan melakukan disable terhadap hidden.
hidden off
Lihat halaman hidden.

III.6.

Contoh Plot Berwarna

Contoh Plot Permukaan Berwarna


Plot permukaan sama dengan plot mesh kecuali muka persegi yang diberi warna. Warna muka
ditentukan oleh nilai z dan colormap. Pernyataan ini membuat grafik fungsi sinc sebagai plot
permukaan, memilih colormap, dan menambah garis warna untuk menunjukkan peta data yang
berwarna.
surf(X,Y,Z)
colormap hsv
colorbar

Plot Permukaan dengan Pencahayaan


Pencahayaan adalah teknik iluminasi objek berdasarkan arah sumber cahaya. Dalam kasus
tertentu, teknik ini dapat membuat perbadaan dalam terang permukaan. Pencahayaan dapat juga
digunakan untuk menambah wujud nyata grafik tiga dimensi
Contoh ini menggunakan permukaan sama seperti contoh sembelumnya, tetapi berwarna merah
dan menghilangkan garis mesh. Objek cahaya ditambahkan ke kiri camera
Setelah menambah cahaya dan menetapkan metode pencahayaan phong, menggunakan perintah
view untuk mengubah pandangan saat kita sedang melihat pada permukaan dari titik yang
berbeda dalam ruang (azimuth -15 dan elevasi 65 derajat). Terkhir, zoom pada permukaan
menggunakan toolbar zoom mode.
surf(X,Y,Z,FaceColor,'red,'EdgeColor,'none);
camlight left; lighting phong

view(-15,65)

III.7.

Image dan Cetak Gambar

Gambar Image
Larik dua dimensi dapat ditampilkan sebagai image, dengan elemen-elemen larik menentukan
kejelasan atau warna image. Sebagai contoh, pernyataan berikut
load durer
whos
Name
X

Size
648509

Bytes Class
2638656 double array

caption

228

112 char array

map

1283

3072 double array

mengambil file durer.mat, menambah tiga variabel ke workspace. Matriks X adalah matriks
648-kali-509 dan map adalah matriks 128-kali-3 yang merupakan peta warna dari image ini.
Catatan File MAT, seperti durer.mat, adalah file biner yang dapat dibuat pada satu platform
dan selanjutnya dibaca oleh MATLAB pada platform yang berbeda.
Elemen dari X merupakan bilangan bulat antara 1 dan 128, yang disediakan sebagai identitas
pada peta warna, map. Selanjutnya
image(X)

colormap(map)
axis image
menghasilkan Drers etching. Pada scan resolusi tinggi bagi persegi magic tersedia dalam file
lain. Ketiklah
load detail
dan kemudian menggunakan tomboh panah atas pada keyboard untuk mengeksekusi ulang
image, colormap, dan perintah axis. Pernyataan
colormap(hot)
menambah beberapa warna abad dua puluhan ke abad enam belasan. Fungsi hot membangkitkan
peta warna yang berisisi arsiran merah, oranye, dan kuning. Secara khusus, matriks image
tertentu telah memiliki peta warna spesifik yang sesuai dengan matriks tersebut. Lihatlah
halaman referensi colormap.
Mencetak Grafik
Kita dapat mencetak gambar MATLAB secara langsung ke printer yang terhubung dengan
komputer atau kita dapat juga memberi nama gambar ke file grafik format standar yang
didukung pleh MATLAB. Ada dua cara untuk mencetak dan mengubah gambar ke file :

Menggunakan pilihan Print dibawah menu File


Menggunaka perintah print

Mencetak dari Menu


Ada empat pilihan dibawah menu File yang digunakan untuk mencetak :

Pilihan Page Setup menampilkan kotak dialog yang mengizinkan kita untuk mengatur
karakteristik gambar pada halaman yang dicetak.
Pilihan Print Setup menampilkan kotak dialog yang menetapkan default pencetakan,
tetapi tidak mencetak gambar.
Pilihan Print Preview mengizinkan kita untuk melihat gambar yang akan tercetak.
Pilihan Print menmapilkan kotak dialog yang meminta untuk memilih pilihan
pencetakan satndar dan mencetak gambar.

Umumnya, gunakan Print Preview untuk menentukan apakah keluaran yang tecetak dinginkan
atau tidak. Jika tidak, gunakan kotak dialog Page Setup untuk mengubah setting keluaran.
Pilihlah kotak dialog Page Setup tombol Help untuk menampilkan informasi bagaimana
menampilkan halaman.
Mengubah gambar ke file grafik

Pilihan Export dibawah menu File mengizinkan kita untuk mengubah gambar ke berbagai
format file grafik standar.
Gunakan Perintah Print
Perintah print menyediakan banyak fleksibilitas pada jenis keluaran yang dikirim ke printer dan
menawarkan kita untuk mengendalikan pencetakan dari file-M. Hasilnya dapat dikirim secara
langsung ke printer atau dismpan di file tertentu. Berbagai format keluaran yang cukup banyak
telah tersedia seperti TIFF, JPEG, dan PostScript.
Sebagai contoh, pernyataan berikut ini akan menyimpan isi jendela gambar sebagai color
Encapsulated Level 2 PostScript dalam bentuk file yang disebut magicsquare.eps. Pernyatan
ini juga memasukkan tampilan TIFF, yang memberikan kemudahan untuk dapat ditampilkan
dalam banyak pengolah kata :
print -depsc2 -tiff magicsquare.eps
Untuk menampilkan gambar yang sama sebagai file TIFF dengan resolusi 200 dpi, gunakan
perintah
print -dtiff -r200 magicsquare.tiff
Jika kita ketik print pada baris perintah,
print
MATLAB mencetak gambar sekarang yang tampil pada printer default.

III.8.

Tutorial Matlab Untuk Sistem Kontrol

Berikut ini akan dijelaskan penggunaan Matlab untuk analisis dan desain sistem kontrol :

Membangun fungsi alih


Analisis sistem kawasan waktu
Analisis sistem kawasan frekuensi
Penggunaan Dasar Simulink
Simulink : Analisis Sistem Kontrol
Desain sistem kontrol

III.9.

Membangun Fungsi Alih

Membuat Fungsi Alih


Sebuah fungsi alih waktu-kontinu SISO (Single Input Single Output) berbentuk

dengan s adalah variabel Laplace, N (s) adalah polinomial pembilang, dan D (s) adalah
polinomial penyebut.
Untuk membuat fungsi transfer model SISO dalam bentuk polinomial anda dapat menggunakan:
G = tf (num, den)
yang mana num dan den adalah vektor baris berisi koefisien polinomial N (s) dan D (s). Vektor
baris ini terdiri dari koefisien pangkat menurun dari s. G adalah nama model objek tf.
Misalnya, Anda akan membuat fungsi transfer G(s) = s/(s2 + 2s + 1), maka ketiklah:
G = tf ([1 0], [1 2 1]);
Atau, Anda dapat menentukan model tf yang sama sebagai ekspresi rasional dalam variabel
Laplace:
s = tf('s');
G = s/(s^2 + 2*s + 1);

Setelah Anda mendefinisikan variabel s, Anda dapat membuat beberapa model tf dengan
menentukan ekspresi rasional tambahan s.
Cobalah Anda membuat fungsi transfer dengan mengetikkan

h = tf ([1 0], [1 2 10])


hasil perintah akan muncul dilayar
Transfer function :
s

s ^ 2 +2 s+ 10
Fungsi alih dalam bentuk Zero dan Pole :
Fungsi alih SISO kontinyu waktu dalam bentuk faktor (zero-pole-penguatan)
berbentuk:

dengan

k adalah penguatan bernilai skalar riil atau kompleks


z1 ,, zm adalah pasangan konjugasi zero riil atau kompleks dari fungsi alih
G(s) akar-akar pembilang N(s).
p1 ,, pn adalah pasangan konjugasi pole riil atau kompleks dari fungsi
alih G(s) akar dari penyebut D(s).

Buatlah bentuk fungsi alih dalam bentuk faktor (zpk) menggunakan :


G = zpk(z, p, k)

dengan z, p, dan k adalah vektor zero z1 ,, zm, pole p1 ,, pn, dan penguatan k.
Sebagai contoh, fungsi alih G(s) = s/(s2 + 2s + 1) dalam bentuk faktor adalah:

Fungsi alih ini memiliki zero pada s = 0, dua pole pada s = 1, dan penguatan sebesar 1.
Dengan perintah model zpk fungsi alih ini ditulis :
G = zpk([0],[-1 -1],[1]);

Bentuk lain, anda dapat menentukan model zpk yang sama dalam bentuk persamaan variabel
Laplace s:
s = zpk('s');

G = s/(s+1)^2;

Operasi lain yang tersedia termasuk sistem inversi, transposisi, dan pertransposition. Anda juga
dapat melakukan pengindeksan matriks seperti untuk mengekstraksi subsistem.
Cara lain untuk koneksi sistem
Operator

Fungsi

sys1 + sys2 parallel(sys1,sys2)


sys1 - sys2 parallel(sys1,-sys2)
sys1 * sys2 series(sys2,sys1)

III.10.

Hasil fungsi alih


Sistem paralel
Sistem paralel
Sistem seri

Analisis Sistem Kawasan Waktu

Analisis Sistem Kawasan Waktu


Respon waktu dapat digunakan menyelidiki perilaku transien model linier SISO (Single Input
Single Output) dan MIMO (Multiple Input Multiple Output) dalam kawasan waktu untuk input
dan gangguan tertentu. Dengan respon waktu ini, Anda dapat menentukan karakteristik sistem
seperti waktu naik (rise time), waktu penetapan (settling time), lewatan maksimum (overshoot),
dan kesalahan keadaan mantap (steady-state error) dari respon waktu. Anda dapat menggunakan
fungsi Control System Toolbox untuk respon langkah, respon impuls, respon kondisi awal, dan
simulasi linier umum. (Lihat Tabel)
Sebagai contoh, Anda dapat mensimulasikan respon terhadap masukan white noise
menggunakan lsim dan fungsi randn MATLAB.
Tabel : Fungsi MATLAB untuk Respon Waktu
Fungsi Diskripsi
gensig Membangkitkan sinyal masukan (untuk lsim)
impulse Menampilkan respon untuk masukan impulsa
initial Memberikan kondisi awal respon
lsim
Simulasi respon untuk masukan sembarang
step
Menampilkan respon masukan langkah
Anda dapat menyelidiki respon sistem linear saat diberi masukan impuls (impulse) dan langkah
(step) . Ada beberapa cara menampilkan respon sistem. Diantaranya anda dapat menggunakan
perintah impulse atau step :
Misalkan, anda akan menampilkan respon dari sistem LTI dengan fungsi alih berikut G(s) = s/(s2
+ 2s + 1) dengan masukan impuls dan langkah.
Untuk respon impuls, ketiklah

G = tf([1 0],[1 2 1]);


impulse(G)

Respon impuls ditampilkan sbb :

Untuk respon langkah, ketiklah


G = tf([1 0],[1 2 1]);
step(G)

Respon akan tampil di jendela gambar :

Anda juga dapat menampilkan respon dengan menentukan data input output dari respon. Anda
gunakan perintah:
[y,t] = step(G);
plot(t,y)

Akan ditampilkan respon dengan hasil yang dengan gambar diatas.

Menampilkan Plot Respon Model MIMO

Untuk model MIMO, fungsi respon waktu menghasilkan larik plot dengan satu plot per kanal
I/O (atau per output untuk initial dan lsim). Sebagai contoh,
G1 = [tf(10,[1 2 10]) , tf(1,[1 1])]
step(G1)

menghasilkan plot berikut,

Untuk mengetahui waktu puncak dan lain sebagainya, Anda dapat klik kanan pada plot dan pilih
Characteristics akan diperoleh

Analisis Sistem Menggunakan Quick Start


Matlab menyediakan cara cepat (Quick Start) untuk analisis sistem linear. Anda dapat belajar
bagaimana menganalisis respon kawasan waktu dan frekuensi satu atau lebih model linier
menggunakan GUI LTI Viewer.
sys1= tf([1 0],[1 0.5 1]);
sys2= tf([5 0],[1 2 2]);

ltiview(sys1,sys2)

Hasil analisis akan ditampilkan dalam gambar berikut

perintah ltiview memiliki default respon step.


Kembali
III.11. GUI LTI Viewer
Untuk menampilkan banyak plot pada LTI Viewer
a. Pilih Edit > Plot Configurations.
b. Dalam kotak dialog Plot Configurations, pilih jumlah plot yang akan dibuka.

akan muncul plot configuration sebagai berikut

Anda bisa menentukan jumlah plot dan tipe responnya. Silahkan anda mencoba.
III.12. Analisis Sistem Kawasan Frekuensi
Anda dapat memanfaatkan fungsi Control System Toolbox untuk analisis kawasan frekuensi
untuk menampilkan plot :

Bode
Nichols
Nyquist
Singular value

Tebel berikut menunjukkan tabel fungsi respon frekuensi dan penggunaannya.


Fungsi

Diskripsi

bode

Menampilkan gambar Bode

freqresp

Menghitung respon frekuensi untuk frekuensi tertentu

margin

Menghitung gain margin dan phase margins

nichols

Menampilkan gambar Nichols

nyquist

Menampilkan gambar Nyquist

bodemag

Respon magnitud Bode untuk model LTI

Berikut contoh penggunaan fungsi dalam tabel untuk analisis respon frekuensi.

Misalkan Anda akan menampilkan respon frekusnsi untuk sitem linear dengan fungsi alih :

Maka ketiklah
H = tf([1 1],[1 0.5 1]);
bode(H)

Akan ditampilkan gambar/plot Bode sbb :

III.13. Tutorial Simulink


Pada bagian ini, Anda akan diajak mempelajari penggunaan Simulink.

Memulai Simulink
Membangun Model
Membuat Subsistem
Melakukan simulasi model
Analisa Hasil Simulasi

III.14. Memulai Simulink


III.15. Memulai Simulink
Untuk memulai Simulink dan membuka library milik Simulink :
1.
2.

Jalankan program MATLAB.


Ketik simulink pada jendela peritah MATLAB .

maka akan nampak Library untuk Simulink seperti gambar berikut.

III.16. Membuat Model Baru


Untuk membuat model baru Anda harus :

Memilih File > New > Model di Library milik Simulink .

Maka akan terbuka jendela model yang masih kosong.

Untuk membuka model yang sudah ada :


1.

Pilih File > Open

akan nampak kotak dialog.


2. Pilih model (file .mdl ) yang ingin Anda buka , lalu klik Open.
MATLAB akan membuka model di jendela model .
III.17. Penyimpanan Model
Anda dapat menyimpan model dengan memilih apakah menggunakan perintah Save atau Save
As dari menu file. Model akan disimpan dalam bentuk format yang disebut model file (dengan
ektensi .mdl ) yang berisi diagram blok dan berbagai sifat-sifatnya.
III.18. Membangun Model
III.19. Membangun Model
Untuk membangun model, Anda membuka Simulink Library Browser lebih dulu dengan cara
Anda ketik simulink pada jendela MATLAB. Layar akan muncul seperti gambar berikut

Selanjutnya, misalkan Anda akan membangun model seperti gambar berikut

Yang Anda lakukan adalah langkah-langkah berikut


1. Bukalah blok kategori continuous - cari blok Transfer Fcn pada Simulink Library
Browser. Klik dan geser blok tersebut ke jendela model.
2. Carilah blok kategori sources - cari blok step klik dan geser ke jendela model.
3. Selanjutnya carilah Scope di Library Sink Klik dan geser ke jendela
4. Bukalah Library Math Operation, cari blok sum dan klik serta geser ke jendela
model seperti tampak pada gambar :

Untuk memilih objek yang akan dihubungkan, klik objek. Tekan Tombol Ctrl lalu arahkan
kursor ke objek ke dua kemudian tekan ENTER. Kedua Objek akan terhubung. Lakukan pada
semua Objek. Untuk Objek sum tarik dari sum ke penghubung plant dan scope. Beri nama model
misalkan latihan_1. Hasil akan diperoleh gambar berikut :

Blok Transfer Fcn akan dimodifikasi sesuai dengan model yang diharapkan. Klik dua kali blok
ini akan muncul jendela Function Block Parameter seperti gambar

Isilah numerator coefficient dengan [50] dan denumerator coefficient dengan [1 10 0] karena
s(s+10)=s^2 + 10s + 0. Dengan klik OK akan diperoleh model seperti gambar berikut.
III.20. Membuat Subsistem
Membuat Subsistem
Jika Anda berkeinginan membuat subsistem dengan Blok yang telah ada dalam satu kelompok,
maka Anda dapat mengubah kelompok blok ke subsistem.
Langkah langkah membuat susbsistem :
1. Lingkupi blok-blok dan garis penghubungnya yang akan Anda masukkan dalam satu
subsistem dengan cara klik mouse sambil menekan tombol kiri mouse setelah memilih

blok lepaskan tombol kiri. Hasil akan nampak pada gambar

2. Pilih Create Subsystem dari menu Edit. Blok-blok yang dipilih akan diganti dengan

3.

subsistem
Bila menginginkan untuk membatalkan pembuatan subsistem, Anda bisa memilih
Undo dari menu Edit

III.21. Melakukan Simulasi Model


Dasar-dasar Simulasi
Anda dapat mensimulasikan model setiap saat hanya dengan mengklik tombol Start pada Editor
Model . Namun, sebelum memulai simulasi, Anda mungkin ingin menentukan pilihan berbagai
simulasi, seperti waktu mulai simulasi dan waktu berhenti dan jenis solver yang digunakan untuk
menyelesaikan model pada setiap langkah waktu simulasi. Menentukan pilihan simulasi yang
disebut mengkonfigurasi model. Dengan perangkat lunak Simulink Anda dapat membuat
konfigurasi beberapa model, menyetel konfigurasi, memodifikasi dan mengatur konfigurasi yang
ada.
Setelah Anda telah menentukan atau memilih satu set konfigurasi model yang memenuhi
kebutuhan Anda, Anda bisa mulai simulasi. Simulasi berjalan dari waktu mulai ditentukan
sampai waktu berhenti yang ditentukan. Saat simulasi berjalan, Anda dapat berinteraksi dengan
simulasi dalam berbagai cara, menghentikan atau jeda simulasi dan melakukan simulasi model
lainnya. Jika kesalahan terjadi selama simulasi, simulasi dapat dihentikan dan penampil
diagnostik muncul yang membantu Anda untuk menentukan penyebab kesalahan.
Memulai Simulasi

Untuk memulai simulasi model, Anda pilih Start dari Simulation pada Menu Editor Model atau
klik tombol Start pada toolbol model.

Selama simulasi berlangsung, tanda waktu simulasi berjalan ditunjukkan Tombol Stop sebagai
perintah untuk menghentikan simulasi akan akan aktif dan muncul bersebelahan dengan tombol
Start. Tombol Pause akan menggantikan tombol Start pada toolbar model.
III.22. Analisa Hasil Simulasi
Analisa Hasil Simulasi
Untuk mengetahui bagaimana tanggapan keluaran model sistem, Anda dapat mengetahui hasil
keluaran model sistem milik Anda. Untuk mengetahuinya Anda dapat menggunakan berbagai
cara.
Menggunakan Blok Scope
Anda dapat menampilkan jejak keluaran selama simulasi menggunakan blok Scope. Lihatlah
gambar berikut

Tampilan Scope akan menunjukkan jejak keluaran. Blok Scope memberikan kesempatan Anda
untuk memperbesar atau memperkecil sesuai keinginan dan memberikan kemampuan untuk
menyimpan keluaran dalam bentuk data workspace.
Menggukana Variabel Keluaran
Dengan mengeluarkan nilai waktu dan keluaran, Anda dapat menggunakan perintah plot untuk
menampilkan hasil simulasi.

Blok dengan nama Out adalah blok keluaran dari library milik Ports & Subsystems. Jejak
keluaran, yout, dihasilkan oleh solver integrasi.

Anda dapat juga menjalankan simulasi ini dari menu Simulation dengan menetapkan varaiabel
untuk waktu, keluaran dan state pada panel Data Import/Export yang ada pada kotak dialog
Configuration Parameter. Selanjutnya Anda dapat menggambar hasil simulasi menggunakan
perintah
plot(tout,yout)
Menggunakan blok To Workspace
Blok To Workspace dapat digunakan untuk memperoleh keluaran. Model berikut sebagai
ilustrasi penggunaannya :

Variabel ya dan t akan tampil dalam workspace saat simulasi sdh selesai. Anda berarti telah
menyimpan vektor waktu dengan memasukkan blok clock ke blok To Workspace .
Blok To Workspace dapat menerima masukan array, dengan jejak elemen masukan disimpan
dalm variabel workspace.

III.23. Desain Sistem Kontrol


Desain Sistem Kontrol adalah merancang kontroler atau kompensator sedemikian rupa sehingga
sistem memiliki performansi yang dikehendaki.
Ada dua pendekatan desain : Desain kawasan waktu dan desain kawasan frekeuensi :
Desain kawasan waktu yang akan dijelaskan :
1. Desain kedudukan akar (root locus)
2. Desain Kompensator
3. Desain Kontroler PID
Desain kawasan frekuensi yang akan dijelaskan :
1. Desain Penguatan
2. Desain Kompensator
3. Desain Kontroler PID
MATLAB telah menyediakan alat bantu desain yaitu SISO Design Tool
III.24. Desain Kedudukan Akar
Desain Kududukan Akar (Root Locus Design)
Apa yang dimaksud dengan desain kedudukan akar?
Teknik yang umum untuk mencocokan kriteria desain sistem kontrol adalah desain kedudukan
akar. Pendekatan kedudukan akar dalam desain mencakup desain dengan cara memanipulasi
penguatan, pole dan zero didalam diagram kedudukan akar.
Ketika parameter sistem K berubah-ubah, maka diagram kedudukan akar sistem umpan balik
menunjukkan jejak-jejak pole lup tertutup sistem. Secara khusus, metode kedudukan akar
digunakan untuk mentala (tuning) penguatan lup sistem kontrol SISO dengan menetapkan pole
lup tertutup yang dikehendaki.
Perhatikan, sistem kontrol lup tertutup :

dengan G(s) adalah plant, H(s) adalah dinamika sensor , dan K adalah penguatan skalar yang
diatur-atur harganya. Pole lup tertutup adalah akar dari

Teknik kedudukan akar terdiri atas menggambar kedudukan pole lup tertutup dalam bidang
kompleks saat K berubah. Anda dapat menggunakan gambar kedudukan akar untuk menentukan
nilai penguatan yang sesuai dengan pole lup tertutup yang diinginkan.
CONTOH SEDERHANA
Untuk ilustrasi sederhana, perhatikan sistem umpan balik satu (H(s)=1) dengan plant memiliki
fungsi alih.

Anda menginginkan sistem dengan kriteria memiliki rasio redaman


Pertama, Anda menetapkan sistem LTI :
>> sys=tf([1],conv([1 0],conv([1 2],[1 4])));
>> rlocus(sys)
Maka akan ditampilkan kedudukan akar (root locus)

Anda bisa melakukan zoming gambar dengan perintah :


>> axis([-5 1 -3 3])

akan ditampilkan gambar hasil zooming :

Selanjutnya Anda dapat memberikan perintah sgrid (Z,Wn) untuk menampilkan garis yang
berhubungan dengan konstanta rasio redaman sebesar Z dan frekuensi alamiah sebesar Wn.
Untuk

maka Anda ketik saja :

>> sgrid(0.5,0)
Maka akan ditampilkan kedudukan akar sistem dan garis untuk rasio redaman sebesar 0,5.

Perintah rlocfind akan dapat ditentukan secar interaktif nilai K dan kedudukan akar titik yang
diinginkan dengan cara meletakkan kursor pada titik yang diinginkan.
>> [k,akar]= rlocfind(sys)

Jika Anda tepat menaruh kursor pada perpotongan garis dan root locus akan dihasilkan pada
jendela perintah MATLAB :
Select a point in the graphics window
selected_point =
-0.6706 + 1.1460i
k=
8.2055
akar =
-4.6614
-0.6693 + 1.1456i
-0.6693 1.1456i
Jadi nilai K yang tepat untuk sistem dengan rasio redaman sebesar 0,5 adalah K= 8,2055.
Desain Kedudukan Akar dapat menggunakan SISO TOOL Design. Silahkan Anda
menggunakan SISO Tool Design (root lcus design)
III.25. Desain Kompensator (SISO Tool Design)
Desain Kompensator
Pada dasarnya, desain kompensator berkaitan dengan Anda menambah pole dan zero baru
kepada sistem.

Anda telah melihat hasil mengurangi penguatan kompensator dapat mengurangi redaman dan
bila Anda menaikkan penguatan akan menimbulkan ketidakstabilan sistem atau sistem menjadi
tak teredam. Untuk itu, untuk memenuhi kriteria desain tidak mungkin hanya dengan cara
meningkatkan atau mengurangi penguatan pada kompensator saja.
Ada tiga parameter yang harus ditetapkan pada desain kompensator yaitu : pole, zero dan
penguatan. Setelah Anda memilih penguatan, kita dapat menambah pole dan zero pada
kompensator.
Menambah pole pada Kompensator
Anda dapat menambah pole riil pada halaman Compensator Editor. Klik tab Compensator Editor
, jadikan C sebagai pilihan, dan klik kanan dalam tabel Dynamics. Pilih Add Pole/Zero > Real
Pole. Gunakan kotak Edit Selected Dynamics untuk membaharui parameter pole parameters,
seperti ditunjukkan gambar berikut.

Anda dapat juga menambah pole yang riil secara pada plot root locus menggunakan jendela
Graphical Tuning. Klik kanan dalam plot root locus dan pilih Add Pole/Zero > Real Pole. Klik
pada daerah plot root locus yang Anda inginkan untuk menambah satu pole riil.
Pole riil yang ditambahkan dengan cara ini secara otomtis ditambahkan ke tabel pada halaman
Compensator Editor .
Setelah Anda menambah pole dan zero, plot tanggapan LTI Viewer akan berubah dan root locus
serta Bode plot tampil dengan pole dan zero baru.
This figure shows the Graphical Tuning window with the new poles added. For clarity, you may
want to zoom out further, as was done here.

III.26. SISO Design Tool


Anda dapat memanfaatkan alat bantu desain sistem kontrol yang telah disediakan oleh MATLAB
yaitu SISO Design tool.
SISO Design Tool menyediakan fasilitas desain kompensator untuk sistem umpan balik input
tunggal dan output tunggal, dan membantu Anda merancang sistem dengan cepat dan melakukan
berberapa tugas berikut :

Mengubah dinamika lu tertutup menggunakan teknik root locus


Menggambar tanggapan Bode untuk sistem lup terbuka
Menambah pole dan zero kompensator
Menambah dan mentala kompensator lead/lag dan filter
Memeriksa tanggapan lup tertutup (menggunakan LTI Viewer)
Mengatur margin penguatan dan margin fasa
Mengubah model antara waktu diskrit dan waktu kontinyu
Melakukan desain kompensator otomatis

Berikut Tutorial Desain Sistem Kontrol dengan SISO Design Tool.


III.27. Tutorial Desain Sistem Kontrol (SISO Design Tool)
Pada bagian ini akan dijelaskan bagaimana cara menggunakan SISO Design Tool.
Untuk memulai bagaimana memulai desain, Anda harus memiliki model sistem yang akan
dirancang. Misalkan model sistem yang akan dirancang memiliki fungsi alih lup terbuka :

Selanjutnya buatlah LTI model :


>> sys=tf([10],conv([1 0],conv([1 2],[1 4])));
lalu Anda membuka SISO Tool Design dengan mengetik :
>> sisotool(sys)
pada prompt MATLAB .
Perintah ini akan membuka SISO Design Task node untuk merancang kontrol dan Estimation
Tools Manager serta jendela penalaan grafis yang terdapat gambar root locus dan Diagram Bode
untuk sistem dalam bentuk default.
SISO Design Task Node (Tampilan halaman Architecture)

Jendela Penalaan Grafis untuk contoh model sistem diatas :

Menggunakan SISO Design Task Node dan Control and Estimation Tools Manager
SISO Design Task node pada Control and Estimation Tools Manager terdiri dari halaman berikut
untuk menentukan desain kontroler dan sifat-sifatnya:
Architecture:

Mengubah struktur umpan balik dan sinyal serta blok


Melakukan konfigurasi desain multi lup dengan cara membuka sinyal untuk
menghilagkan efek lup umpan balik yang lain.
Mengimport model ke dalam sistem Anda.
Mengubah waktu sampel sistem atau menyambung antara waktu sampel yang
berbeda untuk merancang kompensator yang berbeda.

Compensator Editor:

Mengedit pole, zero dan pengauatan kompensator secara langsung.


Menambah atau menghilangkan beberapa pole dan zero kompensator

Graphical Tuning:

Mengkonfigurasi plot desain pada jendela Graphical Tuning


Menggunakan plot desain untuk memanipulasi tanggapan sistem secara grafis
Analysis Plots:

Melakukan konfigurasi plot analisis pada LTI Viewer


Menggunakan analisis plot untuk melhat tanggapan sistem lup terbuka dan tertutup
Automated Tuning:

Membangkitkan kompensator secara otomatis menggunakan metode berbasis


optimisasi, PID, internal model control (IMC), linear-quadratic-Gaussian (LQG),
atau pemaparan lup.
Menggunakan alat bantu optmisasi yang mentala secara otomatis.