Anda di halaman 1dari 25

Mengenal Visual Foxpro

Mengenal Visual Foxpro


Microsoft Visual FoxPro 9.0 merupakan aplikasi database handal yang sangat mudah untuk dipelajari, meskipun demikian, bagi yang baru saja belajar, tentunya akan mengalami banyak kesulitan untuk memahami software database keluaraan Microsoft ini. Didalam program Visual FoxPro 9.0 mempunyai banyak sekali aplikasi pengembang yang dapat dimanfaatkan untuk merancang sebuah aplikasi yang bagus. Beberapa pengembang aplikasi yang dimilikinya adalah : Form Designer, View Designer, Menu Designer, Report Designer, Database Designer, Tabel Designer, Query Designer, Class Designer, project manager, Debugger, Jendela Command serta Program Editor. Saat ini Pemerintah Indonesia sedang melaksanakan program pengentasan kemiskinan, tentunya tidak hanya dibutuhkan suatu database orang-orang miskin saja, akan tetapi dibutuhkan pula orang yang mahir mengolah database dengan baik dan benar sehingga menghasilkan data yang akurat dan dapat dipertanggung jawabkan.

Melaluibahasan materi ini, saya berharap dapat membantu kepada para calon pengolah data atau para pengolah data yang selama ini didalam mengolah database menggunakan program pengolah angka seperti Microsoft Excel untuk beralih menggunakan program database dari Microsoft Visual FoxPro 9.0. Banyak sekali orang yang dapat membuat program database dengan program Microsoft Visual FoxPro 9.0 ini, tapi kebanyakan mereka puas jika telah berhasil membuat Form tampilan. Setelah itu mundur teratur kemudian berusaha mencoba program database lain, kemudian mundur kembali, ini dikarenakan mereka tidak mengerti cara membuat perintah untuk melakukan pengolahan data hingga terciptanya laporan yang baik dan benar sesuai yang diharapkan. Jika anda memulai belajar Visual FoxPro 9.0 tanpa adanya pemahaman awal tentang database, maka akan sulit bagi anda untuk menjadi pengolah data atau programmer database

yang handal. Pemahaman database secara Interaktif mendukung anda didalam mengasah logika dan mengenal berbagai macam perintah yang dapat dipakai hingga dapat menghasilkan laporan yang dikehendaki. Siapapun dapat saja mendesain form dengan warna yang bagus dan tampilan yang menarik, akan tetapi itu saja tidak banyak bermanfaat apabila form tersebut tidak dapat digunakan secara maksimal, seperti misal mengolah data yang di input melalui form yang membutuhkan adanya batasan validasi, bagaimana cara melakukan koreksi, penghapusan data, pemprosesan data, hingga jadi laporan yang sesuai dengan yang diharapkan. Anda bisa saja membuat suatu tabel dengan program Microsoft Visual FoxPro 9.0, kemudian mencetaknya semua data didalam tabel tersebut seperti mencetak pada program Microsoft Excel, tetapi begitu ada suatu kriteria atau syarat yang diinginkan didalam pencetakan, tentunya anda membutuhkan suatu perintah.Didalam bahasan ini diberikan pula bagaimana melakukan pengolahan data dan membuatan laporan pada kasus tertentu dari Microsoft Visual FoxPro 9.0 kedalam program Microsoft Excel atau sebaliknya. Jika anda perhatikan pertama kali menjalankan program Visual FoxPro, maka terdapat Jendela Visual FoxPro, Jendela View, Toolbar dan Menu Utama Visual FoxPro. Pada Jendela Visual FoxPro ini anda dapat menuliskan perintah dan logika dari Microsoft Visual FoxPro dimana masing-masing perintah akan menjalankan dan menghasilkan keluaran sesuai dari fungsinya. Jendela Visual FoxPro dari Microsoft Visual FoxPro ini sangat unik, saya katakan unik karena hampir semua perintah baik Internal dari Microsoft Visual FoxPro maupun perintah External dari sistem Operasi / Dos dapat dikenal dan dijalankan dari Jendela Visual FoxPro ini. 1. Manipulasi Jendela Visual FoxPro. Tampilan atau posisi dari Jendela Visual FoxPro dapat dimanipulasi sesuai kebutuhan, sehingga tampilannya sesuai dengan yang diharapkan. 2. Memindahkan letak dari Jendela Visual FoxPro. Posisi Jendela Visual FoxPro dapat dipindahkan ke segala arah, dengan cara menyeretnya ke lokasi baru dimana Jendela Visual FoxPro akan ditempatkan. 3. Menghilangkan sisa histori perintah yang pernah diketikan pada Jendela Visual FoxPro Jika anda mengetikan perintah pada Jendela Visual FoxPro, maka perintah tersebut akan direkam dan dapat digunakan kembali, tetapi jika perintah tersebut sudah banyak dan akan dihilangkan dari dalan Jendela Visual FoxPro, maka lakukan cara berikut ini: klik kanan mouse pada posisi dimana Jendela Visual FoxPro berada, pilih Clear. 4. Menyembunyikan serta menampilkan Jendela Visual FoxPro. Jika Jendela Visual FoxPro akan di sembunyikan atau ditampilkan, maka untuk melakukan itu terdapat banyak cara diantaranya :

Dari menu windows pilih Visual FoxPro Window Tekan kombinasi tombol Ctrl dan F2 5. Menampilkan Jendela Visual FoxPro diatas jendela lainnya. Jika anda menginginkan Jendela Visual FoxPro tampil selalu diatas dari jendela lainnya maka pada batang title Jendela Visual FoxPro klik kanan mouse pilih Dockable "Dockable" . Jika ada jendela lain seperti jendela project manager yang sedang dibuka, maka cobalah anda geser posisi Jendela Visual FoxPro dan letakan diatas jendela project manager atau jendela lainnya, maka akan tampak terlihat bahwa posisi dari Jendela Visual FoxPro yang telah di Dockable akan tampak selalu berada diatasnya. 6. Melebarkan / mengecilkan tampilan Jendela Visual FoxPro. Jika anda rasa keberadaan Jendela Visual FoxPro terlalu kecil atau terlalu besar maka Jendela Visual FoxPro dapat dirubah sesuai keinginan dengan cara: Tempatkan pointer mouse pada sisi Jendela Visual FoxPro hingga tanda pointer berubah menjadi tanda panah dua arah, klik, dan tahan mouse anda, kemudian geser kearah kanan untuk membesarkan dan ke kiri untuk mengecilkan Jendela Visual FoxPro 7. Membersihkan layar view. Jika anda mengolah data maka secara otomatis hasil perintah yang anda ketikan akan tampak hasilnya pada jendela view. Untuk menghilangkan tampilan hasil dari ketikan perintah yang anda ketikan tadi, ketikan perintah Clear. Dengan perintah ini maka layar Visual FoxPro 9.0 akan menjadi bersih kembali. 8. Mengatur konfigurasi visual foxpro 9.0 Untuk mengatur konfigurasi Visual FoxPro 9.0 agar berjalan sesuai yang diharapkan, dapat dilakukan melalui menu Tools Options. Kotak dialog Options memiliki sejumlah Tab yang didalamnya masing-masing mempunyai pilihan untuk dikonfigurasi sesuai kebutuhan. 9. Tab view Pada Tab View terdapat pilihan untuk mengatur tampilan Visual FoxPro 9.0, seperti menampilkan Status bar, Clock, Visual FoxPro results, System messages dan lainnya. 10. Status bar Jika terpilih maka tampilan dari status bar akan terlihat. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut :

Set Status Bar On | Off 11. Clock Apakah Jam akan ditampilkan pada status bar. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Clock On | Of 12. Visual FoxPro results Apakan akan menampilkan proses dari segala sesuatu pemprosesan yang dilakukan program Visual FoxPro 9.0. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Talk On | Off 13. System messages Apakah sistem akan menampilkan pesan pada status bar segala perintah setelah proses yang dilakukan. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Notify [Cursor] On | Off 14. Open last project on startup Jika terpilih maka Visual FoxPro 9.0 akan membuka proyek yang terakhir kali dibuka secara otomatis 15. Most Recently Used list contains Visual FoxPro 9.0 akan menampilkan daftar File yang dibuka terakhir sesuai dengan jumlah isian pada spiner. Pilihan ini akan tampil pada menu File. 16. List display count Maksimum data yang dapat ditampilkan pada objek dropdown list boxes. Default isiannya adalah 15 dan minimum dropdown list boxes berisi 5. Anda dapat menampilkan semua yang anda kerjakan melalui kotak dialog Options ini ke Jendela Visual FoxPro sehingga dapat digunakan untuk keperluan lainnya atau sekedar mengetahui apa saja yang sedang dikerjakan oleh Visual FoxPro 9.0. Caranya :

Tentukan pilihan setting anda pada kotak dialog Options, tekan dan tahan tombol SHIFT kemudian klik tombol OK. 17. Tab general Tab ini mengatur segala sesuatu yang umum, seperti pengaturan sound, programming, data entry, dan banyak pilihan lainnya. 18. Warning sound Off Pilihan ini mengijinkan anda untuk dapat membunyikan atau tidak membunyikan suara pada saat anda menjalankan perintah melalui Jendela Visual FoxPro atau membuat suatu program sehingga jika terjadi kesalahan dapat diketahui dengan adanya suara tersebut. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Bell On | Off Default Pilihan yang akan menampilkan suara dari bawaan program Visual FoxPro 9.0. adalah : Set Bell On Play Visual FoxPro 9.0 mengijinkan anda merubah suara bawaan dengan suara yang anda inginkan. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Bell To ding-dong.wav 19. Programming Cancel programs on Escape Anda bisa membatalkan proses program yang sedang berjalan dengan melakukan penekanan pada tombol Esc. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Excape On | Off Penekanan tombol Esc pada saat program berjalan akan menampilkan pesan interupsi seperti dibawah ini *** INTERRUPTED ***

Log compilation errors Akan menampilkan atau tidak ditampilkan pesan kesalahan pada saat kompilasi. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Logerrors On | Off SET DEVELOPMENT Anda dapat menampilkan tanggal dan waktu menjalankan program, dan lainnya dengan mengatur pada pilihan ini. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Perintah adalah sebagai berikut : Set Development On | Off dBASE compatibility Anda dapat menentukan apakan bahasa yang digunakan akan dibuat kompatibel dengan bahasa Foxbase+ / dbase+. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Compatible Foxplus on Use Visual FoxPro color palette Menggunakan default palet warna yang ditentukan Visual FoxPro 9.0. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Perintah adalah sebagai berikut : Set Palette On | Off Confirm file replacement Menampilkan pesan peringatan keamanan bisa terjadi proses data atau tidak. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Safety On | Off Browse IME control Menampilkan kontrol IME pada tampilan Browse. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Browseime On | Off 20. Data Entry

Navigation keys Menentukan kunci pemindahan kursor antar kontrol didalam Form. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Keycomp To Dos | Windows Pada objek Combo boxes, jika anda memilih pilihan MS-DOS Complatible, maka proses pemindahan dari titik fokus menggunakan tombol ENTER atau SPACEBAR Untuk pilihan WINDOWS Complatible, maka anda melakukan penekanan pada tombol SPACEBAR, ALT+UP ARROW, atau ALT+DOWN ARROW. Fill new records with current values Visual FoxPro 9.0 akan secara otomatis menampilkan record yang sudah diisikan kedalam isian record yang baru. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Carry On | Off Enter or Tab to exit fields Anda dapat mengatur agar Visual FoxPro 9.0 melakukan tindakan keluar dari proses pengisian data jika pilihan ini terpilih. Penulisan perintah pada Jendela Visual FoxPro atau Jendela Program adalah sebagai berikut : Set Confirm On | Off 21. Tab data Mengatur segala sesuatu yang terkait dengan data, anda dapat menentukan bagaimana suatu tabel dibuka, apakah akan ditampilkan header dari tabel tersebut, menggunakan index yang unik, menentukan berapa jumlah byte yang dapat ditampung didalam file memo, menentukan pemilihan penguncian File dan record. Menggunakan teknik optimasi Rushmore. 22. Tab Remote data Digunakan jika anda menggunakan data jarak jauh, anda dapat mengatur batas waktu koneksi, berapa jumlah record yang dapat diambil, menggunakan metode perintah SQL untuk update data. Berapa jumlah record data minimal yang dapat dirubah. 23. Tab file location Dengan menentukan lokasi kerja dari suatu program maka diatur pada pilihan ini sehingga Visual FoxPro 9.0 dapat mencari data yang dimaksud dengan cepat. Tentukan direktori kerja

didalam pilihan Default Directory, lakukan modifikasi jika anda ingin merubah ke direktori yang diinginkan, klik OK dan terakhir klik tombol Set As Default untuk menyimpan perubahan. 24. Tab forms Pengaturan Form dapat diatur melalui kotak dialog Form, dimana anda dapat merubah ukuran spasi Grid, pengaturan area disain, merubah pergerakan kursor. 25. Tab projects Pada Tab Projects terdapat pilihan apakah unsur objek yang ada didalam project di klik 2 kali akan dijalankan atau dibuka secara desain modifikasi. 26. Tab controls Disini dapat dilibatkan class-class, anda bisa menambah class melalui Tab ini. 27. Tab regional Anda dapat mengatur format dari tanggal yang akan dipakai, batasan yang digunakan, jenis format jam yang akan digunakan, pembatas desimal, simbol mata uang dan lainnya. 28. Tab debug Anda dapat merubah warna tempat tampilan huruf dan latar belakang, teknik tampilan pelacakan dan lainnya. 29. Tab editor Anda dapat memformat editor pada Tab ini, bagaimana tampilan comentar, warna perintah yang akan dituliskan dan lainnya. 30. Tab file mapping Mengatur pemetaan pada kontrol yang akan dibuat jika anda melakukan Drag tabel atau field ke dalam Form dan lainnya. 31. Tab IDE Pada Interactif Development Environment, anda dapat mengatur setting tampilan, ekstensi dari File, mengatur Tab dan Inden, Pengaturan Huruf, perataan Objek dan lainnya. 32. Tab reports Pengaturan yang berhubungan dengan laporan dapat anda setting disini, ditampilkan atau tidak grid didalam pendesainan laporan, default huruf yang dipakai dan lainnya.

Jika anda telan melakukan perubahan settingan pada kotak dialog Options, untuk menyimpannya lakukan dengan memilih tombol Set As Default, kemudian klik tombol OK. 33. Element layar utama Visual FoxPro 9.0 Tampilan layar utama Visual FoxPro 9.0 memiliki beberapa elemen yang dapat dipergunakan. Elemen tersebut adalah : 34. Title bar / batang judul Title bar adalah baris yang menyatakan judul aplikasi yang sedang berjalan atau aktif. Title bar pada jendela Visual FoxPro 9.0 dapat diganti atau dirubah sesuai dengan kebutuhan, misalnya tulisan title bar akan diganti dari Microsoft Visual FoxPro menjadi Aplikasi Inventory dengan menuliskan perintah pada Jendela Visual FoxPro sebagai berikut : _screen.Caption="Aplikasi Inventory" Maka title bar berubah dari Microsoft Visual FoxPro menjadi Aplikasi Inventory. Atau dapat juga dengan perintah seperti dibawah ini: _vfp.Caption="Program Koperasi Tunas Muda" Dengan cara diatas maka title bar akan berubah menjadi Program Koperasi Tunas Muda 35. Menu bar Baris yang berisi menu dan submenu dari Visual FoxPro 9.0 yang dapat dipergunakan sesuai dengan fungsinya. Menu bar pada Visual FoxPro 9.0 terdiri dari : File, Edit, View, Format, Tools, Program, Window dan Help. File Berisi segala perintah yang berhubungan dengan pengelolaan File-File. Edit Berisi segala perintah pengeditan seperti membatalkan, memotong, duplikasi dan perintah lainnya. View Menu ini untuk menampilkan jenis-jenis toolbars. Adapun jenis toolbars yang tersedia adalah : Color Palette, Database Designer, Form Controls, Layout, Print Preview, Query Designer,

Report Control, Standart dan View Designer. Format Berisi segala sesuatu yang berhubungan dengan pemformatan seperti memformat atribut huruf, membuat indent, membuat komentar, menentukan spasi dan lain-lain. Menu Format ini tampil jika posisi kursor anda terdapat pada Jendela Visual FoxPro. Jika posisi kursor terdapat diluar Jendela Visual FoxPro maka Menu Format ini tidak muncul. Contoh ini menjelaskan penggunaan dari salah satu isi dari Menu Format yakni Comment. Menu Comment digunakan Visual FoxPro 9.0 untuk menandakan suatu baris perintah yang tidak ikut terbaca didalam program. Tanda jika perintah berisi Comment adalah dengan adanya tanda seru diapit tanda bintang ( *!* ) didepan tulisan komentar tersebut. *!* "Quit " -> Perintah keluar dari visual fox pro 9.0 Anda dapat membuat komentar sebanyak anda mau, mengingat didalam membuat program atau mengolah data sering kali terjadi lupa tentang urutan perintah atau alur pemprogramman, untuk itu perintah Comment ini sangat membantu. Tools : Berisi daftar perintah yang terkait dengan utilitas seperti Wizard, Task Pane, Macros, Toolbox, Debugger dan lainnya. Program Menu ini berisi tentang segala aktifitas program, seperti menjalankan program ( ! Do.. ), membatalkan jalannya program ( Cancel ) , mengkompile program dan lain-lain. Window: Berisi perintah untuk mengatur tampilan window, memilih window yang akan diaktifkan, menampilkan serta menyembunyikan Jendela Visual FoxPro dan lain-lain. Help : Berisi semua bantuan yang berhubungan dengan Visual FoxPro 9.0 36. Jendela Visual FoxPro / perintah Jendela Visual FoxPro ini sangat unik, dikatakan unik karena hampir semua perintah baik Internal Visual FoxPro 9, maupun perintah External dari sistem operasi / dos juga dikenal dan dapat dijalankan dari Jendela Visual FoxPro ini. Didalam Jendela tersebut, anda dapat menuliskan perintah-perintah dari Visual FoxPro 9, setiap

perintah yang di tuliskan lewat Jendela Visual FoxPro akan langsung terlihat hasilnya pada Jendela View. Hal ini memudahkan setiap orang pemakai Visual FoxPro 9.0 untuk melakukan trial and error sebelum menghasilkan satu laporan. Sehingga kesalahan dapat diketahui sebelumnya. Untuk menampilkan atau menghilangkan Jendela Visual FoxPro dapat dilakukan dari menu Window Visual FoxPro window atau Ctrl+F2 37. Status bar Status Bar atau baris status yang berfungsi untuk menampilkan status atau kejadian yang sedang berlangsung. Posisi baris status berada pada baris paling bawah pada layar utama Visual FoxPro 9.0 38. View window Adalah layar lebar yang berfungsi untuk tempat menampilkan hasil proses dari perintah Visual FoxPro 9.0 yang ditulis melalui Jendela Visual FoxPro. Salah satu kehebatan dari software Visual FoxPro 9.0 ini adalah : Operator / pamakai dapat melihat langsung hasil yang dikerjakannya melalui jendela ini 39. Toolbar Batang panjang dibawah menu yang berisi beberapa icon yang dapat digunakan untuk mempercepat proses. Keseluruhan toolbar dapat ditampilkan atau di sembunyikan melalui menu View Toolbars kemudian centang kotak yang ada didepan toolbar kemudian klik tombol OK, maka toolbar yang ditandai akan tampil. Toolbar dapat pula ditampilkan dengan beberapa cara, diantaranya adalah dengan cara : meletakan pointer mouse ke batang toolbar aktif kemudian klik mouse sebelah kanan pada batang toolbar tersebut lalu pilih toolbar yang akan ditampilkan. Toolbar dapat disembunyikan dengan cara yang sama yakni dengan cara menghilangkan pilihan pada kotak toolbar terpilih. 40. Jenis-jenis toolbar Visual FoxPro 9.0 mempunyai banyak toolbar yang dapat digunakan didalam pembuatan aplikasi, diantaranya 41. Toolbar standard

Toolbar yang tampil pertama kali saat Visual FoxPro 9.0 dijalankan, berfungsi untuk melakukan segala sesuatu yang umum, seperti membuat File baru ( Project, form, report, dll ), menyimpan hasil kerjaan, menjalankan form dan lain-lain. 42. Toolbar database designer Icon yang ada didalam toolbar ini dapat dipakai untuk mendefinisikan tabel didalam database designer, seperti menambah tabel, melakukan relasi antar tabel, membuat view, dan lain-lain. 43. Toolbar from designer Digunakan untuk mendisain antar muka form, didalamnya terdapat icon untuk merapikan, menampilkan dan menyembunyikan peralatan, jendela properti dan lain-lain. 44. Toolbar layout Icon-icon yang ada pada toolbar ini berfungsi untuk mengatur tampilan objek pada form, seperti meratakan objek, meletakan objek didepan atau dibelakang objek lain dan lain-lain. 45. Toolbar color palette Icon-icon yang ada pada toolbar ini dapat digunakan untuk merubah warna suatu obyek didalam form. 46. Toolbar form controls Icon-icon yang ada dapat berfungsi untuk membuat objek yang dapat digunakan pada form, seperti objek tombol, spinner, image, option group dan lain-lain. Toolbar ini dipakai sangat dominan didalam pembuatan aplikasi pada form. 47. Toolbar query design dan view designer Icon-icon yang ada digunakan pada saat anda melakukan proses query, seperti menambah Tabel, menghapus Tabel serta menampilkan perintah SQL dan lain-lain. 48. Toolbar print preview dan report control Icon-icon yang ada digunakan untuk melakukan segala aktifitas yang dibutuhkan pada laporan, seperi mencetak, menuju ke halaman yang diinginkan dan lain-lain. 49. Customize toolbar Icon yang ada didalam toolbar dapat ditambahkan atau dikurangi dengan cara, klik kanan mouse pada batang toolbar, pilih Customize Akan muncul kotak Customize Toolbar, pilih pada isi pilihan Categories, kemudian pada pilihan

Button sebelah kanannya klik salah satu button kemudian lakukan drag atau seret icon tersebut kearah batang toolbar yang ingin ditambahkan. Misalnya saja klik pilihan Report pada Categories, klik icon layout toolbar yang ada pada posisi paling kanan, seret kearah batang toolbar standard yang ada diatas layar utama Visual FoxPro 9.0, lepas mouse dan sekarang tampak icon layuot toolbar telah ditambahkan pada toolbar standard. 50. Menghilangkan icon dari dalam toolbar Untuk mengeluarkan atau menghilangkan icon yang ada didalam toolbar, adalah klik icon yang akan dihilangkan kemudian seret kearah luar toolbar menuju area jendela view. Icon yang diseret tadi jika diletakan pada jendela view maka akan membentuk toolbar baru. 51. Posisi toolbar Posisi toolbar yang tampil dapat dipindah-pindahkan sesuai keinginan dengan cara menyeretnya ke lokasi yang baru. 52. Membuat toolbar baru anda dapat membuat toolbar sendiri dan akan diisikan dengan icon yang anda butuhkan saja, caranya : dari menu utama pilih View Toolbar, kemudian klik tombol New, tentukan nama toolbar yang akan dibuat. Setelah toolbar terbentuk, masukan icon yang anda inginkan dengan cara yang sama seperti diatas. 53. Keluar dari program. Untuk keluar dari program Visual FoxPro 9.0 Klik menu File Exit. Keluar dari program Visual FoxPro 9.0 dapat juga dilakukan dengan menekan kombinasi tombol Ctrl + F4, atau mengklik langsung button Close yang ada di pojok kanan atas program Visual FoxPro 9.0, atau dengan mengetikan perintah Quit pada Jendela Visual FoxPro.

Visual Foxpro
Elemen Dasar Visual Foxpro

Elemen dasar Visual Foxpro terdiri dari Tipe Data (Type Data), Operator, Fungsi/Procedure dan perintah.

1. Tipe Data

Dalam membuat program tidak terlepas dari rumus dan formula yanng berupa ekspresi. Dalam Visual Foxpro ekspresi atau rumus tidak boleh jenis data (type data) bercampur. Tipe-tipe data yang tersedia dalam Visual Foxpro adalah karakter, karakter biner, numerik dan bilangan pecahan, bilangan bulat, bilangan pecahan ganda, bilangan uang, tanggal, tanggal plus jam, logika (L) dan memo (M). Tipe Karakter Tipe karakter adalah tipe data string berupa deretan karakter alfabet, dari A sampai Z, dan angka 0 9 yang dingggap karakter. Tipe karakter dibuat menggunakan (diapit) tanda kutip tunggal, kutip ganda atau tanda siku. Contoh : Visual Foxpro SWALT Info [Visual Foxpro Programming]

Tipe karakter Biner Tipe karakter biner seperti tipe data karakter biasa, tetapi bersifat permanen. Tipe Numerik dan Bilangan Pecahan Tipe numerik (float) adalah tipe angka atau angka pecahan yang mempunyai jangkauan 0.999999999E+19 sampai dengan 0.999999999E+20.

Tipe Bilangan Bulat Tipe bilangan bulat adalah tipe data angka yang mempunyai jangkauan antara-2147483647 sampai dengan 2147483646. Tipe Bilangan Pecahan Ganda Tipe bilangan pecahan ganda (lebih besar dari tipe float) adalah tipe angka atau angka pecahan yang mempunyai jangkauan +/-4.94065645841247E-324 sampai +/-8.9884656743115E307. Tipe Bilangan Uang Tipe bilangan uang adalah tipe data untuk bentuk data berupa uang yang mempunyai jangkauan 922337203685477.5808 sampai dengan 922337203685477.5807. Untuk menyatakan bilangan bentuk uang kita harus menggunakan simbol $ (bentuk default). Tipe Tanggal Tipe tanggal adalah tipe data untuk bentuk data tanggal (date). Format defaultnya adalah bentuk tanggal US, dengan format mm/dd/yy (jika SET CENTURY OFF). Untuk memudahkan kita membentuk format tanggal tertentu, perhatikan tabel dibawah ini :
Pengaturan AMERICAN ANSI BRITISH/FRENCH GERMAN ITALIAN JAPAN / TAIWAN USA MDY DMY Format saat SET CENTURY OFF mm/dd/yy yy.mm.dd dd/mm/yy dd.mm.yy dd-mm-yy yy/mm/dd mm-dd-yy mm/dd/yy dd/mm/yy

YMD

yy/mm/dd

Tipe Logika (L) Tipe logika (L) adalah tipe data untuk bentuk logika TRUE (benar), dapat digunakan simbol T,t,Y atau FALSE (salah) dapat digunakan simbol F,f,N,n. Tipe Memo Tipe memo adalah tipe data untuk digunakan sebagai karakter panjang, dan hanya berlaku untuk field bukan variabel. Memo berukuran tidak tetap, seperti karakter dan disimpan dalam file .FPT. Tipe Umum (G) Tipe data umum biasa dapat dipakai untuk menyimpan data OLE (Object Linking Embedded), seperti spreadsheet, grafik, suara yang dibuat dari aplikasi lain.

2. Operator

Operator adalah simbol yang dipakai untuk operasi tertentu, biasanya dipakai dalam ekpresi atau rumus tertentu. Contoh simbol simbol operator seperti pada tabel berikut :
Operator = + Kegunaannya Pengujian kesamaan Penjumlahan Semua tipe Numeric, Character, Date, DateTime Logical Numeric Numerik Untuk tipe data

! atau NOT Negasi (kebalikan) *, / ^ Perkalian/Pembagian Perpangkat

Catatan : Dalam suatu ekpresi variabel harus memiliki tipe data yang sama, jika tidak sama harus dikonversikan dahulu tipe datanya.

3. Fungsi / Procedure

Fungsi atau procedure adalah kumpulan instruksi tertentu untuk tujuan tertentu yang diberi nama, sehingga jika ingin dipakai hanya menyebutkan nama fungsinya saja.

Visual Foxpro
Tampilan Utama Visual Foxpro

1. Jendela Microsoft Visual Foxpro Saat Microsoft Visual Foxpro dijalankan, sebuah jendela kerja akan tampil seperti gambar dibawah ini.

--> MenuBar -->Toolbar

--> Command Window

2. Menu Bar

3. ToolBar Toolbar, seperti pada gambar dibawah, berisi ikon-ikon yang berfungsi mepersingkat perintah pada Menu Bar.

4. Jendela Project Manager

Jendela Project Manager menunjukkan proyek aktif dan file-file penyusun proyek tersebut.

5 Jendela Properties

Jendela Properties digunakan untuk mengubah properti suatu objek. Pengaturan properti pada jendela Properties dapat dilakukan dengan berbagai cara : Dengan mengetikkan nilai yang diinginkan (contoh : properti Caption, Width). Memilih nilai yang telah ada (contoh : properti Style, Aligment). Memilih sampel yang ada (contoh : properti BackColor, ForeColor). Browsing (contoh : properti Picture).

Selain dengan jendela properties, pengaturan properti juga dapat dilakukan lewat program melalui baris-baris listing.

Visual Foxpro
Cara Instal Visual Foxpro 9.0

Sebelum melakukan Instalasi Program Microsoft Visual foxpro ada beberapa hal yang perlu diperhatikan sebelumnya, yaitu : Minimum Spec Komputer : Processor Sekelas Pentium atau lebih tinggi. RAM min 128MB atau lebih Hardisk : 200 MB (full install) Monitor dan VGA = 800600 dengan 256 warna OS : Microsoft Windows 2000 SP3 atau lebih tinggi, Windows XP atau Windows Server 2003. Namun hasil aplikasi nantinya dapat dijalankan di Windows 98 atau lebih tinggi. Jika seluruh persyaratan tersebut telah terpenuhi, maka proses install Visual Foxpro seharus nya dapat berjalan dengan baik. Proses instalasi akan diawali dengan install paket Prerequisites dahulu dan dilanjutkan dengan proses install visual foxpro. Proses instalasi : 1. Jalankan file SETUP.EXE maka akan muncul gambar seperti dibawah ini. lalu klik tahap yang pertama 1 Prerequisites, akan muncul gambar agreement pilih i accept ... lalu klik continue, kemudian akan muncul gambar lainnya pilih install now, setelah itu muncul windows proses install data Prerequisites setelah selesai visual foxpro akan meminta untuk merestart komputer anda.

2. Lalu klik tahap yang kedua 2 Visual Foxpro.visual foxpro akan mengcopy data yang di butuhkan untuk install Jika sudah akan muncul perintah untuk memasukkan Serial Number. masukkan serial number di kotak Product Key. Jika sudah lalu klik Continue, lalu akan muncul windows pilihan install, kapasitas harddisk klik install now, akan muncul windows proses penginstalan tunggu hingga selesai. jika sudah selesai akan muncul pemberitahuan yang menyatakan Setup is Complete. Kemudian klik Done

3. Selanjutnya langsung saja klik Exit (lewati tahap 3 Service Releases) karena tidak terlalu penting .

4. Dan selesai sudah proses Instalasi Visual foxpronya.