Anda di halaman 1dari 11

Tutorial

Pengenalan Software Vensim PLE













oleh
Lukmanulhakim Almamalik

Januari 2004









Tutorial Pengenalan Vensim PLE


Sekilas Vensim PLE
Vensim merupakan suatu perangkat pemodelan visual yang membolehkan Anda
untuk melakukan konseptualisasi, dokumentasi, simulasi, analisis, dan optimasi
model sistem dinamis. Vensim PLE (Personal Learning Edition) merupakan suatu
konfigurasi dari Vensim yang dirancang sehingga penggunanya lebih mudah untuk
mempelajari sistem dinamik. Vensim PLE menawarkan suatu cara yang sederhana
dan fleksibel dalam membangun model simulasi dari diagram simpal kausal (causal
loop diagram) atau diagram stok dan flow (stock and flow diagram).

Dengan menghubungkan kata-kata dengan tanda panah, keterkaitan antar variabel
sistem dimasukan dan dicatat sebagai hubungan kausal. Informasi ini digunakan oleh
Equation Editor untuk membantu Anda membentuk model simulasi yang lengkap.
Anda dapat menganalisis model yang telah Anda buat melalui proses building,
melihat pada penyebab dan penggunaan suatu variabel, dan juga pada loop yang
melibatkan variabel. Ketika anda membangun suatu model yang dapat disimulasikan,
Vensim PLE menyediakan perangkat untuk mengeksplorasi perilaku model.



























Lukmanulhakim Almamalik 2

Tutorial Pengenalan Vensim PLE
Memulai Software Vensim
Tujuan tutorial ini adalah untuk membantu Anda mengenal software Vensim PLE.
Program Vensim yang digunakan dalam tutorial ini adalah Vensim PLE v.51.b
untuk versi PC IBM-Compatible.

Fitur Utama
Vensim PLE menggunakan suatu interface (antarmuka) yang mirip dengan sebuah
meja kerja (workbench) dan sekumpulan perangkat (tools). J endela utama Vensim
PLE adalah meja kerja (workbench), yang selalu mengikutkan Title Bar, Menu,
Main Toolbar, dan Analysis tools.

Ketika pertama kali Anda membuka program Vensim PLE pada komputer, maka
pada layar seharusnya akan tampak Fitur Utama Vensim PLE seperti gambar di
bawah ini.




Sketch Tools dan Status Bar juga akan muncul ketika Vensim PLE mempunyai
suatu model dalam keadaan terbuka.


Memulai Suatu Model Baru
Untuk memulai suatu model baru, klik menu File dan pilih New Model.
Akan muncul kotak dialog Model Setting use info/Skech to set initial value
seperti gambar di bawah ini.

Lukmanulhakim Almamalik 3

Tutorial Pengenalan Vensim PLE



Kemudian klik tombol OK (tanpa harus memperhatikan terlebih dahulu
parameter-parameter yang ada pada kotak dialog tersebut). Tampilan utama
Vensim PLE sekarang akan tampak seperti gambar di bawah ini.



Title Bar Menu Sketch Tools Main Toolbar


Output File
Window
Analysis Tools
Build (Sketch) Window
(Lembar Kerja)
Status Bar


Lukmanulhakim Almamalik 4

Tutorial Pengenalan Vensim PLE
Title Bar
Title Bar memperlihatkan dua item penting, yaitu: model Vensim yang sedang
dibuka (misalkan, contoh.mdl) dan variabel workbench (misalkan, t abungan),
seperti tampak pada gambar di bawah ini.



Variabel Workbench merupakan variabel dalam suatu model yang telah anda pilih
dan ingin anda dapatkan informasinya lebih lanjut, misalkan bagaimana perilaku
dinamika variabel tersebut. Variabel Workbench dapat anda pilih dengan cara
mengklik dua kali tombol kiri mouse pada suatu variabel yang anda pilih atau dengan
menggunakan Variable Selection Control di Control Panel.


Menu


Menu File terdiri dari fungsi-fungsi umum seperti Open Model, Save, dll.
Menu Edit membolehkan anda untuk menyalin dan menempatkan (paste) bagian
dari model. Anda juga dapat mencari suatu variabel dalam model.
Menu View mempunyai pilihan untuk memanipulasi sketsa model.
Menu Model menyediakan akses pada Simulation Control dan dialog Time
Bound, fitur pengecekkan model, dan menimpor dan mengekspor dataset.
Menu Options menset pilihan global Vensim PLE.
Menu Windows membolehkan anda untuk berpindah diantara window-window
yang terbuka.
Menu Help menyediakan akses informasi Vensim PLE.

Beberapa aspek penting dari Vensim PLE yang hanya dapat dikendalikan dengan
menggunakan item-item menu. Daftar berikut memperlihatkan beberapa pilihan
menu yang berguna:
Edit: Submenu Find pada menu ini dapat digunakan untuk menelusuri ke bawah
semua variabel yang ada dalam suatu sketsa model. View: Submenu Refresh
menampilkan kembali tampilan terbaru layar komputer.
Model: Settings>Time Bounds tab menampilkan ulang dialog Time Bounds
for Model yang ditampilkan ketika anda mulai membuat suatu model. Gunakan
dialog ini untuk mengubah time bounds variables (INITIAL TIME, FINAL
TIME, TIME STEP, SAVEPER, and units for time).
Options: J ika anda secara terus-menerus mempunyai tampilan trash pada layar
komputer anda, kemudian pilih opsi Continually Refresh Sketches. Hal ini
seharusnya menghilangkan masalah, akan tetapi mungkin akan memperlambat
tampilan gerakan sketsa. J ika anda tidak menceritakan perbedaan bagian kurva
ketika anda mencetak lebih dari satu kurva pada grafik yang sama, kemudian
pilih Show Line Markers on Graph Lines agar masing-masing kurva ditandai
dengan nomor yang berbeda.
Help: merupakan menu untuk mendapatkan informasi lanjut tentang Vensim
PLE.

Lukmanulhakim Almamalik 5

Tutorial Pengenalan Vensim PLE
Main Toolbar
The Main Toolbar menyediakan tombol-tombol yang umumnya digunakan dalam
item menu dan fitur simulasi.



Tombol Keterangan

New Model: Membuat baru suatu model Vensim.

Open Model: Membuka model Vensim yang sudah ada.

Save: Menyimpan model Vensim dengan nama file yang sudah
ada.


Print: Mencetak sketsa objek kerja seluruhnya atau hanya
yang dipilih yang ada di Build Window (Lembar Kerja).

Cut: Memotong atau menghilangkan sketsa objek kerja yang
dipilih ke dalam Windows Clipboard.

Copy: Menyalin sketsa objek kerja yang dipilih ke dalam
Windows Clipboard.

Paste: Menempelkan sketsa objek kerja yang dipilih dari
Windows Clipboard ke sketsa Lembar Kerja.

Set up a Simulation: Menyoroti konstanta dan mengamati
sketsa objek kerja di Lembar Kerja.

Name the Simulation to be Made: Dataset yang dipilih
diperlihatkan pada kotak. Untuk mengubahnya, klik pada kotak
vertikal ke sebelah kanan kotak.

Run a Simulation: Melakukan simulasi model. J ika dataset
yang diperlihatkan pada kotak ke sebelah kanan dari tombol ini
sudah ada, anda akan ditanya apakah anda akan menimpanya.

Automatically simulate on change (SyntheSim): Suatu
pendekatan simulasi analisis sensitivitas visual lawan perubahan,
perhitungan, dan pendekatan tinjauan.

Run Reality Checks: Membolehkan pengguna untuk membuat
pernyataan lebih dahulu agar menjadi benar tentang suatu model
sehingga model menjadi bermanfaat, dan menyediakan alat
untuk menguji secara otomatis suatu model agar sesuai dengan
pernyataan tersebut.

Build Windows - show/circulate: membuat objek hasil kerja
menjadi lebih visibel.

Output Windows - show/circulate: Membuat Output Windows
menajdi visibel. J ika output tersebut visible, edarkan Output
Windows aktif.


Control Panel: Memperlihatkan Panel Kontrol. Ini digunakan
untuk memilih variable Workbench, menyesuaikan sumbu waktu
untuk grafik, mengelola dataset, dan membuat/mengelola grafik
umum.
Lukmanulhakim Almamalik 6

Tutorial Pengenalan Vensim PLE

Build Window (Lembar Kerja)
Build Window (lembar kerja) digunakan untuk membuat model dalam Vensim PLE.
Build Window selalu muncul dengan Sketch Tools untuk membuat sketsa model atau
menulis persamaan. Status Bar menyediakan tombol-tombol fungsi untuk mengubah
dan memodifikasi sketsa.

Sketch Tools



Tombol Keterangan

Lock Sketch: Mengunci Sketsa. Pointer Move/Size dapat
memilih objek sketsa dan variable workbench akan tetapi tidak
dapat memindahkan objek sketsa.

Move/Size Words and Arrows (Pointer): Memindahkan,
mengubah ukuran, dan memilih objek sketsa dalam lembar
kerja. Memindahkan suatu objek dengan menggerakkan objek
tersebut dengan poiter Hand Move/Size.

Variable - Auxiliary/constant: Membuat variabel (Konstanta,
Auxiliary, etc.) pada lembar kerja.

Box Variable - Level: Membuat variabel dengan kotak pada
lembar kerja (digunakan untuk Level/Stock).

Arrow: Membuat panah lurus atau melengkung pada lembar
kerja. Klik pada variable asal, dan kemudian gerakkan pointer
panah ke variabel tujuan dan klik kembali untuk membuat
suatu panah dengan garis-lurus.

Rate: Membuat konstruksi Rate (Flow) pada Lembar Kerja,
terdiri dari bagian pipa tegaklurus, suatu valve, jika perlu,
sumber atau sink (awan).

Shadow Variable: Menambah suatu variabel model yang
sudah ada ke sketsa di Lembar Kerja sebagai variabel shadow
(tanpa menambah penyebabnya).

Sketch Comment: Menambah komentar dan gambar pada
sketsa di Lembar Kerja. Klik tempat anda ingin menempatkan
komentar sketsa, dan suatu kota dialog akan muncul dengan
banyak pilihan untuk membentuk komentar.

Delete: Menghilangkan struktur, variabel, atau komentar dari
sketsa dalam lembar kerja.

Equations: Membuat dan mengedit model menggunakan
Editor Persamaan.





Lukmanulhakim Almamalik 7

Tutorial Pengenalan Vensim PLE

Status Bar
Status Bar memperlihatkan kondisi sketsa dan objek dalam sketsa. Status Bar
mengandung tombol-tombol untuk mengubah kondisi objek yang dipilih, dan
memindahkan tampilan (view) lain dalam berbagai jenis tampilan model.



Tombol Keterangan

Set fonts on selected vars: Mengubah jenis huruf
variabel yang dipilih.

Set size on selected vars: Mengubah ukuran huruf pada
variabel yang dipilih.

Set bold on selected vars: Mengubah ketebalan huruf
pada variabel yang dipilih.

Set italic on selected vars: Mengubah kemiringan
huruf pada variabel yang dipilih.

Set underline on selected vars: Mengubah
penambahan garis bawah huruf pada variabel yang
dipilih.

Set strikethrough on selected vars: Mengubah penam-
bahan garis tengah huruf pada variabel yang dipilih.

Set color on selected vars: Mengubah warna pada
variabel yang dipilih.

Set box color on selected vars: Mengubah warna kotak
pada variabel yang dipilih.

Set surround shape on selected vars: Mengubah
bentuk bangun pada variabel yang dipilih.

Set text position on selected vars: Mengubah posisi
teks pada variabel yang dipilih.

Set color on selected arrows: Memilih suatu panah
dengan mengklik pegangannya (lingkaran kecil). Pilih
panah multiple dengan menggeser melewati mereka
dengan tool pointer Move/Size.

Set arrow width on selected arrows: Ini digunakan
untuk mengatur ketebalan garis.

Set polarity on selected arrows: Gunakan tool ini
untuk menandai panah pada diagram simpal kausal.

Push the highlighted words to the background: Ini
berguna jika anda membuat suatu komentar yang lebih
besar dengan tool sketsa komentar yang melengkapi
satu atau lebih variable model




Lukmanulhakim Almamalik 8

Tutorial Pengenalan Vensim PLE
Output Window
Output window ditampilkan dengan mengklik pada salah satu tombol Analysis
tools (tool analisis). Tool analisis mendapatkan informasi dari model dan
menampilkan informasi tersebut dalam suatu jendela sebagai diagram, grafik, atau
teks, bergantung pada perangkat tertentu yang dipilih. Beberapa jendela dapat dibuka
secara simultan (bersamaan), dan suatu jendela tertentu dapat ditutup secara sendiri
dengan mengklik tombol Close pada sudut kiri atas atau sudut kanan atas, dan
seluruh jendela dapat ditutup dengan segera menggunakan item menu
Windows>Close All Output.

Analysis Tools
Tool analisis digunakan untuk memperlihatkan informasi tentang variabel
workbench, baik tempat atau nilainya dalam model, atau perilakunya dari dataset
simulasi.

Tombol Keterangan

Causes Tree: Membuat representasi grafik tiga-jenis yang
memperlihatkan penyebab dari variabel workbench.

Uses Tree: Membuat representasi grafik tiga-jenis yang
memperlihatkan penggunaan dari variabel workbench.

Loops: Memperlihatkan daftar dari semua loop balikan yang
melewati variabel workbench.

Document: Memperlihatkan persamaan, definisi, dan satuan
pengukuran model.

Causes Strip: Memperlihatkan grafik dalam bentuk potongan
untuk variabel workbench dan penyebabnya, yang memboleh-
kan anda untuk menelusuri kausalitas dengan memperlihatkan
penyebab langsung dari variabel workbench.

Graph: Memperlihatkan suatu grafik untuk variabel
workbench dalam suatu grafik yang lebih besar daripada
Causes Strip.

Table: Membangkitkan suatu tabel nilai bagi variabel
workbench yang ditampilkan dalam bentuk baris.

Table Time Down: Membangkitkan suatu tabel nilai bagi
variabel workbench yang ditampilkan dalam bentuk kolom.

Runs Compare: Membandingkan seluruh Lookups dan
Konstanta dalam pemasukkan dataset pertama kali ke dalam
dataset yang kedua.

Output Tool Analisis
Mengklik pada suatu fungsi tombol perangkat analisis akan menampilkan suatu
jendela baru dengan format keluaran (output), kecuali untuk perangkat tabel dan
dokumen, yang menambah informasi pada beberapa keluaran (output) jendela tabel
atau dokumen yang telah ada. Output suatu perangkat akan tetap muncul dalam layar
komputer sampai anda menghilangkannya, dan tidak akan diperbaiki sampai
perubahan dibuat pada model.

Contoh output tool analisis untuk tampilan grafik.
Lukmanulhakim Almamalik 9

Tutorial Pengenalan Vensim PLE

Close
Close P Padlock rint Export Maximize Save



J ika anda mengubah suatu model atau membuat suatu dataset baru, anda
dapat menghapus output lama dengan mudah dan cepat dengan mengklik
salah satu tombol Close pada sudut kiri atau kanan atas.
Anda dapat menghapus semua output dengan memilih item menu
Window>Close All Output.
Anda dapat mempertahankan output window agar tidak ditutup dengan
mengklik tombol Padlock pada sisi kiri atas. Mengklik kembali Padlock akan
membuka window.
Isi window output dapat dicetak dengan mengklik tombol Print.
Anda dapat menyimpan informasi output window secara permanen dengan
menklik baik tombol Save atau tombol Export sementara output window
sedang aktif.
Tombol Maximize mengubah ukuran tampilan window antara normal dan
maksimal.



Control Panel
Panel Kontrol membolehkan anda untuk mengubah nilai setting awal yang mengatur
operasi Vensim PLE, seperti variabel workbench mana yang dipilih atau Dataset
yang dimasukkan. Buka panel kontrol dengan mengklik pada tombol Control Panel
di Main Toolbar, atau dengan memilih item menu Windows>Control Panel. Grup
panel kontrol mengatur dalam lima folder seperti gambar di bawah ini.

Lukmanulhakim Almamalik 10

Tutorial Pengenalan Vensim PLE


Variable Selection, membolehkan anda memilih suatu variabel sebagai
variabel workbench.
Time Axis, membolehkan anda untuk mengubah atau focus perioda waktu
pada waktu tool analisis beroperasi.
Scaling, membolehkan anda mengubah skala output grafik.
Datasets, membolehkan anda untuk me-load, atau mengubah urutan dataset
yang disimpan.
Graphs, membesarkan Pengaturan Umum Grafik.
Lukmanulhakim Almamalik 11